Android App (1.7)

Are there any functional (user facing) changes in the updated android mobile app? (Other than the cosmetic of larger fonts.)

Thanks
Gary

Not sure. I do see that value tiles can show decimals now.

Yeah! Release notes should be posted today. Check out our new Hello, Home Widget.

2 Likes

dang tyler, you’re always one step ahead of me.

Some of my custom device types are not displaying all the information after I upgraded.

Aeon Smart Energy Switch with Cost for example stopped displaying cost.

1 Like

@April, @tyler,

The 2 custom devices that I created are not displaying the info provided.
My ecobee device actually crashes at load time.

Although, I mostly use value tiles, and some standard tiles in the UI.

Are there any new limits/constraints we should be aware of as developers?

Let us know ASAP as there are many ST users out there who use custom devices…

https://github.com/yracine/device-type.myecobee/blob/master/ecobee.devicetype.groovy

https://github.com/yracine/device-type.myneurio.groovy/blob/master/neurio.devicetype

I sent this over to our Android team. I’ll let you know what they say.

1 Like

None of my IP camera devices are showing pictures anymore, and one of them crashes when I load the device page (no logging). Anything changed with how pictures are accessed?

Thanks!

Tyler…Where is this located?

New Features:
Added Hub Updates

It appears the ability to re-name an existing mode is gone. You can delete it, but you can non rename it from what I see…Can you confirm this?

1 Like

Not sure that’s a bad thing, things have gone all sorts of pear shaped for me when I’ve renamed the modes…

Looks like “unoffical” custom Nest integration suggested by Smartthings Support is broken with this App version. Tiles still show but when you select them to make adjustments they crash. Works fine with previous App version but overall 1.7 is FAR more stable and better than previous in all other ways I can tell so far.

Now all of a sudden the APP is crashing when I try to view the status with in my device.

Other than the crashing of the APP on custom device types the improvements seem nice.

After updating to 1.7 it thought I didn’t have a hub already set up. Before I realized it I had another hub created. I had to delete it from the IDE.

I have 10 motion devices but the 10th one gets truncated in the dashboard and scrolling doesn’t work. It worked in the previous version.

Anyone know how to revert back to the previous version?

@April it is faster, yey!

But also getting the custom device failures when you try to load a group things view with a custom device. The easy way to reproduce the bug is to use this device type https://github.com/SANdood/Aeon-HEM-v2/blob/master/Aeon%20HEMv2.groovy

2 Likes

all my custom devices are doing fine, and I’ve got lots of them, and many are serious hacks…

Yeah, it’s the ones that use colors from values in certain ways

1 Like