Ambient Weather V6 Reporting Motion Detection with WS-2902c?

Just installed my Ambient Weather WS-2902c and integrated it into ST using Kurt Sanders’s app and device handler. For some reason, one of the parameters reports ‘motion’, but there is no motion detector on aWS-2902c. Anyone have a similar issue, and how did you correct it (or what have I done wrong :slight_smile: )?

P.S>: I think Motion detection is actually Wind, how can I correct this?

1 Like

Yes, motion sensor is for wind state, and water sensor is for rain state. All of these and so much other information is documented in the Ambient Weather GitHub Readme

  • Temperature Measurement
  • Relative Humidity Measurement
  • Illuminance Measurement
  • Water Sensor
  • Ultraviolet Index
  • Sensor
  • Refresh
  • Battery
  • Wind Motion Sensor (Active = Wind Speed > 0)
  • Wind Speed ‘Psuedo’ Capabilities for display in 3rd party applications
    • “Power Meter” (Wind Speed)
    • “Energy Meter” (Wind Speed)
1 Like

Thanks for the reply. Yes, i did read your document and it helped a lot. Is there anyway to change the wind from a motion sensor to ? As it sets off an intrusion alarm in STHM when armed and there is wind. Thanks again.

1 Like

No problem. You can configure STHM to only use/report specific motion/water sensors, rather than select all sensors.

The settings are under the gear icon in STHM > at the top of the mobile display list. Select the ‘>’ and then ‘Security’, Set up Armed (Away/Stay) sensors, and then deselect the ‘Use all open/closed sensors’ and select all but those with which you wish to ignore, like Ambient Weather Station. Make sure you do this for Away and Stay STHM modes and Leak Detectors.

Thanks for the reply. Yes, I did disable the the motion detector and leak detectors.

I know this is deprecated now, but does it still work for now or at least until ST nix’es Groovy? I’ve been literally waiting on buying this weather station for like 4 months until after the holidays. :confused:

It’s working great for me. As stated above, you’ll have to turn off sthm motion for the device as it goes off every time there is wind.