Amazon Fire 7 and SmartThings (Samsung login, Silk, Chrome?)

I really had no issues getting it to work. In fact not only didnit work but ifactory reset it and did it a second time to make sure.

Ill edit this post later and see if i can give you a step by step.

Hi Allan,
Please let me know if you can. Many users seem to be having this issue.

If I’m understanding the thread I linked to, it seems to depend on whether or not you had a SmartThings account before they instituted the separate, but linked, Samsung account.

Users with ST accounts were able to load the login page with silk as the default browser.

Users with Samsung accounts (all new users after a certain point) were not.

It’s certainly possible I misunderstood. @vseven did you use a ST or Samsung account to login?

1 Like

Please take a moment to check out ActionTiles ($23.99 after 14 day free trial) as it is very popular alternative web browser based dashboard (custom dashboard Panel builder with secure sharing) for SmartThings that runs great on Amazon. Fire.


Terry has a great point. The user interface of the ST app overall is pretty bad, and if your goal is to use several tablets to control devices or check the status of sensors, ActionTiles is probably a much better solution.

I have ActionTiles installed on a 5th gen Fire (that I rooted and installed cyanogenmod on but for this purpose that’s irrelevant) and as a dashboard for my living room it’s great.

I also setup a different dashboard for my iPhone. You can create an unlimited number of dashboards as long as they’re all tied to one ST location. Once I had ActionTiles setup, my actual use of the ST app plummeted to almost nothing.

I sound like a paid spokesperson. I swear I’m not :grin:

1 Like

Hrmm…I didn’t even think of that. I have a SmartThings account I believe. Although after trying to use SmartThings on my tablet I ended up switching to ActionTiles. It reacts just as fast as the SmartThings app (which logicaly didn’t make sense to me…) and I could customize it to look how I wanted, overall worth the $24: Replaced My Existing Security Panel with Konnected Security - My Writeup

Could you add a new user to your SmartThings account and login with that one? Or is it a date the hub was added issue?

1 Like

I have both a smart things and Samsung account.

It seems to still redirect to the Samsung account page. Could this maybe be a version of the ST app that dictates the redirect?

Hrmmm…thats a good question. I suppose you can follow the instructions here: Smartthings 2.6.1 for Android issue then in the step for downloading the APK go to and find a old SmartThings app, install it, try logging in with it and if it works once you are logged in try updating.

1 Like

So the bad news is I tried with both version 2.5 and 2.4 with no luck. It seems that the login page has been redirected to the Samsung account login rather than the ST.

If ST won’t fix it to go back to the original login it doesnt seem we will be able to get it working again

This “hardcoding” to require Chrome to login to their own App should definitely be considered a SmartThings bug; except they can certainly make the excuse that FireOS isn’t supported.

Still… Be sure to contact and mention this in a Play Store review, as we’ve been told this increases the likelihood of attention from ST.

Of course I hope that ActionTiles helps you make good use of these tablets to view and control your Things; but having the full SmartThings App concurrently available for adding Things, SmartApps, SHM alerts, etc. would also be valuable.


Thanks everyone for the input.

Sadly nothing I have done has worked. I hope ST reverts back to using the ST login or makes the ST app native to the Fire Tablets. I have emailed support and posted queries on both product pages.

Ive installed Home Remote as a work around for now. But I will certainly look at actiontiles as an option.


I just recently set up a Fire 7 with the Fully browser and ActionTiles. And I’m really happy with the results. I definitely would recommend it.


I have Fire 7 (Ads removed), Fully Browser and Action Tiles all great BUT I have to swipe away the Amazon home screen which then brings up Fully Browser. Is there a way to have Fully Browser there all the time? Thanks

I simply use FireFox with a “Run on startup” app to start it along with a FireFox add-on that makes it run full screen. I disabled the lock screen using the developer options (setttings -> about tablet -> click on your serial number 7 - 9 times to enable developer mode, then disable screen from locking). See here for more info: Post 24 of my Konnected Writeup

Only time I ever have to unlock my screen is if I reboot the tablet which isn’t often at all.

1 Like

At the moment, I still get the lock screen far too frequently and haven’t determined the cause (running Fire HD8 with Fully and tablet always powered, lock while powered is disabled). I suspect notifications?

Maybe but I know I get the standard google play “xxxx has been updated” without it locking. Just got a couple weather alerts for my area in the last week that didn’t lock it either. Every once in a while it won’t be in full screen but that’s a easy fix and its maybe once a week so I haven’t bothered to troubleshoot it.

Im running the fire 7 tablets with play store sideloaded with the ST app. Ive also got mine permanently on power and have no issues once the lock screen is disabled on power. I also get the notifications in the top bar, but it doesnt force the screen to go to lock.

Are you sure you have disabled lock on power in the developer options?

1 Like

I take it ads/no ads version of the tablet does not matter?

having ads if I remember correctly, forces the lock screen after a certain amount of time in order to show the ads. So if you are looking at using them specifically for this, you might want to get the ad free versions.

There is also any easy way around the ads. When you run the setup for the fire, dont sign into your account. This will stop the ads, but at the same time, disable a good portion of the nice to have stuff on the tablet. Prime video etc. But if your objective is solely to use them as pads for lights/automation, this should fix your issue.

Once you turn on the developer options there is a setting to never lock the tablet. This effectively disables the local screen from coming back up until you reboot the tablet. I haven’t seen the lock screen on mine in over a month, last time I updated and rebooted it.

1 Like