Amazon Echo

Gerri, I’ll have to wait until Monday to test if my dimable virt fan switch is working correctly.

Ok, thx. I just read that on ST. How long has it been broken?

It’s the name of one of our news reporters reportersh here in Sacramento. I’ve had to change the channel more than once… Lol

How are you controlling HH using Alexa without using virtual switches?

I have this working using IFTTT as a “man in the middle” protocol. It’s working really well.

I can turn on the TV to Netflix on Roku, I can shift from Roku to cable or the DVD player, I can turn off the whole entertainment system.

It works because one IFTTT trigger can trigger multiple events.

So I have one virtual switch which represents the TV coming on. When it is turned off it triggers my harmony power off activity, and it also turns off all my other entertainment system virtual switches using one IFTTT recipe for each off.

Then I have one virtual switch to turn on each harmony activity. And additional recipes so that as each entertainment device comes on, I turn off the virtual switches for the other entertainment devices.

So if I say “Alexa, turn Roku on,” The virtual switch for power comes on, the virtual switch for Roku comes on, the harmony activity for watch Roku is triggered, the virtual switch for cable goes off, and the virtual switch for DVD goes off.

Then while I’m watching Roku, if I decide I want to switch to cable, I say “Alexa, turn cable on.” The virtual switch for power gets the on request but it’s already on so nothing happens there. Virtual switch for cable comes on, the harmony activity to watch cable is triggered, virtual switch for Roku goes off, and the virtual switch for DVD gets the offer quest, but it’s already off, so again nothing happens there.

Ultimately, I say “Alexa, turn tv off.” And the virtual switch for power is turned off, the virtual switch for cable is turned off, the virtual switch for Roku is turned off, The virtual switch for DVD is turned off, and the harmony activity to turn power off is triggered.

So three harmony-controlled devices (TV with cable, Roku, and DVD), four virtual switches because there is one additional switch for the power on/power off condition, and a bunch of IFTTT recipes.

Everything happens in one or two seconds, I can use natural language, and it works great. I’m really happy with it. :sunglasses:

I can confirm that at some point in adding the new echo integration, the IP address for a hue bridge that was previously connected is zeroed out in both the smartthings mobile app and in the echo official app causing Any bulbs that are connected to that bridge to then be uncontrollable from either smartthings or echo, although they will still be controllable from the native Hue app.

It’s an easy fix, you basically just have to re-discover the Hue bridge from both the smartthings side and the echo side. After that everything works OK again.

I have added instructions for this fix as step 11 in the community FAQ:

I did so many different things with echo today that I’m not sure at what point in the process this happened but it definitely happened.

@tgauchat @ben @tyler

1 Like

@hscox030.

I am am only using it for HH actions that do not require a mode change. I am just turning a group of lights/switches off and on as needed.

I experienced this exact problem… thanks for describing it so thoroughly.

I “prefer” to have my Hue bulbs on the Echo directly through the Hue Bridge, since it isolates them from SmartThings (pros, cons, … probably balance out).

At the moment, though, since I was unable to get my Echo to “rediscover” the Hue Bulbs after adding SmartThings access to various devices (with some overlap to the Hue Bulbs by accident…), I currently have Echo talking to the Hue Bulbs via SmartThings.

I will try to separate them again sometime. I suppose it isn’t critical, but SmartThings’s control of Hue is still rather shaky in various ways, so that’s why it is nice to isolate the Echo-Hue communication to be direct, instead of adding SmartThings in the middle unnecessarily.

@swindmiller,

I moved my app post to here to not crowd this topic with a smart app…

1 Like

I didn’t have any trouble getting the echo to rediscover the hue bridge.

I have the Hue bridge available to both smartthings and directly to echo. I did not try to authorize any of the bridge-controlled bulbs for echo via smartthings, so from Echo’s point of view they only exist as part of the bridge.

I don’t know if the fix-it sequence makes any difference, as it happens, I rediscovered it from the smartthings side first, and then did a “discover my devices” for Echo. I did press the button on the hue bridge once for smartthings, and then again for echo.

You can see my list has active devices from SmartThings, wink (which is really a link lighting bridge, not a wink hub), and a hue bridge.

Yes great idea and I knew this was an option but i kept holding out hope that ST and Harmony would get their act together and it’s been what seems like a year now. All of the integration I use to this point is from Harmony to ST via virtual switches and it works flawless. When I power off my tv every night, it turns off my virtual switch which puts the house into sleep mode. I never had a driving need to trigger something from ST to Harmony until yesterday :slight_smile:

I did figure out how to fix it eventually. Funny the SmartThings team laughed off the connection to the echo rollout when it was obvious computer science 101.

@JDRoberts, quick question. I am having the “bulb discovery” issue. Will the trick you suggested get around this? I linked my echo to ST and deleted all of the devices that were linked to the Hue bridge because Alexa has trouble seeing GE link bulbs that are linked to the hue bridge. Every one of the link bulbs are dithered out. Any suggestions? Thanks!

I should be aittle clearer. The trick I’m asking about has to do with redusxovering the Hue bridge in ST. Every time I try to do that and finish the integration I get the bulb discovery error

My set up is the other way around: I do not tell echo that the Phillips bulbs are smartthings devices, even though that same Hue bridge is also associated to smartthings through the smartthings mobile app. I let echo control those bulbs only through the Phillips bridge connection to echo. That gives me parallel lines of control which work fine. Echo can control them and smartthings can control them.

Since echo can combine lights from different services in the same group, I get the same result anyway. So I never deleted the Phillips bulbs from Echo.

This is what I did:

One) added the Phillips bridge and its bulbs to smartthings using the smartthings mobile app in the regular way.

  1. added the Phillips bridge and its bulbs to echo using echo “discover devices” in the usual way.

At that point I could control the bulbs from either smartthings or echo, no problem. This was before the new smartthings/echo integration was available.

  1. use the echo app to link smartthings to it using the new integration. When I was given the opportunity to select the specific devices that I would control through echo, I did not select any of the bulbs that were attached to the hue Bridge.

  2. at some point, the IP address for the Hue bridge got zeroed out in both the echo app and the smartthings mobile app. I don’t know exactly when that happened. When it did happen, the IP address showed as zero in the Hue connect smart app under smartthings labs in the smartthings mobile app, and the bulbs attached to that bridge showed as unavailable in the Echo app.

  3. to fix it, I began by simply using the Hue connect smartapp to discover the bridge again. Not the bulbs, but the bridge. This did require pushing the physical button on the hue bridge.

  4. as soon as I got the IP address showing in the Hue connect screen, and I had saved all of that, I then discovered the bulbs attached to that bridge using the Hue connect smart app. I don’t know if that actually did anything or not, I just let it run for a minute or so and then saved it.

So at that point when I opened the Hue connect smartapp through the smart things mobile app, I could see the hue bridge IP address and the names of all my bulbs.

  1. Time to fix things on the echo side. I opened the echo app. I pushed the physical button on the Hue bridge. I chose settings, connected home, and then tapped “discover my devices.” Echo showed the status bar updating, and when it was done, all of my bulbs attached to the hue bridge were again available to echo.

  2. I confirmed that I could reach the bulbs and control them either with an echo voice command, or through the smartthings mobile app things page, and that a group in echo that combined some bulbs from that Hue bridge with a Z wave switch worked fine.

So I never did delete any devices from either echo or smartthings. I just did a Discover on both sides. But I also never tried to define a bulb on a huge bridge as a smartthings device to echo.

FWIW

@JDRoberts I spent some time setting this up tonight and you are right, this works pretty good if you strictly use the Echo. The problem is, if I start using the physical remote, it becomes out of sync because the virtual switches don’t update. If I modify the Harmony activity to turn on/off the virtual switches, I end up with a looping effect because than IFTTT triggers occur and begin powering on and off activities. I realize you might only use the Echo, but was wondering if you had any ideas on how to resolve this? I am using On/Off Virtual Devices, not the Momentary ones.

I had a set up which took care of this (my housemate uses the physical remote), but just today there was a harmony firmware update and they have changed the way their IFTTT channel works. You can now only issue an end activity for the current activity. That breaks a lot of my set up. So I’m having to redo a bunch of recipes.

The good news is that the new set up should take care of any issues getting out of sync when you sometimes use the physical remote and sometimes use voice. But it means you have to set up an activity whose only purpose is to substitute for the “all off” power button. And you have to have two momentary switches for that exit activity. And all the other activities have to be momentary buttons.

The end result will be fine, but it’s going to be a lot of work to redo everything for me.

Detailed discussion in the harmony topic:

Thanks…I didn’t receive a firmware update. I am on 4.6.71, what are you on? Anyway, I am confused now on how to set this up? I see you switched to Momentery tiles. Can you provide screenshots of your config for perhaps one of your activities?

With screenshots:

Thanks. Looks simple enough now, but the problem is there is an issue between IFTTT and Harmony and it keeps saying my hub is offline, when it’s really not.