Amazon Echo not discovering anything

Hi all, very new to home automation but loved how easy ST has made things. I have (all zwave) two GE appliance outlets and a GE dimmer switch which work flawlessly in the ST app. I also have an Echo which I have linked to my ST account and all my devices show up. However, when I tell the Alexa app to discover devices it says “Connected home not enabled yet. Enable it by adding your smarthome devices.” If I verbally tell Alexa to discover new devices it says that I need to wait 1-2 hours. Any ideas guys? I’ve tried unblinking/linking accounts a few times and rebooted the Echo and ST hub.

tl;dr : Cannot get Amazon Echo to discover my devices.

I assume that you linked your Smartthings Hub with your echo? If you had try unlink then link back. In the future anytime you add a new device you need to unlink then link back to authorize those devices. You don’t have to delete the devices or groups on echo to do that.

Hi greencat, yes, all linked up. I see it linked in the Alexa app and the ST app shows Echo as a smartapp. All three devices I have are listed and authorized. Still no luck yet.

This might help:

Hi there! This is the exact guide I followed to get my accounts linked up. Clicking discover devices or telling Alexa to discover doesn’t work. If I could at least see my devices listed I could probably troubleshoot further.

Do you have US accounts for both smartthings and Amazon?

Yes, US accounts for both.

OK, can you take a screenshot of your echo app so we can see what’s in it after you click on settings and then connected home. Scroll down to the services section.

I updated my original post with a screenshot. Let me know if you can’t see it and I’ll attach another one. The screenshot is what I see after I click discover devices, the error is at the top.

OK, it’s saying that the authorization didn’t complete on the smartthings side.

Open your SmartThings mobile app.

Choose rooms view (icon with four little squares on the bottom of the page), then smart apps.

Find the Amazon Echo smartapp and open it.

The next page will show the list of devices you have authorized to echo. If there are any there, just follow that wizards directions and authorize some. Remember to click next at the top right of the page when you finish.


I’m fairly sure it’s set up on that end also, but attaching screenshots:

Weird. That does look OK.

There was an echo app updates of days ago, is your app up-to-date? Otherwise I think you just need to get in touch with Amazon support.

Sorry I can’t help more.

Yep, all apps up to date. Definitely appreciate all the help you’ve given. I’ll try to get in touch with Amazon later. If they provide a solution I’ll update the thread here.

1 Like

I thought this also but you don’t actually need to unlink to add devices. To add new device just open the Echo Smart App in the SmartThings Mobil app and add new devices there. Then open your Echo App and select support->home automation-> discover new devices.

No delete, exclude nor unlink needed.


If you start from the official echo app, do you need to unlink and relink in order to authorize more devices.

If you start from the official smartthings mobile app, and open the echo smartapp there, then you do not need to unlink. Just add more devices to that list.

You need to do the Discover in either case.

Hey all, just an update. I finally got this working, and of course – user error, sort of. My Echo had not received any updates for probably 4-5 months because I have firmware updates for Amazon devices blocked at my router. I found an Amazon article stating what the latest firmware was and mine was far behind so I took a chance and removed the blocks to allow the Echo to update. Sure enough it discovered all my devices:

tl;dr : I got it working

1 Like


My Echo is also not finding all my devices, although they are enabled in SmartThings for Alexa to discover them
Can you please send me the link on how to unlock the router (port, protocol, etc) to allow for updates?

Having the same issue here. Recently got a Harmony elite remote and hub. Linked it with smartthings and thru that my echo. At first all my harmony activities showed up in the alexa smartapp, I authorized them there then discovered them on the alexa app. So far so good but she apparently she got confused because “watch tv” was too similar to “fire tv”. So I went into the harmony app and changed “watch tv” to “cable”. The edit shows up on the smartthings harmony app , I saved the changes there but when I go into the alexa smartapp they’re not there. I tried uninstalling the alexa and harmony smart apps them reinstalling, unlinked echo from smartthings then relinking all to no avail. Smarttings won’t let me delete harmony activities that no longer exist either. I ended up using IFTTT to link alexa to harmony for voice control and it works great . IFTTT immediately sees all the harmony updates on its app but the ifttt smartapp doesn’t.


When you renamed the harmony activity, did you go into the Amazon echo smartapp (inside of the ST mobile app) and reauthorize it with Alexa?

I tried but even though I first went into the harmony smartapp and authorized them there the edited or added harmony activities don’t show up in the echo smartapp. Its weird as they show up in the native harmony app and the ifttt app and the harmony smartapp but somehow it’s list in translation to the rest of smartthings.