SmartThings Community

Amazon Alexa Integration - STOPPED working (25 September 2018)


(Dave Gutheinz) #1

The Amazon Alexa Integration withe SmartThings stopped 24 hours ago.

  1. All devices were listed as offline.
  2. Tried a re-install to no avail.

DaveGut


#2

Same here, and I have a ticket open with support (haven’t back yet…).

I suggest you notify support as well. Can you still control devices through Alexa even though they’re offline? I can, but I also can add any of my new devices I just recently included to my hub.


(Benji) #3

If you’re in Europe there was apparently an Amazon outage. SmartThings also noticed an outage in Europe, since they’re hosted on AWS as well, it’s probably all related.


(Dave Gutheinz) #4

Already notified. Just wanted to see if others were having same problem. I could not control via Amazon.

Just tried - still broken. Have temporarily converted to Hubitat integration. May be permanent (was a future goal).

Dave


(Benji) #5

Not sure how Hubitat would help you if Amazon themselves were having an outage…


(Dave Gutheinz) #6

Hubitat is working fine with Amazon (no outage at either end. Ported today.


#7

@Gutheinz and @Benji,

Yup, something is up. No word from Support in 2 days, and all my devices in the Alexa app are offline. SO, I removed the app, re-enabled the skill, ran discovery, and now NO devices are even listed.

What a POS. Between this and the crappy new app, and the issues with the recent beta, Hubitat is looking better and better…

@tpmanley - #619657

Oh yeah, now I get the red bar of death message “Error saving page” in the ST Alexa app… Oh yay…

EDIT:

IDE app log shows this:

Live Logging Errors:

6:34:38 PM: error org.springframework.orm.hibernate3.HibernateOptimisticLockingFailureException: Object of class [physicalgraph.app.EventSubscription] with identifier [003070d4-0b26-40ac-9486-3a91bb3cb084]: optimistic locking failed; nested exception is org.hibernate.StaleObjectStateException: Row was updated or deleted by another transaction (or unsaved-value mapping was incorrect): [physicalgraph.app.EventSubscription#003070d4-0b26-40ac-9486-3a91bb3cb084] @line 5016 (updateSubscriptions)

6:37:06 PM: error java.util.concurrent.TimeoutException: Execution time exceeded 20 app execution seconds: 92648225496399 @line -1 (doCall)

EDIT:

Going to the New app and then Connected Services and then Amazon Alexa, I see the following errors:

In the App:

“Network or server error occurred. Try again later”

Live logging:

After trying to discover devices:


image


(Ron Talley) #8

I can say that Alexa is getting better and better but SmartThings seems to be going in the opposite direction. However, I will say this, I would wait it out for a little before I go uninstalling apps and making a big fuss. These things tend to work themselves out.

I will be on the classic app until I am forced to switch over. From there, I plan to move even more of my HA over to Hubitat. Now, saying all that, Hubitat has its own issues with Alexa. Couldn’t even use Alexa with it without it trying to cut off all of my lights and things that were not part of routines.


#9

Yeah, I know. I’ve been with ST since they were launched in Kickstarter. I’ve been through worse with them, but this is still frustrating.