[Alpha] Lutron Connected Bulb Remote

I’d like to see documentation to that effect because it would be useful.

1 Like

So, I paired another Connected Bulb Remote to my ST hub and then a GE Link bulb. Status in the ST app does seem to update and I can control the bulb from both locations. I did occasionally see a glitch where control from the app wouldn’t work and I’d have to turn it on and then back off with the Lutron remote, but it would then work from the app again.

1 Like

The wink hub has a lutron radio. The smartthings hub does not. :disappointed_relieved: Both have A zigbee radio.

Lutron makes a pico remote on the proprietary Lutron frequency, and the “connected bulb remote” which is a zigbee device. These two remotes look very similar, but are using different frequencies.

Lutron frequency


You can use the pico remote with the wink hub. There is no way to use it directly with a smartthings hub, there’s no radio to communicate with it.

If you have the Lutron smartbridge pro ( which has a Lutron radio), you can set up a raspberry pi as a “man in the middle” and use a pico with smartthings that way. But not directly like you can with a wink.

This thread is about the zigbee device (LCBR). Not the pico.


JdRoberts… Yes you are absolutely correct. I was not trying to imply we could (directly) use the pico with ST (my bad peeps), Was merely stating that it will work with more than just controlling lutron devices, given the right setup, as that specific “branding” of lutron uses ClearConnect as opposed to zigbee… I guess I wasn’t clear on that (although I did try by saying “back in rooted wink days”)

Also unless there has been a change since I was on wink, there is no way (without root) to use the pico for anything on the wink hub other than controlling lutron stuff .

And yes I know this thread is for connected bulb remotes (LCBR) and not Picos… Saw a few mentions and one member state that it(pico) would only work with lutron stuff… In essence that is right, but given the right amount of hacking it’s possible to extend pico functionality…

Also… Haven’t really looked into it but SmartWink (asides from RPi MITM) may be a decent way to use the pico in ST as lutron is already integrated that way (using rooted wink hub). And it’s also a viable way to use the LCBR as a 4 button remote, just needs someone better than me to integrate the LCBR on ST side using that SmartWink setup…

However, if the LCBR can be made to control a virtual bulb in ST that would really help in making it more than a bulb remote.(don’t know how possible this is, but worth the suggestion imho)

So just an update on my progress - the GE Link bulbs definitely work better with the LCBR in SmartThings because the status is correctly synched with the SmartThings app. The Cree Connected bulbs work fine as well in terms of bulb functionality, BUT the status rarely (if ever) updates in the SmartThings app. For people trying to get this to work, here is what I did - the instructions below assume you’re starting with a new Lutron remote and a GE Link or Cree Connected bulb which are not currently paired to an LCBR; obviously, if the remote has previously been paired to a bulb or if the bulb is currently paired to a remote elsewhere in your environment, you might want to reset them both before trying the procedure below.

  1. Install the device handler provided by Sticks18 in post 26.
  2. Pair the bulb to SmartThings using the normal pairing procedure.
  3. Pair the LCBR with SmartThings. Typically, that involved pressing/holding down the top button for a few seconds while the ST hub is searching for the device.
  4. Next, take the LCBR to the lamp/fixture with the bulb you paired in step #2. Pair the remote directly to the bulb using Lutron’s instructions (basically, hold the remote within 4 inches of the bulb, hold the top button down for 10 seconds, and the bulb should blink/dim a few times to show it is pairing). Once the pairing is done, ensure that the remote controls the bulb successfully by using it to turn the bulb on and off. If this doesn’t work, try pairing the remote again, ensuring that you hold down the top button a few seconds after the bulb blinking stops.
  5. Assuming the remote controls the bulb, verify that you can still control the bulb with your SmartThings app. If you can control the bulb with both, you’re done. If control from the app doesn’t seem to work, try turning the bulb on and back off with the remote and then try again (see notes below). If it still doesn’t work, unpair everything, reset the bulb and remote, and try again.
  6. To reset the remote, hold both the top and bottom buttons down for 15 seconds. In terms of resetting the bulbs, that generally involves turning the power to the bulb off and on several times with each state (on and off) being active for 1.5 to 3 seconds depending on the manufacturer.

Some notes:

  1. I only assign the remotes on a 1:1 basis to bulbs, so I did not use the SmartApp provided by Sticks18. I did try to use it at first but could never get it working with the Cree bulbs; you only need to use it if you want to try to use 1 remote to control a group of bulbs.
  2. Note that when you control the bulb with the Lutron remote, the bulb’s status in SmartThings seems to only update if you’re using a GE Link bulb. Cree bulbs don’t seem to update their status in the app.
  3. Occasionally, I noticed that if I controlled the bulb with the remote a few times, control from the app would stop working. To resolve this, I usually just had to turn the bulb on and off from the remote once and the app started working again.
  4. At this time, only GE Link and Cree Connected bulbs work using this method.
1 Like

If you are using the code by @sticks18 , that has capability.button which means it should be recognized as a button controller by any smartthings automation that let you assign a button to an action. That would include the official smartlights feature and core.

So if it does work as a button controller, you can use a button press to control anything that smartthings does, including turn on a virtual light.

The only thing is there was a recent platform change and now all these automations require that “number of buttons” also be defined or it will only respond to the first button. I don’t know if @sticks18 updated his code yet to include that or not.

1 Like

I think I love you … I’m going to try this later at home… OMG…YES

Hey, I’m not saying that it works now. Just that if it does work, that’s how it will. :wink:

Let us know how it goes.

Here is a question. Did St ever get groups/multicast/etc figured or working? If I recall correctly, that was part of the issue with not getting this remote to work.


can I use the device handler from post 27 , just to use my lutron remote with smartthings bridge as a button device ?
how shall I pair the remote after installing this device handler ?

also, is there a device handler for Hue living colors remote ? (I ask this because in the lutron device handler I see “Philips Hue Wireless Dimmer” comment.

I was also wondering how, if possible, if we can use the remote as a generic button controller.

I paired the remote with the device handler from sticks18 to SmartThings and then installed the Button Controller app but the buttons do not toggle an appliance plug that I configured the remote to handle.

Thanks @sticks18! I am just trying to pair Cree bulbs with the remote, so I don’t have the Zigbee profile issue, but it’s a huge benefit to be able to do it with an app instead of with the remote-bulb pairing method. I am switching to ST from Wink and I really would rather not unmount my remotes to pair them if I can avoid it.

I resolved this issue by modifying the existing device handler for the GE Link bulb. The “On” function used to just turn the bulb on and it would be at 0%, which sucked - but now now my custom device handler also sets level to 80% automatically inside the “on” method. So now, no matter what - when I turn on the bulb it gets set to 80% even if it was turned off and dimmed by the lutron remote.

Hi, are you able to share the DTH?

Any update on when zigbee group support will be implemented? Will this enable use of the Lutron Connected Bulb Remote as a 4-button controller?

I don’t know why this confuses me so.

I have multiple Osram Lightify RGBW downlights that I am trying to control. So, I’m supposed to:

Pair GE Link bulb to ST
Install Sticks18’s LCBR DH and SmartApp
Pair LCBR to ST
Pair LCBR to GE Link bulb
Where do I get groupID and endpoint? Live Logging no longer shows my GE Bulb.

removed everything using alanrosesf’s instructions.

  1. Installed the GE Link DTH here (mentioned by a few in this thread but the links were dead).
  2. Install sticks18’s Lutron Connected Bulb Remote DTH
  3. Install sticks18’s Lutron smartapp
  4. Pair GE Link bulb to SmartThings
  5. Pair Lutron Connected Bulb Remote to SmartThings
  6. Pair Lutron Connected Bulb Remote to GE Link bulb
  7. While in the SmartThings API site, go to My Devices, click on a few of the bulbs you wish to eventually control and take note of what their endpointId is (located in the Data row; all must be the same, for my Osram Lightify’s they were 03)
  8. Turn off/on GE Link bulb (I did this via the LCBR, not sure if that is necessary though)
  9. In the SmartThings API website, look under Live Logging for your GE Link bulb (mine was now named GE Link Pro) and look for a debug message that contains the endpointID of the bulb, and make note of it.
  10. Open up the Lutron SmartApp
  11. Set your Lutron Remote
  12. Select the GE Link bulb under Select a bulb connected to the remote
  13. Under Zigbee Endpoint of selected bulb, enter the Endpoint ID of the GE Link bulb that you took note of above (mine was 01) and hit return or enter
  14. Go back to the SmartThings API website and look at your GE Link bulb under Live Logging.
  15. Look for a debug message that looks like this:
  16. 622e533a-c29c-49bd-928e-5072244e8e19 11:16:09 PM: debug description is catchall: 0104 0004 01 01 0040 00 F461 01 00 0000 02 01 07016226
  17. In my case, my group ID for Remote was the last 4 digits in the string above (6226, located after 0701). Enter this number in that field in the SmartApp.
  18. Select the bulbs you want to control with. I think there might be another field that you have to enter in the endpointID of said bulbs (the number you took note of earlier). We aren’t talking about the endpointID of the GE Bulb. Again, my Osram LIghtify’s had endpointIDs of 03.

Works now! Thanks


Hi @bgadam were you able to get over the hue’s never showing in ST even after a reset from the lutron remote? I’m seeing the same thing, banging my head against the wall after trying every combination of reset and join possible with the remote, bulb, and ST hub.

I just can’t seem to figure out what my group ID is (Cree bulbs). Can anyone help?
Here is what I see in live logging:

43c25fc8-0788-4328-b238-f1df853fe747 2:08:29 PM: debug description is catchall: 0104 0006 0A 01 0140 00 3624 00 00 0000 01 01 0000001000
43c25fc8-0788-4328-b238-f1df853fe747 2:08:29 PM: debug description is read attr - raw: 36240A00080A0000002001, dni: 3624, endpoint: 0A, cluster: 0008, size: 0A, attrId: 0000, result: success, encoding: 20, value: 01

Wow, this was a long time ago… I think all of my Hue’s are on the Hue
bridge and have been very stable/reliable… otherwise, i don’t remember
how this played out…

Are you on the group ID step or trying to find the endpoint for the Cree bulbs? The two live logging messages you copied are not related to the group ID at all. The message should look like what @eekhelpspike sees in step 16, particularly the second 4 digit section should 0004. You should be able to follow those instructions to get that version of the integration working.