All SmartApp events broken? (May 30, 2018) (subscribed events not triggering automations)


(Convinced ST will never be unbroken…) #21

Why did you migrate away from it?


(Dan) #22

I was thinking the exact same thing! :slight_smile:


#23

Yep, I noticed when I looked at my Grafana dashboard of temperatures / power graphs, and saw that they all flatlined around 4:30am EDT


(Matt) #24

it is nice having local processing but the platform needed a bit of maturing. they have released several firmware updates since then (I was the 1st to get their hub outside the core team) and it worked well but I had some issues with ZWave and there was no harmony support or 3rd party api support at the time.


(Dave N) #25

WebCore dead here at 5:45 when I got up. :frowning:


#26

Well, this is weird. ST Support says no incidents reported. Everything operational.

https://status.smartthings.com/


#27

Lol. I submitted a ticket and within 30 seconds thereafter events started working again :slight_smile:


(Ryan Applegate) #28

Issue has been identified and resolved. Let us know if you continue to experience any issues.


#29

Which was?

An update to the Status would be nice :slight_smile:


(Eric) #30

thanks for submitting that ticket. Clearly that fixed it.


(Andreas A.) #31

The outage for event subscriptions was (barely) less than 6 hours long. Clearly that doesn’t warrant a mention on the status page… :roll_eyes:


#32

FLASH!

The Status page has been updated … sort of … no real meaty info :unamused:

I’ll get the conspiracy-ball rolling:

2:45AM CT: Alien (the unworldy type) beams down to the software engineers’ area and temporarily renders the over-worked engineers unconscious with his super duper mind-mush-rendering ray gun, set on the lowest setting (low mush.)

2:46:05AM CT: Alien witnesses extraneous characters being inserted into some sort of home automation control software as the engineers’ foreheads slam onto their keyboards.

2:48AM CT: Alarmed by the resulting chaos, but mostly fearing the wrath of the ST user community, the alien beams back to his spaceship — but not before scavenging all the pizza, tacos, and energy drinks from the fridge.

9:15AM CT: Software engineers regain consciousness but notice that all hell is breaking loose in the ST world … well, actually just the custon SmartApps … or so they think.

9:45AM CT: Software engineers retrieve the last satisfactory working-version of the control software from their revision control repositories located somewhere in the Ukraine … and all is well again … or so they think.

10:30AM CT: Head software engineer reports in to work, then checks on the status of ST — but is super pissed that there’s no pizza, tacos, or energy drinks in the fridge.


#33

bOs_gzNA_400x400


#34

Hmm… it seems to be broken again…


(Joel) #35

i’m finding all my zigbee motion sensors have suddenly stopped working.

going to try a reset


(Jimmy) #36

Wouldn’t touch them for now. platform issues.


(Joel) #37

thanks. i only reset my hub (soft). gonna wait now - good advice.


(jkp) #38

Some North American users may be experiencing intermittent issues loading and controlling devices in the new and Classic SmartThings apps as well as the developer portal. Our team is investigating and we will provide updates as they are available.
Posted less than a minute ago. May 30, 2018 - 18:38 EDT
https://status.smartthings.com/incidents/xsljd5pb5034


( I hate Mondays) #39

Sorry, got the message 28 days later :frowning: SL is a special case that can actually execute locally, whereas the Lighting Director is a SmartApp that runs in the cloud. Might have been a cloud hiccup, which would explain SL working and LD not.


#40

My c2c connector is not responding to any subscribed events. On changing device state from smartthings app, events are not getting triggered.