All motion sensors just turned into contact sensors during the Edge beta!

for ST use: all the motions that have switched from motion to contact sensors for me and needed to be removed and re added to ST for them to work again were all SmartThings SmartSense Motion Sensors. There was no way for me to select a new driver from within the app because the three dots were not present, nor was the back button to get back to the main screen in the app. If you look in the logs you can see that when motion happens it actually says contact open.

1 Like

I can see where there is potential for confusion at the Zigbee level because contact and motion sensing can both be implemented as IAS alarms. It does seem a leap from there to selecting completely the wrong driver though.

I’d expect you to be able to change to the correct driver because the device fingerprints are there, but it does require you to have that driver installed and I can imagine that might not be the case for you.

We’ve already seen issues where zigbee devices showed up in the app as zwave devices of a completely different device class. :disappointed_relieved: It just needs a typo in the fingerprint that happens to match the fingerprint of a different device.

Of course those then showed no activity. Here I’m sure you’re right that it’s “activity detected” from the device that is then being displayed as Open instead of Motion.

So I did find a workaround a few minutes ago.

I’m already subscribed to ST’s Edge channel (beta) to use the illuminance sensor, so I went back to that channel and enrolled their Zigbee Motion Sensor and then changed a couple to use that new driver. That seemed to have worked, so I’m changing one sensor at a time, but so far so good.

How I did this was to:

  • Find your hub in the mobile app
  • Wait for the device list to load and the three dots in the upper right will be available
  • Select Driver
  • A list of all loaded drivers show up. You will notice Zigbee Motion Sensor is missing
  • Scoll down and look in the section “Channels your hub is registered to”
  • Select SmartThings Drivers (Beta), then tap on Available Drivers
  • From the list that pops up, after you authenticate, select Zigbee Motion Sensor and tap on Install
  • Go back into the app and change Driver and the Zigbee Motion Sensor option should now be there

I also noticed when looking at what was already installed, what ST installed yesterday is now also Installed (except they missed Zigbee Motion Sensor).

3 Likes

Sorry guys. I’m not in the beta group, but thank you all for being in the beta. Wow, what a disaster this would be for me too if I was.

I hope that this problem will now trigger SmartThings to change direction and NOT automatically convert devices from DTH to Edge drivers without some sort of user prompt confirmation in the SmartThings app showing the user what it’s changing, and letting the user ‘accept’ the change, and allowing the user to modify the target device type and then accept the change.

Yes, where I was going was that in this case they should know all the combinations of device and handler that are eligible for migration, and which driver they migrate to. So it just seems it should be a bit harder to select the wrong driver.

1 Like

Okay changed all of my devices to the zigbee motion.

But many of the automations were lost! Had to re-create them

However, any automation that used the old smart lighting as far as I can tell did not loose any rules.

1 Like

Yeah I can see that all automations that used the motion capability of these sensors are still there but have the motion steps totally removed. Guess I’ll have to re-add the motion component for each one whenever I get motion for them again.

Most of mine didn’t require me to do anything believe it or not. As soon as the driver changed to the right one I noticed the automations started working again without any intervention by me except to re-enable them.

2 Likes

Hey Brian, We are deep diving into this again :slight_smile:

After ST migrated your device the second time to the right Zigbee Motion Driver, did you have to go back into the App and manually add the motion steps of your rules back?

Thank you.

I am not sure I follow. When was the “second time?” I went in 2 weeks ago, set each sensor to the right driver, then redid all the routines at that point. I have not touched anything since then, though, which is maybe what you’re hoping for.

Ok thanks, I think I was looking for a different situation than what you described.

Thanks :+1: