All device handlers got broken overnight (3 June 2020)


Yesterday everything was working fine, but this morning my smartthings classic up shows all my devices weird. Only heard functions work, but like the thermostat doesn’t have the mode switch or to set the target temperature it just does the current temperature and a refresh button. See the attached screenshots. I haven’t got the note that my account was moved to the new platform yet and I have quite a few things that I wrote or got from github that I can’t control current anymore. Customer support says they don’t support these device handlers anymore… Which is ridiculous… Why ideas?

Here’s an example of one how it should look like

And he it does now:

For this one the only workaround would be two switches, one for low speed and one for high…

Same, everything is broken (again). Samsung, you really are useless.

I have wrote a custom DTH with a thermostat multi tile and different small ones.
It worked perfectly for me until the recent classic app update.
Now it’s only showing two tiny tiles with no actual function.
The parameters behind are getting updated but not shown in app.
What the heck is up with smartthings mucking up the UI.

I have similar issue with Classic app starting today. All of moisture sensors are now showing as temp sensors, my Alexa and Sonos devices have the blank icons, my Aeotec range extender is now showing up where is hadn’t before.

Hello I have the same issue, and fibaro ubs temperature sensor stopped working … fibaro radiator thermostats same and i can not set them up anyhow becuase they only work on the smartthings classic app, does anyone know a fix ?

1 Like

I just logged in to classic and noticed a mess of things. My alarmdecoder setup is basically blank and some other devices look weird. What the heck happened here

We’re looking into this issue.

1 Like

For me it’s back to normal now.

Great to hear. Things look right on my end as well. Thanks all for bringing this up!

Edit: Here’s a side by side comparison of a broken device page and working one. On the left is a how a custom DTH for a Zigbee fan should look. On the right is what it looked like during the incident. The DTH was essentially “deconstructed” as each of the components was separated into their own tile and all of the tiles were the same size.

Thanks for the fix but you really need better testing before releasing updates! I’ve recently wasted days trying to figure out why certain devices had stopped working correctly (due to the recent 30.3 firmware update) and now this. It’s absolutely shocking, and none of these are niche edge-cases; you keep breaking functionality for very common Z-Wave certified devices!

My hub went offline last night and for thr first time I’m aware of I needed to power cycle. Odd.

Not sure if this is related or not, but last night I realised that I’d stupidly deleted the classic app from my iPhone during a tidy-up, and as I needed it to sort problems out, I tried to reinstall it.

As soon as I log in now, it displays the message “Available countries could not be fetched from the server” as shown below. This seems to persist today - and I get the same on my iPad too.

I’m also back to normal today. I agree with the need for better regression testing fir the classic platform.

This is unrelated to the issue from last night. If you are being prompted to create a location that makes me wonder if you are signing into the right account. Deleting the app wouldn’t remove the location so you shouldn’t need to make a new location.

Out of curiosity, what device is that?!

It’s just the Hampton Bay controller and the King Of Fans Zigbee Fan Controller that a former co-worker modified.

1 Like

Ok, bummer (kind of)… I was hoping you guys had some new device you were testing!

[sorry, as this is unrelated, this is probably wrong place for this now]
Just to check my sanity, I logged off and on again in the new app, and it’s definitely the right account.

However, I seem to have it working again - I changed my login password, and interestingly the old app still insisted on my old password. So I used the “New to SmartThings” option, and logged in from there - and it now works fine. Wish I’d tried that obvious step before! Thanks.

1 Like