All automations gone. Cant add new

So I was on here and found code for a Smart App that I thought I might like. Copied the code etc. Saved. Published. After that, the mobile app has no automations and says I need to add at least 1 location and 1 cloud connected device to create an automation. There is a location and I can control all my devices from the mobile app. The classic app allows me to add automations. Everything seems to work except for adding automations. I’ve tried deleting that smart app. Restarting phone. Uninstalling and reinstalling Smartthings mobile app. Not working. What did I do wrong here? Any help is appreciated.

What smartapp did you attempt to install? Link to the post for it if possible. When you tried to add it to IDE, did you login at or other?

Right now I am confused with some of your post.

That is the app I attempted. I followed the directions exactly in the post (my first attempt at doing this). I went to account.smartthings to do it. Seems like after I went in on the app to set it up, it all went south.

What thermostat do you have?

Go Control Z Wave thermostat

If it does not show in the Automation tab, you may want to look in Marketplace: Smartapps : my apps. I am not familiar with this app but possible you need to open it there for the first time, save your settings and then access it from the Automation tab. If that fails, you should post in the thread you posted above and that way the developer will get notified you posted in their thread and hopefully contact you with answers for you :slight_smile:

Any clue why it wont let me make a new automation. It says I need to add a location and cloud device, but clearly I have that covered.

All your devices are showing in the My Home: Things tab?

They are. And I can control them from both apps. Just cant make a new automation at all.

Best to contact ST support at

You are logging in with the main account and not a guest/shared account?

as far as I know. I never created any other accounts, and did nothing differently.

I don’t have an answer. Maybe someone else can provide you with one.

Ya. I guess I’ll have to do that. Thanks for the help anyway.

I dont use the new app except for one automation, however before today most automations created in classic were visible and adjustable in the new app, now nearly every custom automation has gone from the new app only, my one automation in the new app has also been failing but i dont think its a major issue

I read somewhere in another thread that some backend changes and updates are afoot along with app updates… i think, so dont fret too much hopefully the issues should resolve soon enough

Adam4, hello, my name is Jordan. I’m the developer of Thermostat Manager. Reading over this thread, I tend to agree with Fido and jkp that there must either be a problem in the new SmartThings app’s system or something is going on with your account. While I don’t see anything interesting going on over at (there is an issue related to Ring doorbells going on, however…), not every issue is always visible there. My suggestion would be to contact SmartThings support. They will be able to look at your account and see what is going on. Personally I don’t use the new app so I couldn’t speak to any issues that are specific to it. Although I will say that I have never had any complaints in regards to the new ST app and if Thermostat Manager has some sort of issue with the new app then I will get to work immediately to fix the problem.

FYI, Go Control Z-Wave thermostat is very much in Thermostat Manager’s wheelhouse. Should have no problems there. The only thermostats you might have some problems with could be the Nest or Ecobee smart thermostats as the AI wants to control everything – but even these can be made to play nice.

If there is any thing I can help with just let me know.

1 Like

That’s great to hear, Jmarkwell. Looking around, I’m thinking that using your app did not cause this, as others are having the same issue. I’m sure I’ll get it sorted.

In regards to thermostat manager, I went looking for it because other apps such as “keep me comfortable” do not recognize my thermostat, even though every other part of smartthings does. It says I don’t have a thermostat available. I’m looking forward to trying your app to see if that recognizes it.

Just reloaded thermostat manager. It says I cannot add my GoControl thermostat. There must be something in the way I added it to smartthings that makes it not work. The Goodnight, Goodmorning stuff works just fine though, which is odd. All I really want to do is use a different temp sensor to control the temp rather than the one in the thermostat. Should be a fairly simple thing I would think.

Hey Adam! Having same issues here today with the new app and automations. I can delete them, and if I spam add it will let me create new ones but I cannot edit or turn on/off anything in automations. I haven’t added or changed anything when this started. I was just going in to edit some of the automations I had with my motion sensor.

Update:. Seems to be working fine this morning

I just saw this thread. I am having the same issue and posted it as a bug in the current hub 0.25 BETA test session. Based on this thread, it might not be the firmware upgrade. I also updated my Samsung S7 before I found the automations missing. Did anyone else having this issue, recently update their smart phone?

My phone hasn’t been updated in a week or so. The hub and app has been working great since I got it last week. Just today I started having this issue.