Alexa Voicemonkey Skill

I expect these folks are getting cratered by the increase in account volume. It happens. :scream:

I believe Eric Inovelli said their customer support requests went up like 1000% because of the migration.

Same here.

They will definitely have to charge a fee for this I reckon.

1 Like

This is what Christian said to me:

Unfortunately it’s been happening to a few people and trying to get to the bottom of it.

For now I’m afraid you’ll have to reset:

  • (steps removed)

Apologies for any inconvenience. This product is very much still in Beta so I’m still fixing a few bugs here and there.

Well, at least the developer of this skill is far more responsive and helpful than Smarthings support

2 Likes

So what are the steps to get it working. Or is there way?
Alexa doesn’t seem to be picking up the new monkeys.

When smartthings was in startup mode, they had fantastic support. And it continued I would say all the way into 2016 or 2017 when the support got transferred over to Samsung. But it was definitely great for the first few years.

On top of that, there are still employees who participate in this forum by their own choice and are also really good. :sunglasses:

But yes, there’s no question that the Frontline support has become people who are just reading off of scripts and it can be really frustrating.

2 Likes

Forgive my newbie question but I have never used the make a web request function before and I have a few questions.

  1. When I add the voicemonkey url to the piston do I need to add quotes before and after?

  2. Do i have to free text urlEncode or should it autopopulate?

  3. Do i need to add urlEncode if I am having alexa make a custom announcement when monkey is fired?

This is my current piston

And then I have an Alexa routine as follows, When gargedoorleftopen is pressed, Then announce “garage door was left open”

For yours, you are just triggering an announcement on the Alexa side and leaving the “announcement” in the URL request off. You won’t need urlEncode or an expression. To trigger the announcement routine, for URL, do “value” instead of “expression”. Then put in your value as - https://api-use-voicemonkey?access_token=YOURTOKEN&secret_token=YOURSECRETTOKEN&monkey=garagedoorleftopen Then stop, and don’t use any quotes.

Otherwise, there’s really a few ways to code the URL. If you code it as an “expression”, what you are doing is actually using Webcore’s functions to format the URL for you. If you are doing that, you will need a quote right off the bat, all the way up until equal sign after announcement. Then urlEncode(“Your announcement”).

Or, you can actually use the “URL Generator” feature in Voicemonkey to format the URL for you, and then just put that in as a value with no quotes needed. Basically, a URL needs %20 instead of spaces. urlEncode is doing that for you.

Multiple outputs

For those wondering how to send one web request and get several (or all) echos to respond, the answers is fairly straightforward.

  1. create a new monkey - we’ll call it everywheremonkey

  2. for each echo you want in the ‘everywhere’ announcements, create a separate routine, triggered by everywheremonkey, where the ‘respond from’ at the bottom of the routine is set to that echo.

Now, when one web request goes to everywheremonkey, multiple Alexa routines run simultaneously, all focused on a different echo device.

Oh, and also in webcore I have created a global variable for each monkey with the whole URL in it apart from the custom speech

Due to this, my overheads to speak are an absolute minimum:

Make a web request to (concat(@monkeyname, “my message to speak”))

Since those are globals, they’re available from any piston. Speaking becomes a one line command again.

3 Likes

I had this working fine yesterday, today I added a new Monkey and called it a new webCoRE script, and now when the Routine runs (when the monkey ‘is pressed’ instead of the variable message, I get Alexa saying: Welcome to VoiceMonkey, visit voicemonkey.io to get started.

I also noticed when I created a URL for the new Monkey, the secretkey had changed.

Ideas?

Same thing happened to me. Just try to disable and re-enable the skill.

1 Like

Thanks!! Unlinking and relinking solved it.
I am quite pleased with the integration and would probably consider paying for it, but not if this happens very often

1 Like

Yeah I feel the same. It’s happened to me once and Christian gave me steps to fix it, which it did but I’d hate for this to keep happening as I’ve set up quite a few now and would be a headache to have to start all over again. I’d also be willing to pay for a more robust skill but I’m not even sure if and how/when it’ll do it again.

I also had to relink shortly after i first set it up. So far that’s been the only time I’ve had to, so I’m hoping that it stays that way.

After the relink I have not had a single issue. It’s only been about 10 days, but so far, it has proven 1000 times more reliable then the Samsung Alexa skill, which is now up to a 74 percent 1 star rating

1 Like