SmartThings Community

Alexa + SmartThings + IFTTT + Harmony to turn TV on and off by voice (2015 version)

I have over 15 harmony activities integrated into Smartthings. Can somebody tell me why I can only view 5 of them under “things”? But if I go in my harmony smart app, I can see them all and piggyback virtual buttons to them.

In this picture, there are only four shown, but…in this next picture, there are 14 in the harmony smart app.

I can’t get the other 10 activities to show under “things.”

Very cool! @JDRoberts Whats the best way to use natural language for this? Are you naming the activity as simply the channel name ; i.e. “ESPN” “IFC” etc? Or creating Alexa groups? something else?

I tie a virtual button to the harmony activity. Then I name it for example ESPN so I say “Alexa turn on ESPN”.

Only issue I have is only 4 of my 14 harmony activities show up under “things”, but yet I can link all 14 to their own virtual button. I don’t know why all 14 don’t list under things.

I started out just using the channel name, but that can sometimes conflict with built-in echo options. For example if I say “turn on ESPN” it would often try to start the ESPN radio station. So I changed the name to “ESPN TV” and then it worked fine. But you may just have to experiment to see what feels natural to you. See the naming quirks thread for more discussion.

1 Like

OK, I think I know what’s going on here but I don’t currently use the official Harmony/smart things integration smart app, so I can’t test it. But here’s what I think.

The official Harmony Connect smartapp now creates its own virtual switches
The current version of the official harmony connect smart app already creates a virtual switch for each of the activities. At least it’s supposed to. Those new virtual switches get a really strange name where [harmony] is appended to the end of the activity name. (Obviously whoever wrote this doesn’t have an echo.) those switches then show up in your things list. Not the activities, just the virtual switches. The activities only show up under the harmony.

You can see in your screenshots that those are switches because of the icon that they have which is an on button.

your own virtual switches

If you are creating your own virtual switches through the IDE or through one of the smart apps that create virtual switches, they should also show up in the things list under whatever name you gave them, although they may have a different icon depending on the device type you selected.

your missing activities

My guess, although again it’s only a guess because I haven’t tested it, is that you may have added harmony activities after you initially connected the hub to SmartThings. If so, you haven’t gone through the official process to create the virtual switches for those activities.

If those activities did exist at the time you connected the hub, maybe it only makes switches for the first four. That would be a bug, though.

Ordinarily you could try removing the harmony hub and then re-adding it, but I can’t recommend that at this time because people have had problems with re-adding hubs recently.

So I would suggest either just making your own virtual switches for the missing activities and associating them individually, or waiting until you contact support@smartthings.com to see what they suggest. I just don’t want you to lose any functionality you currently have which is why am not suggesting changing names or anything.

But the main thing to understand right now is that what you are seeing in the things list are the virtual switches which have been associated with Harmony activities. Not the harmony activities themselves. So you have 14 harmony activities, but only four Virtual switches to go with them. It’s the virtual switches that are missing, not the activities.

Good luck, let us know what you find out.

Those icons that look like harmony hubs are activities. Those were created prior to syncing harmony to Smartthings.

The other 10 harmony activities were created after Smartthings integration.

Whenever I create new activities now they show in the harmony smartapp, and I am able to create virtual buttons in the IDE and link to newly created activities to them.

I just don’t know why there are only 4 harmony activities visible in my things list, but I can see all 14 virtual buttons that operate my 14 activities just fine.

I’m afraid to unlink and re link my harmony hub to Smartthings at this time like you already stated.

I believe the ones with the harmony icon on the left are in fact virtual switches that were created by the harmony connect smart app at the time that the hub was added to SmartThings. You can see their button icon on the right. The "[Harmony] at the end of the activity mean on these devices is what identifies them as a device created by that Smartapp. If you look in the activities list itself, you’ll see there’s no similar bracket text for the activity itself. The virtual switch created by the Harmony Connect smartapphas the same name as the activity plus the bracket text.

So the question is how can you use the official smart app to create the same virtual switches for activities that are added after the initial hub discovery. I don’t know. My guess is that you’re supposed to remove the hub and then re-add it but that’s the part that’s that’s been breaking recently, so I wouldn’t suggest you try it without checking with support first.

So you’re saying those little icons that look like harmony hubs are the virtual switches are were automatically created when activities were added?

They do present with [harmony] in the name.

If so, then where are my other 10? I added those activities the same day as the first 4.

1 Like

Gotcha. Ok thanks. I’ll sit tight until the dust clears b 4 I delete and re add my hub.

I meant to say those were added in the same WAY as the first four, not “day”.

In the same way, but after you had discovered the Harmony Hub in SmartThings, right? The first four, which existed before you added the hub to SmartThings, had their virtual switches created as part of the hub join. I just don’t know how you’re officially supposed to get them created for activities that you add to harmony after you did the hub join. It might be really easy, I just don’t know.

The harmony integration is pretty cool. I can tell Alexa to turn on appletv and that will start appletv plus with Ifttt, I can trigger a lifx scene to start with my 4 lifx bulbs in the living room when the virtual appletv button is pushed.

1 Like

Yes, those 10 were added after harmony hub was joined to Smartthings

@eric182, I would try the following:

  1. Go into the ST app [My Home->SmartApps->Logitech Harmony (Connect)]
  2. Touch the “+” under “Select Harmony Activities (14 found)”
  3. Check the boxes next to the items you want to add as “Things”
  4. Touch “Done” in the upper right
  5. Touch “Next” in the upper right
  6. You should now be back in the SmartApps listing
  7. Touch Marketplace on the lower right
  8. Wait a few seconds
  9. The number of items you selected in #3 should now appear next to “Not Yet Configured”
  10. Go through each one and add them to a “room”, touch “Next” then touch “Done”

I hope that helps.

Good luck!

1 Like

I’ve tried this many many times over the last three weeks or so. When I select my 14 activities as things and click next, I would get the red error banner across the top of the app. I was unable to successfully add them as things.

However, I just tried this again 5 minutes ago and it worked. Now I have all my 14 activities as things. The only difference? I was not on my own wifi. I was at work when I did this. I don’t really think that made a difference, but it’s kinda weird.

Thank you.

Anyway to tell Alexa to pause the tv . Or to stop playback, like you can on Xbox one ?

It’s pretty clunky, but you can do it. Since I’m quadriparetic, I do use a pause, but I expect most physically able people will prefer to just use the buttons on the remote.

Anyway, it’s just like everything else. The first thing you have to do is set up a harmony activity that does exactly what you want. To get a pause, create a new activity, select the appropriate device and then select the pause button for a “step” in the starting sequence.

So it’s the same as the example given above in post 285 for changing the volume.

Once you have the pause activity set up, you can use echo to trigger that activity the same way you do for any other activity. :sunglasses:

Tried this and for some reason it wants to turn everything off. The start commands has no off commands in it at all. It has Amazon Fire tv on and pause that’s it. Not sure why it’s turning things off .