Alexa <--> Smarthings access doesn't work in the app

Hey community -

real basic issue here. within the Amazon Alexa app, I go to enable the SmartThings skill.
I get to a page with a title "Authorize Amazon Alexa to access your Works With SmartThings Devices.
There is some info, then a dropdown.
The dropdown doesn’t work (says “select one” but tapping it doesn’t allow me to select anything). It probably wants me to select a location, but there are none in my dropdown.

So I am unable to authorize the smarthing …

Curious… What Shard are you on?

ie, what URL are you directed to when you login to ?

I’m having the same problem, I get to login.

After you login, you are automatically redirected to a specific Shard website.

Please capture that URL. It might be useful information.

Yes I then get redirected to graph-eu01-euwest1
However on eu01 the site shows me as having no hubs and locations available.
I tried the other shards listed in your post too, FAQ: How to find out what "shard" (cloud slice IDE URL) your Account / Location is on?

I had a similar problem when I was setting up my ikea smart lights with smart things I tried all the shards and could’t find my hub on any of them. but when I logged in using it did find my hub and I was able to set everything up.
No everything has disappeared again… My hub still works with no issues.

Yup… Please research this with

And share your results? I really hope this helps myself and others understand what’s going on and how to get it resolved if we experience it :confused: :pray:.

I have just emailed that address - will post their reply on this thread - or better yet, hopefully they jump in with their thoughts!

in short - I need to purchase a smarthings hub in order to use Alex to communicate with the Smartthings Outlet that I bought

As explained to me after a long thread with Brian, a technician there (who I am very grateful to):

You speak the command to the Echo: “Alexa turn on kitchen lights” . From there the Echo will communicate via Wi-Fi (LAN) to the router. From the router it will go to your modem and out to the Amazon servers and back to your modem and router. From your router it will then send the command to the SmartThings hub (because they will be linked) and from our hub it will send it out to the lights (on).

Our hub acts as a brain and Zigbee/Z-Wave radio transmitter/receiver. Our hub will also utilize the router it’s connected to to also communicate with Wi-Fi or LAN devices (like your Echo).

Essentially Alexa does not have a Zigbee or Z-Wave transmitter or receiver and has no way to communicate with Zigbee/Z-Wave devices (why the hub is required).

Lastly - the hub is 50% off at the moment:

Hope that helps!!

Had you stated in your original post that you had only purchased an individual SmartThings device and you were having trouble connecting, you would have gotten the same answer from the community that you needed to first purchase the hub. It was assumed that you already had the hub since you were trying add the SmartThings skill to Alexa and were unable to select a Location (a registered hub is required), in which the reply you got was in reference to a recent issue showing up in the SmartThings universe.

Anyway, glad support pointed you in the right direction, and welcome to the world of SmartThings.


Hi All, so I do have a hub (the smartthings mesh router) and am having the same problem. I just recently bought it and a gen2 echo dot but cannot authorize smartthings skill on the alexa app. When I click on the drop down there’s nothing to choose from. I’ve contacted smartthings support and they said it may be a problem work the alexa app. I called alexa’s support number and they said it may be because I’m logging into my samsung account and not my smartthings account. However, it seems like smartthings accounts are integrating with the regular samsung account so there shouldn’t be any need to ha e a smartthings account. Anyone know what I should do?

i often use a browser to make changes or to configure things for alexa. seems to be more reliable then the app. see if it does the same thing using a browser on a pc/mac.