SmartThings Community

Alexa and "TV"

I’m trying to be able to say “Alexa, turn on the TV.” and have it happen. For some reason every single time she replies saying that I have several devices with that name and asks “Which one do you want?” If I reply “TV” she then says “OK” and the harmony activity starts. Also, if I try “Alexa, turn on TV” the exact same thing happens (omitting “the”)

I have a harmony hub with two activities “TV” and “AppleTV” - could it be confusing those? There doesn’t appear to be any way to have it tell you which devices it thinks are named the same. I have no other items in ST that have “TV” in their names.

I’ve had Smartthings/Harmony integration since it was first introduced and it’s worked fine - My Echo Dot 2 is new.

Thanks for any help here.

See the echo naming quirks thread. It seems pretty clear that some words are reserved for echo’s own use, perhaps for future functionality. TV does seem to be one of these, as is ESPN.

If you use the IFT TT channel method so that you were saying “Alexa, trigger TV,” it will work. Once you put the “trigger” in there it will pretty much let you use anything.

But if you’re using any of the other methods where echo has to parse what you’re saying to figure it out, you just have to work around these quirks and choose a different word.

At our house we ended up using “local” And “cable” depending on exactly what device we wanted.

1 Like

Thanks @JDRoberts, I had read that thread, but it wasn’t clear if TV was actually a reserved word or not/ And if it is, why does it work when I say it again?

It seems to do with echo taking an extra step to figure out that you’re asking for a home automation request. If you hit one of the reserved words, it doesn’t process it right away, it asks for clarification.

But this is all just guesswork based on what does work and what doesn’t. I don’t really know why it happens. But many people report that it does.

So it’s up to you what you want to do. You can always give the clarification, you can switch to the trigger method, or you can change to a different word. Whichever feels more natural to you. :sunglasses:

I use the word “television” instead of “tv” and it works much better.

1 Like

The annoying thing is I have a friend with the exact same setup (two activities named TV and AppleTV) and he’s able to do it on his system without issue. Well, he said it asked for clarification the first time, then after that it he didn’t have to clarify anymore.

Alexa’s reserved words are extremely frustrating because they aren’t published anywhere. This is why I use IFTTT for my blinds and some other devices as I know it will work everytime.

1 Like

My harmony activity is called “watch tv”. It always works.

@bamarayne - how do you activate it? “Alexa, turn on watch tv?” if so, I’m hoping to avoid the semi-awkward phrases for others… it’s much more natural to say “Turn on the TV” I may not have a choice here though…

Yeah that is it… I honestly have tried anything else.

You could askAlexa…

I had the same problem so I changed the activity to " cable" so I say “Alexa turn on cable” or “echo turn on cable” ( for my one dot ) and it works.

2 Likes

Sounds simple, but try editing your Alexa list of things. I added and removed some things in smartthings but Alexa did not remove them, but added a second copy. I started having the same issue you are, getting that I have duplicates and was very frustrated till I actually logged into Alexa and noticed things were actually duplicated there. Removing it there and adding it back solved the issue.

Hope that helps!

1 Like

Believe it or not it happened to me again just now. I had reconfigured a dual relay micro that I use to turn my room fan and light off independently and for some reason “turn my room light on” was not working in Alexa anymore. It gave me the duplicates error. I opened Alexa and removed all devices then did a rediscovery and now all is well!

Good idea!

1 Like

I’ve noticed lately that it’ll work with “Alexa turn on cable” or “Alexa turn cable on”. Whichever way seems more natural to the individual.

I had the same problem and changed TV to television. Works every time now.

1 Like

Mine is just called TV and “Alexa turn on/off the TV” always works. It is my only ST switch with the word TV in it, though.

Almost did that but cable is 2 syllables and television is 4.

I was able to get this working…

When you install the Harmony Connect “SmartApp” from the SmartThings marketplace, it auto-creates Devices that represent your harmony activities. For example, I had two harmony activities: “TV” and “AppleTV” - installing the harmony connect app created two devices and it named them “TV [Harmony Activity]” and “AppleTV [Harmony Activity]”

The issue was the names… I went into those devices and edited the names to just be “TV” and “AppleTV” and now it works as expected.

1 Like

Sorry forgot all about how you have to delete the harmony activity phrase.