Alarm.com and Smart Things

@kingd10 I suspect it’s still a 2FA/auth problem. Have you logged into alarm.com directly and made sure 2FA prompt is disabled?

My integration is working fine, which I find so strange. I don’t understand how it can work for one person and not the other(assuming handler and smartapp code is the same).

FWIW, I verify functionality by turning on the ST device using an automation or trigger.

I’m seeing the same situation as you with successful alarm.com logins, but not correctly arming/disarming. I’m also seeing (somewhat sporadically) your above error:

something went wrong: org.apache.http.conn.ConnectTimeoutException: Connect to www.alarm.com:443 [www.alarm.com/192.155.71.71] failed: Read timed out

and

something went wrong: groovy.lang.MissingMethodException: No signature of method: java.io.ByteArrayInputStream.getAt() is applicable for argument types: (java.lang.Integer) values: [0] Possible solutions: getAt(java.lang.String), reset(), reset(), getText(), read(), read()

I took similar steps: full uninstall of the app & DH and contact my provider to exempt me from the 2FA prompt (I even just switch providers because my old provider Brinks wasn’t helpful, and Surety did it immediately after I asked). I’ve also confirmed on several devices that 2FA is not prompting.

@crizo22 Thanks for the reply. I have logged in via mobile app and web browser on different devices to confirm there is no 2FA popup. Additionally, when I navigate to alarm.com [Settings → Login Information → Two-Factor Authentication] it also appears as expected with options to setup via Email or Text Message.
I typically would have automatic triggers, but in the past it would work for me by turn on the disarm/arm switched. Are you running the latest version of the app that has some of @schwark 's attempted fixes, or are you still running your pre-2FA installed app?

@leftride I’m glad I’m not alone :sweat_smile: I was getting worried when I started seeing people post that it was working for them…

The second error you added I did notice I am get tonight. And now, just as you said, I am seeing them both sporadically on different disarm/arm attempts.

Hmm. I am going to be publishing another version shortly that just tries multiple times. Will try and repro this issue before I do.

1 Like

Here’s a quick update:

I tried reverting back to an older version of the app here:
https://github.com/schwark/smartthings-alarmcom/tree/85ffdd4b0b68988697eb9a4532704176e13be0c5

This, along with getting the security company to exempt my account from 2FA appears to have resolved the issue. I’m now able to arm/disarm successfully.

1 Like

@kingd10 that version worked for me as well, thank you for sharing that!

@schwark I haven’t taken the time to do a diff (it’s bedtime), but this older version and the removal of the 2FA prompt is working so not sure what changed, but might be worth a look.

1 Like

I never had the issue of it not working, until today… I tried updating to the most recent @schwark version, but ST still not triggering commands… it was working this entire time that I been seeing everyone posting about 2FA, but I logged in to mobile site & not seeing any 2FA messages. I use Guardian services. Not sure why it stopped for me today. Again I tried finally updating the smartapps on repo, but didn’t fix.

I just tried uninstalling & reinstalling… no go. It does not even show in the activity in alarm com app.

@adrian97c did you try using the older code branch kingd10 referenced above? It’s been working well for me for the last day. I’ve been testing regularly and arm/disarm works without issue.

It looks like there were changes made in the getRecipe() call between the 2 versions that (at least for me) are causing the latest version to no longer work.

The older version was what I was using… the 2019 version. It stopped working, so then I tried upgrading to the new version (that I was avoiding), which didn’t work either.

I’m still so confused why our success/fail rate is so random. I’ve had the issues above, and now that 2FA is disabled on my account, the smartapp is working fine. I have found various issues with controlling the alarmdotcom triggers from automations and scenes, but toggling the virtual switch directly currently works for me.
Any chance this could be an android/ios thing? I’m on iOS, latest version.

It is quite common in authentication situations that there is an additional pop up page that will confuse automated scripts. It may well be that some alarm.com providers have such a pop up and others don’t, or that some providers offer an account level option to disable the pop up and some people have it set and others don’t.

So situations like that can mean that people using the same smartapp and DTH still get different results.

I’m late to the party, but, my automations stopped working as well. Worked last Friday and didn’t work on Sunday and has not worked since. By looking at logs it doesn’t even appear that it is trying to contact Alarm.com. Updated code and seems by looking at logs that Smartthings sees the switches working, but won’t sent any info to Alarm.com.

Looks like those lucky people like us had no issues until this week… must be something rolling out slowly. Def not the 2FA as it’s not enabled & not getting any prompts.

I’ve tried reinstalling using older app, & now the switches all show on… won’t turn off. Nothing being sent to alarm


Another wierd thing (besides it not working), is that the switches show up as all “on”, & tapping them does nothing. Stays showing “on”.

Also the switches show in “devices”, but they are not showing when creating automatons or scenes…

Any way to fix the broken Switches?

Update: I deleted & re-installed using the most recent codes… the switches now toggle correctly, but 2 issues remain: 1) they don’t reach alarmcom 2) ST can’t see them when creating Scenes/Automations.

I don’t think this ongoing issue has anything to do with 2FA. For me, 2FA is a settings menu option, I do not have it turned on, I don’t get a pop-up reminder, and I am still have issue with both the 2019 version of the smartapp and with the newest version of the smartapp. I have also tried JEstrada39’s fix above, but cannot even login unless I change the username input form “string” to text. Even after logging in successfully with this version, I end up with three switches all turned on at once with no functionality.

Didn’t realize how dependent I was on this one app, as it was critical to the security automations I had setup for my home. HELP!

1 Like

Any updates on this.

1 Like

I’m super dependent on this SmartApp and have tried every suggestion and every combination without any luck. I too am anxious for an update… even hearing from those that it is still working so I can try their setups.

FWIW, the homebridge alarm.dot integration is still working (just re-enabled it, it was off b/c I didn’t want two different automations controlling the same system, hard to debug problems). I am able to view the status of all of my sensors. I didn’t try any arm/disarm activities since the family is home but the fact that the API appears to be working tells me maybe that implementation has found an alternate way to interface? The code is open source (github) if someone wants to dig in and see if something can be copied.