SmartThings Community

Aeotech Multisensor 6 (gen 5 zwave plus, model ZW100-A)

dth_humiditysensor
dth_motionsensor
dth_luxsensor
dth_sensors
dth_vibration

(Travis Muszynski) #249

I have the update interval set to 300 seconds. That is about all I have really been able to change. For this particular device, All I need is LUX, motion, and temp updating every 300 seconds. I’ve been only playing with the temp calibration so I can decide if I want to buy another one or not for another room.


(Travis Muszynski) #250

Also, I’m still not able to edit the device with the Android app. Only in the IDE or the Apple app.

It just says, “Sorry, there was an unexpected error”


#251

You and I are in the exact same boat, it seems. Android app errors out attempting to go into Prefs, but iOS works fine!

I can deal with that, just hoping to get negative temp offsets up and running.

As always, @Robert_Vandervoort your help is greatly appreciated. Your device type has leaps and bounds more potential than the stock ST device type. :smiley:


(Robert Vandervoort) #252

Thanks guys. @onetrav I WILL make that offset work… mark my words… These are badass little sensors… you can’t beat the profile, style, and battery life (maybe not so much with 5 min intervals, but hey, USB power!)

@kars85 what you and onetrav are experience in the Android app is just the Android app being a P.O.S… I have the same issue on any device I try to edit preferences for… try editing another device’s name in the android app for example… It’s not the device type in this case. hopefully they’ll fix it soon. I also can’t see any devices not grouped inside a room, the entire “things” view by iteself is broken but for the IOS app working fine.

There is the capability to throw different metrics into different report groups… IE report LUX and Temp every 10 minutes, Battery every hour, everything else every 2 hours, whatever… I didn’t include support for that because it would be a LOT more code to do so in a usable state. I could allow for bit switching or decimal value entry for the report groups but you’d need to refer to the documentation for how to set it… Basically each parameter has a binary or decimal way of telling the device which things to send in each group. I’m only using two groups, one for sensor data and the other for battery. I would add parameters for interval for group two which is the battery report, and I could provide parameters for what gets sent. I have the feeling however that most folks wouldn’t care so much? I imagine many won’t ever adjust the parameters but at the same time I also imagine the REASON you’d even want to use my code is because you WANTED the control?

Anyway… feedback is always appreciated and this thing will evolve until it doesn’t make sense to evolve further.

On another note, I have added engineering specs for the smart switch and smart dimmer new iterations, the 6… pretty sweet little doodads! Those are in my github repo… hope to get my hands on some soon.


(Travis Muszynski) #253

Robert, your rock. Keep up the great work. If you get this dialed in, I wouldn’t mind buying a few of these little guys. Very versatile.

I thought ST was working on an official integration set to release last month. Maybe they are just going to use yours when it’s done.


#254

This might help:


#255

I seem to be having the same issue accessing the config panel…doesn;t do anything ? I am using your v 1.4. Is this a known issue or an I dorking something up? I REALLY like these sensors, so I appreciate everyone’s help with this!


#256

Another question…has anyone figured out how to turn off the LED or at least adjust when it turns on? I have this set up in the baby room and it freaks him out when it blinks on for some reason…thoght I’d turn it off if I could? Thanks!


#257

The config tile works in the background. In essence, it takes the values you set within the preferences tile (offsets, etc…) and then once those are setup, you need to double tap the button on the sensor and get the timing down well enough (within 100ms) and hit the config tile on your phone. The timing is something I haven’t mastered yet, but I think it perhaps has something more to do with negative offsets not quite working correctly.

If you go into the ST IDE and view the Live Logging while you’re doing all this, you’ll see that the config button merely tries to upload the settings to the ST hub.

EDIT: is your profile name (isu) anything to do with the Ames area by chance?


#258

Yep…Iowa State…Ames! Appreciate the help. I read about the double tap on the sensor to upload the settings, but the trouble I face is that the tile does not allow me to change anything in the background? What am I missing?


#259

I also get a “sorry unexpected error” if I try to edit the device within the app? Any thoughts?


(Ian Watson) #260

Hi,
I’m trying to use your code for the MultiSensor 6 V1.4 to create a New SmartApp by Code and I get the following error message after I cut and paste the code and hit “create”

“No signature of method: script14443417489382065402086.metadata() is applicable for argument types: (script14443417489382065402086$_run_closure1) values: [script14443417489382065402086$_run_closure1@4a3ee38b] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)”

Any idea what I’m doing wrong?
thanks


(The fish is still dead.) #261

You need to create a new device type, not a SmartApp.


#262

Cool - I live in North Ames. Saw the forum name and figured you were somehow geographically related.

The problem you’re facing is likely in the timing. Depends on how you have the Aeon powered. If battery, hold the action button down until you get an orange blink (this indicates it is awake and open to accepting config commands). If USB powered, you need to quickly double tap the action button, then hit config after you’ve set the preference how you’d like, all within 100ms. Not a lot of margin for error as far as timing goes.

I’m wondering, personally, if I can power via battery to configure the device’s preferences, just to allow a larger window of time to configure. I haven’t had any luck via USB.

As far a the unexpected error, it sounds like you’re on an Android. ST’s android app is basically read-only at this point, and faces multiple issues. The iOS app or IDE via your computer are probably the only way you’re going to get any changes done efficiently at this point, until ST figures out the Android app problems.


(Ed) #263

Thank you so much!! The device arrives today once I get some batteries for it I’m starting on it. Thanks again for helping me get started into smartthings!


(Eric M) #264

I think when the sensor is mains powered it is always awake. At least it is for me. I can send config commands to it at any time and they take.


#265

To get negative temperature offsets working, I just went into the device type and manually specified it there. If you want a -10 degree offset, you need to set the variable as -100. Or in my case, I wanted a -6 degree offset, so I set the variable to -60.

If you’ve already added the device type, just save and republish, and whala :smile:

One more thing that I can get off my desk!


(Travis Muszynski) #266

I have tried exactly what you described and was still unsuccessful. The change definitely took because it shows up in the “edit device” page, but I don’t think the device took the config. If I uninstalled and then reinstalled with the code changes already in place, it may take but I’m not ready to resort to that.

The other issue comes when I add a second sensor that requires a different offset. I could just copy the device type and make another one.


(jhoff80) #267

I’m wondering if part of the problem is manufacturer quality control on this, or possibly something related to firmware versions (which apparently can only be updated through the Aeotech Z-Wave PC dongle). I’ve got three of this sensor right now, all on AC. Two of them work absolutely perfectly. The third is slower to react to everything and has far worse motion sensitivity despite having identical settings to the other two.


(Frank ) #268

I just purchased one and have been really disappointed due to the slow response and listed range. Should I exchange it in hopes of getting a faster device? I’m assuming they’re all on the same rev of firmware?