Aeotec Nano Switch Wiring?

So I installed a couple of these yesterday, I noticed a low, high frequency sound from all of them. My Qubino dimmer is dead silent though. Anybody else noticed this?

I just installed one of these (see here for details) in a 3-way cirucit. I can not hear any type of humming coming from the switch. There is a fairly noticeable “click” when the switch is turned off or on, but no humming that I can tell.


Usually the humming is from a dimmer type of switch and not on/off relay switch. That’s why you don’t hear any humming. Your switch is not a dimmer.

True, but I thought @Arnqvist was asking about switches and not dimmers. A little tricky nomenclature don’t you think. I see the reference to the Qubino dimmer though, so yea, probably not an apples-to-apples comparison.

1 Like

Alright, yes it’s my nano switches that makes a high pitch sound. My Qubino dimmer is silent, even though I know that dimmers are usually humming.

Its not loud though, i cant hear it from across the room so I’ll live with it.

Ok can someone just confirm I’m understanding this right for Nano Switch (not dimmer)? Currently switch has line and load with neutral tied off in back. So I need to join Nano N to neutral, Nano L to Line, Nano IN to Line, Nano OUT to Load, Nano S1 to switch, and Line to Switch?, Nano S2 to nothing? Is that right? I was very confused by diagrams use of two switches.

Just to close the loop that did work. Thanks to @ccheng for clarifying the documented diagram was showing a setup with 2 switches. I suppose that should’ve been understood implicitly. I also had to force the nano to detection mode using 4x button push. After that my external switch toggle was able to control the load. Finally this was my first zwave plus device and was going into a v1 hub so when it initially failed to pair (non secure method) I was worried about some DTH or other compatibility issue. However soon as I moved my hub (using plug in wifi extender) next to the switch, it paired fine and was still able to communicate after moving hub back to its standard location. Just figured I’d post end result in case someone in similar situation down the road.


@ccheng, you are totally wrong on the settings. This is a quote from Aeotec, USE THESE settings and you will be really happy with your switch.

Changing mode on the External Switch/Button Control.

The Nano Switch can be controlled via 2-state (flip/flop) external/manual switch, momentary push button or the 3-way switch. To automatically detect and set the mode to the appropriate type of manual switch wired into Nano Switch, toggle the button on the manual switch once and wait 2 seconds for the Nano Switch to detect the type of manual switch.

You can also set the external switch mode through Configuration Command Class.

Parameter 120 [1 byte] is the parameter that will set one of the 3 different modes. You can set this configuration to:

(0) Unknown Mode
(1) 2-state switch mode
(2) Momentary push button Mode
(3) 3-way switch mode
(4) Enter auto switch detection mode

Does anyone know if these can be used with aluminum house wiring? I can’t find anything on Aeotec’s website.

Note: 1. The gang box should be sized 3×2×2.75 inch / 75×50×70 mm or larger, minimum volume 14 in / 230cm .
2. Use flexible copper conductors only.

What you can do is to buy a short copper strand pigtails and using Al/Cu Wire Connectors to connect the copper to aluminum.


I just installed one of these switch an seem to have everything up and running but i’m running into an issue where the app is not detecting the wall toggle.
Lights turn on and off etc but ST smartthings does not detect the physical state change.

So if i turn but if i turn the light on with smartthings app, the light turns on and the app updates as light being on, but when i toggle the wall switch to turn the lights turn off, ST doesn’t update the app and show the lights going off.

My other older aeotec switches update ST app with any physical walls switches.

Any idea’s, issue with device handler or switch setup?

I just wired in two of these, like right now, and I went to check this behavior since I had this thread pulled up and wanted to make sure. If I flip the physical switch on either of the two units I just installed, the switch state IS updated in SmartThings. It isn’t quite as fast an update as if you use ST to operate the device, but it does update.

1 Like

So after spending literally 2 full days trying to wire this nano switch in a 3-way setup I’ve completely failed. Any chance someone could help me out on here? This is my exact wiring on the circuit.

I have installed the switch. The physical switch does not work. App works fine. I have installed the tweakerbur really don’t know where exactly to change the parameters?

It’s a single dimmer relay to control a single switch

For “Parameter ID” type 120. For “Parameter Value” type 1. Save and wait for the config to update, then test the manual switch. Then restore the proper DH in the IDE.

Thanks. Tried the instructions above, no joy.

Bit of an old thread but might help someone else. Just set the button mode on the Aeotec Nano Dual switch and the parameters are different. I was trying to set value 2 for my push button switch as stated above but not getting very far. Needed to set it to 3.

Parameter ID 120 (S1) - Values:
0 = automatic identification mode.
1 = 2 state switch mode
2 = 3 way switch mode
3 = Push button mode

1 Like

I just bought an Aeotec Nano Switch and I’m having trouble getting the toggle switch to work. The zwave stuff works fine.

I had exactly the same problem with our 2 new Aeotec Nano Switches. The problem for me was that the Nano was misunderstanding what kind of physical switch I was using.

I resolved the issue by putting them into ‘learning mode’, sometimes referred to as “Switch Configuration Mode”. To do this, you need to press the action button on the Nano 4 times quickly. The LED light will then blink blue to show you it is in learning mode. From here, toggle the physical switch (just one way, i.e. off to on) and then leave it for a few seconds.

That’s it - the next time you use the physical switch, the Nano will respond accordingly.

This put me on the right path, but after doing this, only S1 responded to the manual switch. S2 did not, and would only turn on via the app or the action button on the Nano. To make S2 work, I had to put S2 in learning mode by pressing the Nano action button 6 times, then follow the same steps I followed for S1 (explained above).
So to put S1 in learning mode, press the action button 4 times. For S2, press it 6 times.


i am using the ZW139 nano and had the same or similar issues described here, where the unit worked fine for zwave but was unresponsive to S1 state changes. I tried with the tweaker and then with the 4 button press which meant that it did now respond to S1. However, for reasons i don’t understand when S1 goes high (i am using 240VAC) it turns the Output off. conversely when S1 goes low it turns on. I checked with zwave tweaker and Param 120 is 1 (2 way). i am used to the Quibino devices which allow this to be reversed. can’t see any way to do that on this device. It would help if there was a Device Handler which allowed you to adjust params and inspect S1 / S2. Maybe i am soft, but i don’t know why you would go to all the trouble of making the device and then not provide a fully featured handler for ST. I have a work around, but can’t see me buying any more of these unless i can fix the issue. Thoughts welcomed.