Aeotec Nano Dimmer - Slow Dim Speed

aeotec

(Corey O.) #1

I have an Aeotec Nano Dimmer: https://www.amazon.com/Aeotec-Dimmer-lighting-controller-dimming/dp/B06XC4CH98

Like other zwave dimmers, it doesn’t turn on and off instantly, but rather fades on and off by default. The fade speed is frustratingly slow (like 10 seconds). It can take some time to even tell whether or not your command was received by the device. I don’t know who thought this would be what most people want, and I saw some complaints about it in the comments. Most other devices allow you to adjust this. Is there any way to adjust this to instant on/off (or close to it)?


(Eric) #2

I think you’d have to make a custom device type to control parameter 0x7D (125) to set default dimming rate.

They don’t make it easy.

EDIT- well this tool is kinda fascinating and maybe it becomes easy. I haven’t tried it yet. I think you’d change the target device, to this below device-type ZwaveTweaker, then tweak the parameters and press configure, then change the target devices back to the desired/original device-type.


(Corey O.) #3

@ero4444 I installed the zwave-tweaker device handler and when I attempt to alter anything via the edit button, I get a 403 (permission denied error).

I took a look at the device handler code and it simply calls:
generate_preferences(configuration_model())
the configuration_model() function is not defined anywhere in the device handler. There is a documentation string at the end of the device handler explaining the configuration options, but I still have no idea where the code resides or what it’s doing. Any thoughts there?


(Eric) #4

I still haven’t tried it yet. ARe you sure you got the whole file - it’s huge.

Usually when I see “permission denied” in the smartthings domain, I suspect ST cloud problem, or a conflict between IDE functions. Lately I think there is an interference when editting Webcore and some IDE task. Just don’t know - I am just a cut-paste-tweak guy, not a groovy programmer.

I think that same post or similar one, discusses setting parameters via the device simulator, but you then have to cut-paste the parameter code, so it’s not as easy as making ZwaveTweaker work.


#5

I suggest you ask any questions about the Z wave tweaker In the author thread for that code. It is a very popular utility and many people use it. The author will be automatically notified when you post a new question to that thread, and other people who are using the code should also be able to help. :sunglasses:


(Corey O.) #6

@ero4444

I still haven’t tried it yet. ARe you sure you got the whole file - it’s huge.

yep, I was finally able to change the configuration option, but I had to do it through the smartthings app on my phone once I had changed the device handler. I’m now getting permission denied errors just for trying to change the device handler at all. I think these are bugs in graph.api.smartthings.com .

At any rate, I changed the value of field 125 from ‘255’ to ‘1’. The aeotec nano dimmer still takes 2 years to dim on and off. Does this likely point to the firmware ignoring that parameter?