Aeotec Hub will not stay connected to zigbee devices

Anyone else having issues keeping their zigbee sensors connected to the Hub v3?
Randomly one will reconnect eventually but it is not consistent.

I am constantly resetting the devices only for them to disconnect within 24hrs again.

|Firmware Version|000.048.00003|
|Hardware Version|Hub v3 US|


Sounds miserable and I am to get a new system this weekend unless there is a simple fix I am missing.

I have some lights connected but most of mine are contact sensors (used to set off an alarm if needed).

I know it’s not just one brand of sensor too. I have bought different brands and newer versions of sensors to see if it made a difference. They all disconnect.

However my z-wave seem to stay connected but I hate zwave.

Have you tried different drivers? I have aeotec and philips sensors that has always been working like a charm, but I also have few cheaper brand sensors (nedis) that were disconnecting daily basis but as soon as I changed their drivers from stock driver to community drivers (all were made by Mariano) they have been working flawlessly.
Also have you checked that your zigbee and wifi channels aren´t overlapping each other?

How do I update or change a driver? Do you have a link to instructions?

I have played with channels several times.

I’m having the same issue. 75 Zigbee devices just go offline every 24 hrs… I have a ticket open with support but they go no clue.

I’m suspecting something to do with the Zigbee and the thread antenna. Everytime this happens the hub light is green which means it’s working fine. Zwave and Wi-Fi devices work just fine. This is only affecting Zigbee

@nayelyz i know I asked you this before, but support has gotten nowhere. Level 2 team doesn’t have a clue of what’s going on. Any input on your end or taking it up with the big boys team would be much appreciated.

1 Like


I am so frustrated and done.

Zigbee Wafers (Juno Connect) randomly falling off the mesh on my Aeotec Hub,
I’m using alternate drivers. I’ve also had the same issue with the stock drivers.

1 Like

Very quick question… do any of you have SmartThings Station as well as the V3? Or another Samsung hub like Family Hub (fridge)?? Just curious here.

I do not have any other Samsung hub devices…

I can also give feedback that I have some zigbee devices that have 100% fallen off the mesh.
I have others that report offline to the hub, but are clearly still on the mesh as they’re responding to devices that they’re bound to. So clearly still on the mesh, just not communicating correctly with the hub.


Hi, everyone.
Please, when this kind of issue happens, you need to send the Hub logs right away so they get uploaded to the server and the team can take a look without the fear of losing them since they get deleted every 12 hrs approximately from the Hub or even less depending on how many devices are connected and how chatty they are.

  1. In the IDE, enter “my hubs”
  2. Enter the corresponding Hub and go to “view utilities”
  3. Click on “send” below “send hub logs”

Note: Logs get lost as well when we reboot the Hub so, if you already did that and devices haven’t gone offline yet, the current logs don’t have information about the issue anymore.

After you send the logs, please provide support access to your account:

  1. Confirm the email account registered in the forum is the same one you use for SmartThings. If not, please share it with me over DM
  2. Enable support access to your account:
  1. Go to the SmartThings Web (
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.
1 Like

@nayelyz , this is happening right now for me. Hub logs have been uploaded just now too.

Device : Upstairs Lights, DNI CB46 reported by the API browser tool BUT DNI DDB7 reported by the IDE
Driver Name : Zigbee Switch

It was online, then went offline, and now is back online but is not controllable via the app.

ST already has access to my account/hub.

Wasn’t this an issue a while ago that was solved?

EDIT : This switch is about to be replaced with a dimmer, so any debugging won’t be able to be done in the very near future.

@nayelyz hub logs were sent today to level 2 at 7:07pm

ok, I found the ticket you have with Customer Support, as we’re different teams, I’ll let them follow up with you to avoid duplicated efforts.
I already asked the engineering team about this issue.

I don’t have information about that, the team followed up directly with you, I mentioned you in my question, so they might remember.

1 Like

I will keep you posted with their progress

Same here. Need to reconnect different items every few days. “Smart”, i guess that´s not it at the moment : )
I now did as @nayeyz recommended and am curious if this will cure the pain.

Thanks for the reply @nayelyz . I didn’t catch it time yesterday, but one of my locks that has never had an issue went offline and then back online again after an hour. What’s interesting is that sometime between June 20th and June 26th all my locks got automatically converted from DTH’s to Edge drivers, at least that’s what I’m theorizing because those were some of my last devices to convert and I was monitoring that quite closely before leaving on a vacation.

Welcome to the SmartThings Community, @happy14
I’m trying to enter your account but it seems we don’t have permissions, did you verify that the email you use here in the forum is the same as in SmartThings?

I am having the same problems with BOTH zigbee and zwave devices. I have a zigbee Sengled open close sensor that will not stay online. Yesterday it was working, today no. Also major issues with zwave devices that show offline BUT I cannot exclude them and try reinstalling. I follow the correct procedure by running exclusion from the hub and then pushing the correct zwave button on the device but it cannot find it to exclude. I even tried a hard delete but that did not work either. Furthermore with my Aeotec zwave extender it is showing multiple times in the app with all but one of them showing offline but again no way to delete the offline ones. I am in the middle of migrating to a Samsung V3 hub and having many issues which I did not have at all with my old hub which died on me. Makes me wonder why I stayed with ST.

No, sorry.
Now I put my Smartthings mailadress as an additional Adress to my forum account.

1 Like

I am having this issue with my zigbee lights and switches. They are not responding to commands. I have uploaded the logs awhile ago.