Aeotec 4 button key fob?

Trying to connect a new “Aeon Labs ZW088-A,Black,US,AL001 Aeotec Z-Wave Key Fob, Gen5, Black” and it flashes like described in the manual like it connects, and when looking in the live logging it sees it has a Aeotec key fob but gives the following info
" 1:01:08 PM: warn Exception ‘java.lang.NullPointerException: Cannot invoke method parse() on null object’ encountered parsing ‘cmd: 5E02, payload: 01 02 00 0A 00 0A 00’ "

can anyone assist with this issue and help me get it connected, thank you

Bumping, same issues here, I am unable to get it to pair (the lights look like it does, but I don’t see anything in the “things” section. While looking at the logs, I get this.

I have reset it to factory multiple times, changed modes, excluded. Those all function correctly.

I don’t know for sure, but I wouldn’t be surprised if the device type handler for this device broke at the same time as the device type handler for the Aeon mini mote, as they are based on the same code.

These Are officially supported devices, so get in touch with support and they can let you know what the current status is.

Not sure what went wrong for you guys but I got my same remote on Thursday there and installed with no problems with the integrated DH. Be sure and change the mode of the remote by sticking the two pronged key in the back of it. I’m using the ‘Use Buttons as PIN Input’ smart app to run routines very successfully!

1 Like

I am having a similar issue.

I just purchased the Aeotec Keyfob ZW088-A. I follow the instructions to the letter. I even tried excluding it, then rejoining it to the z-wave network. When I click the + button on the things page, it just sits there and nothing happens when i press the “learn” button on the remote. however, in the IDE the event log says that it found the device

2018-01-08 9:26:32.168 PM EST
moments ago HUB zwStatus ready Z-Wave include search ended
2018-01-08 9:24:52.813 PM EST
moments ago HUB zwStatus include search Z-Wave include search started
2018-01-08 9:24:52.756 PM EST
moments ago HUB zwStatus ready Z-Wave device setup finished
2018-01-08 9:24:48.204 PM EST
moments ago HUB desc 14 Aeotec Key Fob rejoined
2018-01-08 9:24:46.592 PM EST
moments ago HUB zw device: 14, command: 8407, payload: zw device: 14, command: 8407,… zw device: 14, command: 8407, payload:
2018-01-08 9:24:46.044 PM EST
moments ago HUB zwjoin 14 zw:S type:0101 mfr:0086 prod:0101 model:0058 ver:1.03 zwv:3.83 lib:02 cc:5E,86,72,70,80,84,85,59,73,5A ccOut:2B,26 role:02 ff:…
2018-01-08 9:24:45.996 PM EST
moments ago HUB zw device: 14, command: 5E02, payload: 01 02 00 0A 00 0A 00 zw device: 14, command: 5E02,… zw device: 14, command: 5E02, payload: 01 02 00 0A 00 0A 00
2018-01-08 9:24:45.951 PM EST
moments ago HUB zwStatus device setup Z-Wave device setup started
2018-01-08 9:24:44.683 PM EST
moments ago HUB zwStatus device inclusion Z-Wave device inclusion started
2018-01-08 9:24:04.310 PM EST
moments ago HUB zwStatus include search Z-Wave include search started

I reached out to support late last night, I’ll post what they come back with.

Just adding to this that I am also seeing this same issue. I had 2 Minimote v1 working for a year+ but they stopped working around christmas/newyear. Been trying to exclude and add them again. The exclude shows in the app and log as successful. Then the re-add doesn’t show up in the app, but the event log shows that a device has re-joined, but as an ID as one higher then the last time. Meaning if I exclude ID 20, the next time it says the minimote rejoined as ID 21, exclude 21 and the next time its rejoined as 22.

Also tried to exclude multiple times in a row. After the initial exclude of ID 20, let’s say, every other attempt at excluding succeeds in the app and tells me in the log that device ID 00 was excluded.

I also have a ticket in to support.

I just got a response from support saying they don’t support these devices, so I am a bit confused…
They are both on the website under support - so doesn’t that mean they’re supported?


I’m trying to poke around a bit, and I figured I could create the device in IDE and assign it’s network ID because it clearly pairs from the log.
There is a device handler that exits (contrary to what support told me) but I don’t know how to figure out what the network ID is. Any idea how to find out what the z-wave network ID is?

The zwave ID should be the one that comes up in the “Events” log when it says “zwjoin” the value will be the ID. Also can see it in the Event that says “Aeon Minimote rejoined”, the value should be the ID.

I tried to assign a new device to that ID and it gave me an error (I was still using the default minimote device type" and when I included it again the events log had my new name for it.

I could be wrong about the ID, but my experiment suggests it is.

I’ll have to try it when I get home later this evening.
Hopefully support gets back to me with a better answer than “not supported” because hats not correct.

Searching around on GetHub found this

not home to test

found this on Gethub as well , a link to many device type files related to smartthings

got the new key fob connected to the ST hub but its not working correctly

and the older one is still working and has 1 thing different in the setup , in the old one has an additional feature in the current status of “button pushed”.
trying to find the process of setup to get the 4 buttons working, any help will be great

I am able to finally pair these devices, but when i click “button X” while trying to setup the device it gives me an error “Something’s Wrong. We Can’t load your screen right now.”

Any ideas?

you probably need to install the device handler for the 4 button key fob

I have one of these that I was able to pair with the built-in handler a few months ago. Everything was fine, until last night when I changed out the battery, and something went terribly wrong.

First of all, when changing the battery, the remote somehow got into group controller mode and I didn’t realize this right away. When I finally got it back into standard controller mode, SmartThings is registering the button presses in the notification log. However, none of the actions I have assigned to the buttons are functioning.

Secondly, I now have an additional remote and a “Z-Wave Device” paired during my attempts to get everything back up and running. Neither one of these devices are correct, and I can’t seem to remove them from the app.

Help please.

I’ve still not been able to make this device work. Not sure if anyone else has had issues. Ive been hoping for a software update or something but no such luck.

I had it working, I had the black with brushed steel on top slider. It took me long time to make it work, but I don’t have it anymore.