Aeon Smart Switch won't register

I received my third Aeon Smart Switch this morning, and the SmartThings hub can’t find it.

I’ve setup others without incident.

The hub did go INACTIVE last night…I believe due to a ISP service outage. I got it online again early this morning using the Red button on the back of the unit.

I’ve tried putting the new Smart Switch really close to the hub, so it’s not a distance related issue. I’ve tried connecting via the generic option as well as via the specific device in the Marketplace…no difference.

Just wanted to make sure there wasn’t anything else I should try before returning it to Amazon for a replacement.

@cmeans, even though it is NIB, did you try excluding it? I have had to do this before with some Z-Wave devices, even though they have never been previously added to a ST hub before.

May be worth a shot before going through the return process.

1 Like

The blue LED is blinking, which indicates it’s not registered on a Z-Wave network. Thanks though.

I would still go through the Exclude process, sometimes it has not been properly excluded and due to this will not work despite indications that it should.

OK. Certainly willing to try.

The instructions with the Switch do not indicate a way (on the device itself) to remove it from a Z-Wave network…not withstanding that it doesn’t seem to think it’s paired with a network anyway. There are instructions for using a Z-Stick or Minimote, but I don’t have either of those devices.

Where would I go in the SmartThings software to somehow remove it from a network?


Dashboard ->
_____ … Menu ->
__________ My Locations ->
_______________ Configure Options Wheel ->
____________________ Select Your Hub ->
_________________________ Z-Wave Utilities ->
______________________________ General Device Exclusion

While “Active”, power up your device.


That worked, and I was then able to pair the device.

Thanks to you both!

And it saved you the RMA hassle. :wink:

I am glad it worked out.

I’d already gone through it…but Amazon makes it easy. Easy enough to cancel the return as well :slightly_smiling:

I had the same issue attaching a few of these to Smarthings, with an older device handler (custom) installed. I could remove the devices by using the Zwave general exclusion option in ST, however after trying to discover and add to ST, the flashing blue LED went solid, the event log showed that the device was on, but ST never reported finding them. There was no entry for the smart switches via the ST Web IDE - Devices interface either. I could not remove this older custom device handler as SmartThings generated an errror “Devicehandler in use”.

Instead I cut and pasted the code below into the offending device handler using the web IDE:

After saving and publishing the edited device handler, I was finally able to attach the Aeon Smart Switch DSC06106…and they are working correctly now.