Aeon Multisensor 6 sending PIR reset incorrectly

I have two Aeon Multisensor 6 using DTH Aeon Multisensor 6 (Advanced) by erocm123. I have updated to the latest version of the DTH but still have the same problem. Both sensors are USB powered, firmware 1.08.

Problem: I have configured PIR Reset Time to 10 seconds. However, the sensors are still sending PIR reset after the default of 240 seconds. I can see in the debug logs basic set 0xff and basic set 0x00 being sent 240 seconds apart even when no motion is present.

Tried: Exclude/factory reset/secure add multiple times, but issue still remains. I have verified that parameter 3 which controls the PIR reset time is set to 10 from IDE/My Devices//Preferences.

It seems that the problem started after I ran the ZWave network repair, which was a mistake, I now realize. So, I tried exclude/factory reset/secure add, but problem persists. What else can I do?


So, the problem seems to be resolved now. For some reason, when I add this sensor to ST, it gets added but the add device never stops spinning giving the impression that the device was not added. So, I used to try again and again till the device finally showed up. This caused the problem. Similarly, when removing this device, the app never showed that the device is removed, but it is actually removed. So, my multiple attempts to add/remove this device was causing the issue. Not sure why the device never shows up as added or removed in the app.