Aeon MiniMote Stop Working


(Morgan) #1

Did something happen in the last few weeks to minimotes? I didn’t change anything, and i think i’m using the stock Device Handler for it.

Mine isn’t doing anything now, and I’m getting these errors in the Logging.

java.lang.NullPointerException: Cannot get property ‘displayName’ on null object @ line 83
ff8e42d6-ae84-403b-af2c-06a634ef55d3 7:57:36 PM: error Child device 32/1 not found


#2

did something happen in the last few weeks to minimotes?

Yes. They changed the stock device type handler and introduced a glitch. Supposedly it’s being worked on and may be fixed in some versions.

One community member who just bought one has been having trouble getting it to work and started a thread on that, but when I referred him to the other thread on problems introduced by these new changes, he felt it wasn’t related to what he was seeing. Still you might want to take a look at his thread.

And in the following thread you can see the discussion, including some comments from SmartThings staff members, about another Aeotec device. And that one has the same error message that you were seeing.

So report it to support and ask them to check with @jackchi in engineering if they seem unaware of the device type handler changes.


(Morgan) #3

Thanks @JDRoberts I emailed support, we shall see what happens.