Aeon Micro Smart Switch Problem


(Mike S) #1

I installed a 2nd Edition Switch today and paired to my hub without any difficulties. The switch is connected to an outdoor light fixture, and once it paired I am able to turn the switch on and off from my Things Dashboard. However, the switch is activating approximately every 60 seconds without any direction from me. I’ve set up a SmartApp that turns it off after it’s been on for one minute, but about 60 seconds later, it comes on again.

I’ve checked the wiring and that seems ok (it’s a standard 2 way flip-flop switch) and I’ve tried Excluding the switch and reinstalling it. I’ve rebooted the Hub and none of these have affected the switch in any way. I’ve also tried cycling the switch thru it’s three modes several times.

Has anyone run into anything like this or have any suggestions on where I might go from here?


(Edward Pope) #2

I would exclude the device and re-pair to the hub, IF that doesn’t solve it, I would assume one of two things. That the device is bad (most Likely) or that there is something in the area causing interference with the device.

Do you have any other devices with the same issue?

Also this assumes that you have it connected properly, which it should be given your description.


(Mike S) #3

I’ve already Excluded it and re-paired it twice. It’s within 2 feet of a Schlage that is working fine, so I’m guessing that interference isn’t the issue. This is the 17th device that I’ve connected to my Hub and other than the usual flaky presence issues, I haven’t seen any other problems.

ST support tells me that they haven’t seen anything of this nature in the past. I’ve opened a ticket with Aeotec but it normally takes them a day or so to respond. But, yeah, I think you probably right, it’s a defective switch.


(Eric) #5

@t2jock - is this the first Aeon Micro Smart Switch (AMSS) you’ve wired?

  1. nothing is connected to the AMSS signal input, no jumper and no wall switch?

  2. Did you mount AMSS at the wall switch? Power to the AMSS is always on? I do not think you can run the AMSS neutral to the switched-hot of the light fixture. So mounting the AMSS at the wall switch without a neutral will be unreliable.

The AMSS neutral must be directly wired to a fixed-neutral (not through a fixture); you can do this by mounting the AMSS AT the light fixture, which has switched-hot and fixed-neutral. Then the wall switch must always remain switched on.


(Ken) #6

Mike,

I had this problem too. The switch has the ability to be configured in different “modes” sounds like its in the push switch mode where the switch actually acts as a push on and upon release it turns off. The instructions state to hold down the button on the back of the module for two seconds or something like that to switch modes. I thought mine was defective too until i found that out.


(Ray) #7

Could be config but for 60 seconds to change state? That’s a pretty long delay. One thing to try is remove the switch and wire it outside with just hot, neutral and ground. Now try turning on/off with ST. Also delete all the smartapps associated with the switch.


(Mike S) #8

I’ve tried just about everything suggested and to no avail. I’m thinking that I may have fried the switch at some point in the installation by wiring it wrong. I’ve pulled it out and I’m going to replace it with a Hue Lux bulb and accomplish what I wanted with something that I know how to make work. Thanks for all of the ideas and suggestions.


(Eric) #9

do you have a neutral at the wall switch?


(Mike Maxwell) #10

By default the aeons do not have instant state change reporting enabled.
I’ve written a specific driver that includes state reporting options as well as control functions for the external switch.


and


#11

Hey Mike,
First and foremost, thanks a lot for creating these device handlers. They’ve significantly improved the state reporting time of my micro switches, and that’s made several of my automations work the way their actually supposed to!
I would like to use the strobe effect you’ve included in the handler with some of my alert automations, but can’t figure out how to have it included as a possible reaction. Do you know of a way to accomplish this? And also, do you know how to alter the duration, speed, etc. of the strobe/blink/flash effects?
Thanks!


(Mike Maxwell) #12

The device type exposes the alarm capability that can be used with stock apps, otherwise you can use rule machine custom commands to access the pre configured modes, blink flash and strobe if I remember.
The blink rate configuration parameters are available using the aeon advanced engineering documents that are available on their Website, I don’t remember them off the top of my head.