Aeon Labs Minimote with SmartThings?

That’s incorrect, but you can verify it with the manufacturer to be sure.

Some retailers, notably www.zwaveproducts.com update the firmware on G1.1 before shipping it, but you can do it yourself from a laptop. I’ve done it.

http://www.zwaveproducts.com/Zwave-Controllers/Zwave-Remotes/Aeon-Labs-DSA03202-v1-Z-Wave-Minimote.html

2 Likes

Excellent, I can blame you for tempting me into this deal then:

Minimote V1 on the way! :smile:

2 Likes

Updated to 1.19, added to ST, installed Button Controller SmartApp, works beautifully!

Just in case those with V1 remotes are confused as to what button to press to add it to SmartThings, you want to press the ‘Join’ button and then in the ST app, connect a new device :slight_smile:

Everything i’ve bought so far from iris works. It may take some tinkering, but it seems to work. The stuff seems to be made by Jasco, which is the same manufacturer as SmartThings devices. Pairing is a little more difficult. It seems to identify the devices as a “Thing.” Then using the IDE interface, I either assign it to the same type of SmartThings device—or add the code from MitchP via his GitHub postings. Works fine.

Just got a minimote. Updated to 1.19. Followed the smartthings instructions. Connected no problem.

I was then surprised by the button controller. I allocated button 1 to a hue bulb. and a long hold to the same bulb. I expected on the next screen to be given options for what the button does. but that is not how this works! now when i press the button or hold the button, it just switches the light on and off. I expected to be able to specify to alter the dim level or something.

Am i missing something? or is this literally just able to switch on and off?

Having read a LOT of posts now, but being very new to smartthings, I am assuming that I have to make a virtual switch and have the minimote activate that. Then I could use Rulemachine to do some more funky automations than on/off.

Is there a way to configure it so that holding the button will continuously increase the brightness until released?
Or to continuously cycle colours/coulour temperatures?

I presume i could use it to stop some of my rules in rulemachine, again with a virtual switch.

I’ve never set up a virtual switch. Ill give it a go. But would certainly appreciate hearing about how others have set up the minimote to do things?

I read bravenl had made his own controller. How does it differ to button controller? And is it available?

Thanks

Andrew

You don’t need virtual switches. You can incorporate a Minimote button push/held directly into Rule Machine as a trigger event. From that, you could a number of different things.

It’s not possible to use the Minimote as a continuous device, where holding the button down does something special (except for special devices that support it). In general, button pushes are distinct events.

Button Controller+ offers more action choices than Button Controller, but may not have what you’re looking for. You can find it here: SmartThings/Button Controller+ at master · bravenel/SmartThings · GitHub. Button Controller+ allows you to setup all 4 of the buttons in one app. However, you can do some in Button Controller+ and some in Rule Machine.

Thanks for this (and all you do!)

Do I install this code as a device handler or as a smart app? Im guessing the latter!

A

Button Controller+ and Rule Machine are both SmartApps. See the instructions for Rule Machine here: Rule machine - as per the app developer, this app is no longer available for new installs, distribution, or support.

For Button Controller+, in the IDE, My SmartApps, Create New SmartApp, From Code tab, paste the code from Github (which you can get by hitting Raw, then select all and copy), Save and Publish for Me. Then you can install one instance of that app from the MarketPlace/SmartApps/My Apps for each button controller.

JD, just wondering if your PC recognized that the minimote was plugged into a usb port. I plugged it in, the charging light came on, and I ran the aeon firmware update app, which indicated it was successful. But windows never seemed to acknowledge that a usb device had been plugged in. I guess it probably worked, just seems a little strange that a windows program could talk to a usb device if the OS never recognized that one was plugged in.

I’m sorry, I didn’t do that update myself, one of my aides did, so I don’t know exactly what happened. Hopefully someone else will know.

No worries. Does anyone know if there is a way to check which version of the firmware the minimote is running?

I recently added an Aeon Labs Minimote and I am having what appear to be key bounce problems. I press a key once, and my SmartThings hub records multiple keypress events. This causes whatever action I’ve linked to that button to trigger multiple times.

Does anyone else have this problem? Any solutions?

Thank you.

What device handler are you using? You might want to try out this new one. It’s been working great for me:

Also, check out this thread with a similar problem:

This sounds exactly like my problem. I will try installing my own button controller app as a workaround. Thank you!

Once I use the Smartapp Button Controller to setup the MiniMote it seems to work, however I can’t find a way to get back and change any of the settings. Am I missing something?

Yep…

Tayyip on the three horizontal lines in the top right corner of your screen. (That’s called the hamburger… Cause it’s fun, that’s why). Now tap on smartapps and go down to the one you need.

Thanks. Worked perfect. Now, if I have more than one MinImote do I have to install more than one button controller smartapp? If so, how do I name it?

Yes, that so requires multiple installs… And you name them in accordance with the current oceanographic hurricane making system.

2 Likes

BTW, I highly recommend marking each minimote on the back with a number or letter or colored dot sticker so you can tell which is which if they wander from room to room. :wink:

Then you can just name the button controller smartapp instance to match the minimote label.

3 Likes

17 posts were merged into an existing topic: Sudden problem with (2) Aeon Minimotes since yesterday