Aeon Labs Micro Switch Not Registering Manual Toggle


(brian) #1

As the title suggest my Aeon Labs Micro Switch is not registering when I toggle the switch manually. If I turn on the light from the switch the app still says off and none of the triggers are activated. Other triggers such as turn on at X time and off at Y are working fine though. Any thoughts?


(Niclas Walter) #2

Have the same problem. Did you solve it? Mine shows up as power outlet… Anyone who have fixed the problem?


(Mike Maxwell) #3

Try this DTH:

Set the state change to report in the preferences.
Once you’ve done this, you can revert to the previous device type if you like.


(Niclas Walter) #4

Tried it and set the “values” to:

blinker enum
param120 enum 0
param80 enum 2

Did not work… Tried just “2”, did not work either. When i manually hit the light switch it still says “on”.

Did I do anything wrong?


(Mike Maxwell) #5

param 120 represents the type of physical switch that controls the aeon, unless you are actually using a momentary switch of some sort, it should be set to 1.
By default param 80 is set to 0, best change response reporting is achieved when this value is set to 2.

What specific model of the switch are you using?
And, you can control the device via the mobile app correct?


(Niclas Walter) #6

Ok, Set the values you suggested, did not work either.
It’s currently working in the ST app, and in smarttiles. So no problems there.

I’m using DSC18103-ZWEU, and a “regular” toggle… Thank you for trying to help :slight_smile:


(Mike Maxwell) #7

That’s a newer model than the ones I have, so I have no way to test using one of them.
Are there any errors in the IDE when you’re setting the preferences?
It sounds to me like the configuration isn’t being sent to the device after the preferences are set…


(Niclas Walter) #8

Ah ok. Too bad. No nothing funny or errors during the whole time. The switches works even with the code and preferences set, just like before. Just same problem with it not showing “off” when i manually toggle the switch irl…

Thanks anyway! :sunglasses:


(Mike Maxwell) #9

can you try one thing?
set the switch type to momentary, if the preferences are being set, then the physical switch should only turn the light on and off when it’s moved from off to on to off again, or something similar to that.
It will for sure not be on when on and off when off like normal.
Just wondering if the preferences are being set, if they are then there’s something else going on with your setup.
If they’re not being set, then the DTH just isn’t working with that specific aeon module.


(Niclas Walter) #10

Hi,

Sorry been away for a few days, i will try this weekend.

Thanks for all your help!


(Niclas Walter) #11

Yeapp, you were right, I made a error when installing the switch. It’s now working when i followed instructions from the internet.

Thanks for your help!


(Pablo Gux) #12

Great! This device type also works for Aeon Labs Micro Switch G2 DCS26193!
I used the following device configuration (for the device in the Smartthings App)

  • State Change Notice: Report
  • Set Trigger Mode: Toggle

#13

This worked great. Thank you!

I have a perhaps silly question. Without changing the wiring of the device, is it possibly via the DTH to update the status of the switch in the app but NOT actually change whether power is being supplied? I’d like the status in the app to reflect on and off while power is being supplied the entire time.

Thanks.