Aeon Labs Home Energy Meter

Awesome, I’ll have to pick one of these up.

Where did you find this?

Open smartthings app, go to the ’ + ’ icon at the bottom, type energy alerts.

Thanks for the reply. I did the above. I do not have an energy section under plus sign.

not section, just search it

Still having trouble pairing this device. I have the powered one no batteries or button to push. It never shows up when. I push + the search does not find any devices.

Sorry I actually don’t have this device, just use the smartapp for monitoring wattage

You have to remove the front cover to access the battery compartment and pairing button. You do not have to have batteries installed but once plugged in press the button while pairing from your app.

button is behind the wall plate on the V2 hem.

@davglass - would you be willing to share your smart app logger ? That’s just what I’m looking for.

I scrapped it and just started using, there is an example app somewhere that posts to them. It’s free and it was easier than maintaining my own.

1 Like

That looks like exactly what I need too. Any chance you could share the code?

I’m hoping to log energy usage alongside device states (e.g. Thermostat settings, power and light switch statuses etc… to see what’s costing me the most money!)

Thanks in advance.

I just picked up one of these on amazon for less than $20. It paired easily and Installation went quick. My only issue is it doesn’t seem to update very often. Looking at the “recently” section there don’t seem to be any periodic updates on ST unless I have the app open and hit the refresh button multiple times (I have found the the most frequent I can get an update from it is about every 3 mins).

Shouldn’t this be sending regular updates to ST without my interaction? I tried to program alerts for high usage however they don’t seem to be working because ST isn’t getting any data from it. Me having to open the app to get it to refresh seems to defeat the purpose.

Any thoughts?

[quote=“FileMan44, post:33, topic:11646, full:true”]
I just picked up one of these on amazon for less than $20…[/quote]

That was exactly the reason I recently bought two of them, but in my case, neither is even reporting anything at all (troubleshooting mine here).

How hard is one of these to install?

In an ideal scenario (which is not what I have at my house as I found out, because of which equipment the builder chose to install, and how they installed it), it’s extremely easy to install, physically.

The difficulties most people have with it is in getting it to pair (no problem for me), and getting it to report (mine don’t report).

Physically easy but dangerous.

Getting the device to configure is either very easy or difficult. I wonder if the quality of the devices vary a lot.

1 Like

YES! :slight_smile: Sorry I didn’t stress that at all.

Exactly what I’m wondering.

How long does it typically take to get one of these to start reporting? And how can you tell whether you have a V1 or 2?

Here’s what I did to install:

Physically installed it.
Powered via USB. Dim red light flashing on the front through the white plastic.
Went into the IDE, created a device with Aeon Home Energy Meter Type using ST’s type
Showed up immediately in Not Yet Configured when I choose Connect New Device in Things in the ST app.

In the Thing, first two panels are just “–” then I see RESET KWH, Refresh & Configure, the last two of which do nothing.

Also, would I get this same result if I had clamp 1 & 2 reversed in their plugs into the unit?

Edit: Went & installed batteries. Dim red light still flashing after all this.

@mdawson my V1 started reporting immediately.