SmartThings Community

Aeon Labs Garage Door Controller

dth_garage

(Robert Vandervoort) #101

What hub version and which app are you using the new or classic ST app?


(Daniel Haugland) #102

v2 (EU) and Classic.


(Dandan167) #103

The device handler can not turn off the alarm and I don’t believe the actual device will let you either due to safety. You can control volume though.


(Dr. Mom) #104

You can’t turn off the alarm but there’s a way to remove them.
From the Aeon Labs support site. You can change the parameters as noted above or, easier, plug the opener into any PC or Mac (I’m also going to try it on my Chromebook) and open the flash drive. Delete only the music files. The alarm will try and sound but since there are no sounds to play you get silence. It might be fun to add your own sounds also but I haven’t tried that yet.

https://aeotec.freshdesk.com/support/solutions/articles/6000131922-disable-alarm-sound-in-the-garage-door-controller


(Robert Vandervoort) #105

I tried the parameter change to disable the alerts but it didn’t seem to have an effect. Sorry I have had very little time to work on this or any other hobby / fun stuff lately.


(Dr. Mom) #106

Thanks for that update,
I really think the easier option will be to use the second option and remove the sound files from the device


(Jon D) #107

I was able to change the closing sound to the opening sound. It is much more pleasant now.


#108

Please forgive my n00bness, but I’m having trouble getting this hander talking to my Aeotec Gen 5 Garage Door Controller. And I’m quite new to SmartThings so I’m sure I’m missing something obvious.

I’ve been following the steps here to load the new Device Handler in via the IDE: https://sep.yimg.com/ty/cdn/yhst-51756635596032/zw062-aeotec-garage-door-controller-using-with-smartthings-hub-custom-device-type.pdf

Then I’ve gone to “My Devices” tab, clicked New Device, and followed the prompt and gave it a “Device Network ID” of AEOTECDOOR01 and selected the type of the new device handler.

Now in the SmartThings app on iOS this new device shows up but just shows “Checking Status…” and if I try to tap on it it says “Can’t connect to device. Check device and try again”

I guess what I’m missing is, how do I actually pair the device with the hub? i.e. does adding the “New Device” via the IDE trigger the Hub to go into a ZWAVE pairing mode to try and find the Garage Door Controller which is in listening mode?

Hoping someone can close the basic gaps for me in my wrongdoings :slight_smile:

EDIT: I should also say, I have a SmartThings 2018 Gen3 hub… could this make a difference?


(James Yeo) #109

Creating the device doesn’t add the device, if that makes sense. You wouldn’t create a new device in IDE. You add the device handler, as you did. You then physically add the device in the app, following the instructions from the manufacturer. The device will add, and either pick up the handler you added, or once added you go back into the IDE and assign your custom handler.


#111

I just installed this garage door controller two days ago and I am having a couple of issues… They may be related however I do not believe it has something to do with Roberts device handler but I thought this might be the place to try after all.

Everything seems OK and if I do the calibration it all seems normal but sometimes (quite often) it
does not register the status of closed/open or it turns up as “unknown”.

When it goes from “closed” to “open” it stays a really long time in “opening” before changing to “open”. If anyone uses the IR remote to close the door, it does not register this thus ending up showing “open” when its actually “closed”.
“The opening” status can stay for up to 10 seconds before changing the state to “open”. Sometimes it just hangs there until I use the IR remote, which again turns it into “unknown”.
I guess this (turning to “unknown”) has to do with the fact that is has “frozen” or atleast does not communicate with the gateway (v2).

Are there any settings where I could change the delay for the open/closed status?
I have a xiaomi contact sensor which works like a charm on the door as well which I now use to be 100% sure of the doors state. I could use this but it seems like the tilt sensor that came along with the Aeotec is needed?

Any tips to what I can do or try next in troubleshooting?


(Adam Murray) #112

hey mate, the tilt sensor is exactly what you need. it tells the controller its open or closed state. i believe after a while (without the tilt sensor) it will just assume its closed which is why you have the delay. do the calibration steps in the aeotec guide with the tilt sensor installed and you should be good


#113

Hi Adam, thanks for responding. The thing is that I am talking about the tilt sensor. I have re paired it and calibrated it several times.

The thing is that when the tilt sensor goes from closed state to open it registers immediatley going into “opening” but it often ends up with not reporting more than that, or taking a very long time before it changes to “open”. And it does not seem to check the tilt sensors state afterwards, meaning that if the door is closed before the aeotec changes to “open” it will either end up as physically “closed” while aeotec reports “open” or it will be physically “closed” and aeo changes to “unknown”. I am going to double check whether it is the tilt sensor that causes this delay or if it’s the controller itself that reports too slow. I am thinking that the GDC might be the issue because like I said it does not look like it checks and verify the true state of the tilt sensor. As I see it, it should detect the state of the sensor (if its horizontal or vertical) and set its status to “open” or “closed” no matter if it missed any pulse signals being triggered by i.e an IR remote.

Or am I missing something really relevant?