Aeon Labs Energy Meter clamps

Ok, let me create another device type using that same code to make sure I didn’t do something stupid…

Give me a sec and I’ll be right back!

All is good on my end with the code above. I checked on a couple tablets, and 3 phones.

Would you mind going back into the device type you created and over write the code, just to make sure no odd lines of code made into yours?

here is what i just did:

  1. Create new device type from code.

  2. Pasted your code from github taking RAW

  3. Save and publish

  4. Change the device type over to this new device type “My Aeon Home Energy Monitor v1”

  5. Confirm in IDE that all data are showing up correctly:

  6. Still only getting a “?” for the tile without the gear icon :frowning:

1 Like

crapola, I have no idea what I can tell you now. Perfectly executed. Perhaps someone else with more expertise on how device types differ across phones/OS’s/etc. can help?

I think it’s time for me to “phone an ST friend” or use some other lifeline…

Seriously though, I’m at a loss to try and explain why that happens.

Thanks for the help… maybe someone from ST can chime in :smile:

I had the same problem with my Lennox iComfort device type. The problem is displaying values as string doesn’t play nice across OSes.

change powerDisp

    main (["powerDisp"])
    details(["powerOne","powerDisp","powerTwo","reset","refresh", "configure"])


    main (["power"])
    details(["powerOne","power","powerTwo","reset","refresh", "configure"]) 

and you’re more likely to resolve the issue on androids/windows phone. Androids and Windows Phones are displaying decimal points in the app and only iOS isn’t showing decimal points. You will lose the decimal points in iOS by doing this.

no dice :frowning:

20 characters

@cuboy29, I just updated my code on github, cut/paste 1 more time?

I think the code should be:

Thanks @copyninja

wahh still no joy… i’ll email support to see what they have to say. Thanks guys…

Just to throw my two cents in , i had the same problem with the question marks or the red error thing at the top of the page. This version works for me , however I only get the top three tiles on the device page. Randomly the other tiles will show through the configuration tiles for a second every 10 seconds or so. The updated ones all have errors for me even if i comment out the colors.
Galaxy S5

Thanks guys… I was able to get this version working.


  • Aeon Home Energy Meter

  • Author: SmartThings

  • Modified by: Joshua Seidel

  • Date: 2014-12-28
    metadata {
    // Automatically generated. Make future change here.
    definition (name: “Aeon Home Energy Meter w/Cost”, namespace: “Blueharford”, author: “BlueHarford”) {
    capability "Energy Meter"
    capability "Power Meter"
    capability "Configuration"
    capability “Sensor”

    attribute "energyCost", "string"       
    attribute "power", "string"
    command "reset"
    fingerprint deviceId: "0x2101", inClusters: " 0x70,0x31,0x72,0x86,0x32,0x80,0x85,0x60"


I made some mods to my liking. Not sure what I am missing with this version.

@johnconstantelo – I’m also having problems getting your latest iteration of code to work. Well it works, but no matter what I do I simply get a question mark (?) when looking at my “things” from the SmartThings app. I’m using an iphone 6 with the latest IOS 8.

Does anyone have any ideas? I can’t reset my stats monthly without it showing up properly in my SmartThings app. It’s logging fine, just can’t control it.


Hello guys,
Same problem here. Question mark with no info. Tried all the previous fixes and still nothing. I appreciate all your help. Will continue following this thread. Using Android.

Hello, maybe covered somewhere else but i found way (at least on my ios device) to get rid of the unknown or question mark. Basically set to default driver, goto into details of the device on the smartphone app, then via the ide change the driver to the new one, save, publish, then in the smarthings app on the same details page, pull down for refresh which should give you all the new tiles, then select the tile you want displayed on the main screen.

The unknown or question mark seems to be caused by the app remembering a tile that isn’t available after changing the device type.

Hope that helps.

I wish Xcel Energy here in CO offered this product.

Anyone know how to put the v1 device back into discovery mode so I can join it to my new V2 hub? Haven’t been able to get that rolling yet.

@3one5, there’s a button on the back once you remove the mounting plate. Exclude first, and reinclude. I was having some fun working on a device type for mine: (I’ll add the tiles for energy a little later)


Thank you! Be sure to post the code when you’re done!



looking very nice! will it work with the v2?