Aeon Labs Aeotec Z-Wave Smart Switch 6, Gen5


(Kurt Sanders) #21

I'm confused, did you solve the Z-Wave repeating with the WeMo Insight switches or the GE Z-Wave In-Wall switches?


#22

Sorry for the confusion. Only the GE Z-Wave In-Wall Switches fixed my Z-Wave repeating problem. The Aeon Labs Aeotec Z-Wave Smart Switch was advertised as a Z-Wave Repeater, but it did not help with repeating. The WeMo Insight switches are not Z-Wave so could not help my Z-Wave Repeating problem.

I did need some additional outlet switches for something else, and was planning to buy WeMo Insight switches since I have some already and liked them, but I bought the Aeon Labs Aeotec Z-Wave Smart Switches instead thinking that they would help with Z-Wave repeating, but it didn't help. So my comment was if I had known that they won't help, I would not have bought them and would have bought WeMo instead.

One thing I did not confirm was whether I needed BOTH the GE Z-Wave In-Wall Switches AND the Aeon Z-Wave Smart Switches to fix my Z-Wave repeating problem. I had not unplugged the smart switches from my network. I only know that with only the Aeon Smart Switches, my Z-Wave repeating problem was not solved.


(Alan Strauss) #23

I want to be able to shut off my washing machine automatically so I bought the AEOTEC Z-WAVE PLUS SMART SWITCH 6 GEN 5 and am running into issues with the limited range. I am not sure if I should get a repeater or to buy another brand zwave switch or a zigbee switch like (http://www.amazon.com/CentraLite-Lighting-Control-Xfinity-4256050-RZHAC/dp/B01BN6E1UY/ref=sr_1_27?s=hi&ie=UTF8&qid=1456934104&sr=1-27&keywords=zigbee+switch)


(Robert Vandervoort) #24

Sweet Cisco makes good stuff. You're using a controller as in stand alone or you on the Meraki ape? I considered the ones from Ubiquiti that are cloud managed but decided to go with a Netgear nighthawk instead which works so much better than my old n600. My house is just under 2000 sq feet and is two story so distance isn't that big of a deal. What I meant by cost is the point to point nature of Zigbee. What I like about z-wave is that it is a mesh network. It could probably be implemented better but I can reach from my closet to Timbuktu if I had enough devices! Of course it can mean choke points and single points of failure, but, for stuff that really matters like my alarm panel, or my servers / workstation, I hardwire. For me, wifi is for the iPad on the crapper :slightly_smiling:


(Robert Lanza) #25

I just installed my first Z-Wave device to my Universal Devices ISY994.

I actually have a Insteon home automation, it provides better 'pairing' or 'adding to the network' because it uses both RF and PowerLine (the original home automation protocol before Z-Wave and Zigbee, formally called X-10).

There isn't the distance issue.since most of the communication is done over power lines and not RF.

I do not use a Insteon Hub which is the equivalent to the SmartThings Hub.

As I said I use a ISY994 which is the central controller or Hub but it can handle both Insteon and Z-wave in one unit, so your not restricted to only one protocol. It can also do Zigbee.

And its got the most programmablity. IF THEN statements, variables, and a ton more.

However, its expensive and the programming and setup is not easy for those none technical people.

So today I setup my first Z-wave device the Aeon Labs DSC06106-ZWUS - Z-Wave Smart Energy Switch.

It was way too easy. I just put the ISY994 into listen mode for adding new devices.

I tapped the On/Off Switch (with the blue led glowing) and the ISY instantky added it.

Now I'm think of getting a few more but notice that Aeon offers newer models and wondering if they are better.

The models I'm looking at is:

Aeon Labs Aeotec Z-Wave Smart Switch 6, Gen5

The reason I want some of these Z-Wave devices is that the Aeon devices seem to do energy monitoring built into a regular ON/OFF switch.

The Insteon products do not do the yet.

Insteon does offer a separate Energy Monitor but its is not a ON/OFF switch as well, only Energy Monitoring.

I think the reason they don't build it into all their products is that there would be too much traffic on thev power line whereas RF can handle that kind of traffic.\

I am thinking about adding a SmartThings Hub as well, but not sure if I really need it.

I do own Samsungs Smart TV's, they are brand new Curved SUHD TV's with 3D.

I believe they might be able to be added to the SmartThings Hub?

Rob


#26

I can not get 'finding things' to see this switch two feet from the Hub. Do you enter it manually in code? Or use 'finding'? Or use another device from the list?

Thanks much. I got 6 of these as a replacement on a different failed project and am stuck with them. So i need to make them work somehow. :grinning:


(J Huycke) #27

Robert, I've used your device code for the Aeon Labs smart switch 6 gen 5. It works great... thanks for doing this. The one thing I would love to change is (tuning off or at least down the intensity of the light when the device is on... it's for use in a bedroom... when the device is on it powers a fan and means someone is sleeping and the light shines wright into the persons eyes.)

Thanks again,
Jeff


(Robert Vandervoort) #28

Hey bud. Thanks for the feedback. You'll find in the condiguration section
for that switch input behavior and brightness. Did the brightness setting
not work for you? The brightness has to do with the "night light" function
and related color setting in the details view of the device. The LED being
on and a specific color indicating watt usage actually doesn't have a color
or brightness adjustment. Instead you can change the behavior to 0 I
believe which doesn't do the wattage indication but only night light mode,
then just adjust the brightness setting. Arotec may change this one day but
at the moment that's how the device operates.


(J Huycke) #29

Thanks for the reply Robert. I completely forgot about that menu. Those settings worked perfectly. Like an idiot I was trying to go though the code or looking at the main screen of the app. Thanks again for writing the code. It's amazing.


(Phillip Slaughter) #30

I have 6 Smart Switch 6 Gen 5's paired to my v2 Smarthings Hub, as well as several other Aeon Labs devices, including an Aeon Labs repeater. All but one of the Smart Switches was recognized as a z-wave dimmer, which they are not. But they work just fine for my purpose. The last one I bought, keeps being recognized as an Aeon Labs Bulb! I've tried removing it and re-adding to my network, but no luck. I've tried both secure and insecure, but no luck.

I even returned it to the place where I purchased it and got a new one, but it does the same thing.

I don't have a problem with range, since I have multiple z-wave devices and the one that is the furthest from any other z-wave device or my Hub is about 30 ft. through two walls and a floor.

What can I do to get it to be correctly identified? Any suggestions? Any idea when Smarthings will support this device? There seem to be a lot of them out there.


(anthony croton) #32

I am in the same boat

I have one of these Smart Switch 6 and can not for the life of me figure out how to pair this. The ST hub just does not find it ....... I have reset the ST and the Smart switch double tapped the button on the switch for it to pair...... am I missing something as there is not a device type either for this. Any Help would be great thanks in advance.


#33

For my most difficult one I plugged it in right next to the hub while pairing and it worked easily.

In the same room, start searching, hit button once.

Then move it but run repair wave network several times to get other devices to know its moved.

Hope it works for you.


(Phillip Slaughter) #34

I finally found that I could get it to pair, but as an Aeon Dimmable Bulb. I never figured out why, but this can be changed to a Z-Wave Metering Switch, it works fine. Another suggestion I have is that one of these came & was apparently already paired, so I did an Exclude on it & then it paired, except this one was identified as an Aeon Dimmable Switch?? Again I changed it in the graph.api.smartthings.com website & it works fine.


(Jeff Pollock) #35

Hi Robert- I know this is an old thread and not sure if you're still using the Code for this device (Aeon Smart Switch 6, Gen 5) any longer ... I just got mine today and used your Code as my Device Handler. Seems to work great, so many thanks for that! Main reason I used it is that I wanted to set the ledBehavior=momentary. I was able to do that using the Smartthings IDE/web app.

I do have a question though, in your screen shot above it looks like there is also a way to do configurations in the phone App. But in my App, when I go to the "Gear" icon for Config, I get the "Error Refreshing Page" red banner. If I click the "Configure" button on the "Right Now" tab, there is no response.

Is this something on my end that I could fix? ...not sure where to start

Best, -Jeff-


(Robert Vandervoort) #36

That's weird. Android or iPhone?


(JEFF) #37

I am seeing the exact same thing


(Jeff Pollock) #38

Hi Robert- thanks for asking. It's Android 7.0 on the latest ST App.

Small thing, but the biggest bummer is that since that page is dead, I can't rename the device. So I have to remove the handler and then re-add it in order to rename it.

Thanks again for the work though, it reports the wattage just fine from the main page and so I can still monitor if the lights are on and how much draw they have.

Best, -Jeff-


(Jeff Pollock) #39

@Robert_Vandervoort, I put a few min into this today and figured out from an @RBoy posting (https://community.smartthings.com/t/release-enhanced-zooz-4-in-1-sensor-zse40-monoprice-15902-device-handler-with-temperature-humidity-motion-and-luminescence-sensor/55402/11) that there's a bug in the ST Android that doesn't like decimal range values in the Preferences. When that's there, it throws an error when trying to load the Config page of the ST Android App.

I took your latest build (0.4) and removed the decimal range values from the Preferences Inputs and all is fine now.

Thanks again for your work on this handler, very very nice fit for the Aeon switch.


(www.rboyapps.com - Make your home your butler!) #40

I'm just amazed that ST STILL hasn't fixed the issue in the latest ST Android app. @Jeff_Pollock do report it to ST support, only if there's enough push from users will they fix it.


(Robert Vandervoort) #41

Wait, really? WTF? I'm not using decimal values in range, 0..2 means the only valid values are 0,1,2... It's a normal legit thing to use. I think ST Android used to break ON actual decimal values in the past as I remember having to change another device handler for that reason. Another thing was negative to positive ranges android didn't handle gracefully, say -1..1... Honestly it's been so long I don't remember the specifics. @RBoy makes a great point, we need to make some noise about this. Input validation is a pretty important part of user interface design. I'm not going to go on a limb and say the preferences page design is in any way shape or form elegant, but it gets the job done. In my latest available but not really release device type for the zooZ mini plug I am allowing preference changes from the main tiles screen for real common stuff like the LED status indicator. Firing the code off and making sure it takes can be a challenge. I've got it for LED status and some other things but having some issues still, but that's another topic altogether. Glad you found it and there are folks spending time on it. I'll push another release with the Android happy stuff for now.

Thanks again.