Aeon keyfob wont lock kwikset 914


(Jonathan McGuire) #1

I have the keyfob buttons setup, #1 will unlock the door but not lock it, #2 works fine turning on and off my sonos. Anyone have a fix? I have even tried setting the long press as a command for the lock and that didn’t work either, just seems odd that is unlocks fine.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

Which SmartApp are you using?

It’s possible, just a guess, that the SmartApp is getting incorrect status from the lock (or a bug) and thinks it is already locked all the time.

Hence it will issue unlock command but never really tries to lock.

We can pull the code into the IDE to debug…


(Jonathan McGuire) #3

Using “Button Controller”, what additional information do you need and how can I get it?


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #4

Are you familiar with the Developer IDE?
You can add some log.debug statements to a personal copy of the SmartApp, such as printing what the current status of the lock is each time the button is pressed, possibly confirming or discounting my guess about the status problem.

If you’re not familiar with the IDE we can Skype sometime and I you can screen share live through the screens with me. I don’t think there is a tutorial video yet, so Skype etc is easiest to debug together… I find it mutually educational.

Private message me with your available times?


(Jonathan McGuire) #5

Thanks to CosmicPuppy, my keyfob and lock problem is solved! This guy took the time to walk me through the Button Controller SmartApp code in the IDE, and showed me how to trace with debug statements. He found a bug that was preventing the lock command. Not only is everything working great now, but I also learned the basics of Groovy in the process(Terry made me do all the typing).

This community is absolutely amazing. @April and @Ben, y’all really have something special here! Could you possibly add a “donate” button for members like @tgauchat so that I can easily buy him a few beers?