Aeon Home Energy Meter v1 -- Read Clamps Separately

Can someone please help? First I tested the HEM V1 using the standard DH and it works fine. I then loaded this DH and changed the voltage to 120 but nothing shows. Can someone steer me in the right direction?

Makes sense to me, since there are no batteries they are at 0% charge. Mine operates the same way.

Not sure why it’s not working. My usual troubleshooting steps when things aren’t working:

  • Remove the custom DH completely, log out of the IDE and log back in to confirm it’s gone
  • Remove the device (HEM v1) from the hub
  • Login to the IDE and initiate a reboot of the hub
  • Re-add the device (HEM v1) to the hub
  • Login to the IDE and re-create the custom DH with a fresh copy/paste of the code
  • Save/publish the custom DH
  • Apply the custom DH to the device (HEM v1)
  • Log out of the ST app (Android/iPhone), kill the app, re-login to the ST app

After finishing all of that fun, it’s usually working normally. Hope that help. :slight_smile:

Checked the HEM by reversing the clamps from my original HEM to the new HEM both show correct. So conclusion it is installed properly on the HUB V2. Next removed the DH then logged out of IDE. Excluded the device then rebooted the hub. Next installed the device, found fine installed DH and assigned it to the device. Same exact result. If it helps I am on OS X Sierra 12. 2.4 Beta, on the Mac and on the iPhone 10.2 Beta 4. I am at a loss at what can be going on here.

Go back to the IDE and confirm that there isn’t any white space at the end or beginning of the custom DH code. I had that happen once and it was causing weird issues.

No white space in front or rear. This is just crazy.

Not sure what to try, sorry Joel! :frowning:

Someone smarter than me will come along and help out, and I’m very curious to see what they come up with.

I tried it again after excluding it and it showed for 1 second then went blank. Not sure what is going on.

I think I know what the issue could be based on that description. It’s the infamous text/rendering issue between iOS and Android operating systems and the ST platform. I’d be curious to hear from any Android users if they’re seeing this issue.

I just installed this from the newer code [quote=“Jmtyra, post:1, topic:25480”]
look at Omyn’s post
[/quote]

I am also seeing 0%battery
I do have USB power but I also have good batteries installed.

Sounds like the problem. I hope someone else is seeing this it would be a step toward a goal of getting the clamps to read separately.

Sometimes you need to unplug USB power and let it recognize it’s running on batteries before a proper battery report will show up.

Thank you that cleared the low battery

1 Like

Problem solved!!

I had updated my first HEM to the current FW available from the Aeotec site (3.64) when I first got it.

Remembered that today, did a little thinking/reading and found this thread/post:

Which linked to this post:

Both of which led me to revert back to FW 3.61, which - TAH DAH seems to have resolved my problems. Reporting is normal, labels appear, battery level is reported at zero %, just like my other one.

So I now have one HEM on FW 3.60, the other on 3.61, and both appear to work about the same w/the updated two-clamp DTH.

Wondering if you guys can look at your device page for your HEM on the IDE and report back what you have. It’s in the “Raw Description” line. In the example below, the FW version is “ver:3.60.”

Raw Description zw:F type:2101 mfr:0086 prod:0002 model:0009 ver:3.60 zwv:2.78 lib:03 cc:70,31,72,86,32,80,85,60 epc:2 ep:[‘2101 31,32’]

Appreciate any feedback…clearly 3.64 (which is what Aeotec offers as the current version) isn’t a good version to run w/these meters, at least for our purposes.

2 Likes

I am not sure what version I have so you tell me. I hav e two below.

  1. 0 0 0x2101 0 0 0 8 0x70 0x31 0x72 0x86 0x32 0x80 0x85 0x60

  2. zw:F type:2101 mfr:0086 prod:0002 model:0009 ver:3.60 zwv:2.78 lib:03 cc:70,31,72,86,32,80,85,60 epc:2 ep:[‘2101 31,32’]

The first one - not sure what that is, doesn’t look anything like the Raw Description entry in the Device detail. Are you saying you have two HEMs and 1 above is the Raw description for the first one, and 2 is the Raw description for the second?

The second one looks like mine, and has the 3.60 FW on it.

Yes that is exactly it. My first was purchased about a year ago and I never updated the firmware as I don’t have a Windows PC just 5 Mac’s. The second is two days old.

When you flash it does it have to be excluded and repaired?

Dang @Omyn that’s a seriously sweet setup and some CRAZY power consumption!

Yeah, you should exclude it first, as it takes it off the network when you flash.

The updater is self-contained EXE…connect HEM to computer via USB, light will turn on on HEM (showing powered).

Run EXE and click the big “Update” button. Update runs and success report. Close updater app.

Then normal process to add to network and update DTH to this one or whichever one you want.

I am not sure I want to go through the process now. It means finding a windows computer and then excluding it. But since it is working fine why take a chance. I just wish I knew what firmware was on it.