Aeon HEM v1/v2 Firmware 3.64 Numbers are Off?

It doesn’t open the config menu - it pushes the config to the device I believe.
The config properties are set when you edit the device - top right corner click gear

1 Like

I have left the firmware at the version that came on the HEM as there were differing reports of functionality and it is functioning fine for me for over a year now.

This would make a lot of sense, so you have to edit the code and then open the device and hit config for it to be sent to the HEM.

Yes open the device in the app and click the gear (now in the IDE) - after that you set the parameters you want. When that is done you push config and it pushes that to the HEM

My “new to me” HEMv1 has mini-USB port. For my Aeon mini-motes I went to their support site, downloaded firmware update file. It is a windows exe that finds the mini-mote on USB and updates it.

1 Like

Good idea, here it is:

1 Like

Didn’t even realize there was an update. Missed this thread entirely. So the consensus is not to upgrade firmware on v1? I get random 20k readings, rarely, but it’s irritating, so this won’t fix that? This is why I like graphs:

That little red blip masks the fact that I use from 1-3kw, with the average being around 1k:

I still updated the firmware and I still get wild numbers, so I tweaked the code for my DH to look for anything larger than 10000. I thought that was a reasonable value to check against based on my home.

1 Like

is that configurable or do I need to go into the DH? I sometimes have a load over 10k so I will need to bump that up. My wild numbers are in the 200,000 usually

For now you need to just modify line 201 (or around that line number), but I can add another parameter to the DH so that you don’t have to modify code. I’m actually tweaking it now to add comments and code for iOS users to use instead of the ones that work for Android. I’ll post an update to the other thread I created earlier for my DH.


John would you please send me a link to the one without battery? Thanks.

No problem!

I can’t figure this out my HEM V1 is showing everything correctly but not sending data to ST. I don’t see any watts on the logging page. but when I click on recently it shows logs. Any ideas? It was working yesterday as it updated the Google spreadsheet.

The data is really in ST because the app wouldn’t update unless data changed. My DH stops flooding the device’s Recent Activity tab, and event log, with data unless min/max values change, or if it’s reset. That was a request I had almost a year ago from many, many, users. It still sends data to Google spreadsheets, it just doesn’t flood logs with tons and tons of event history.

Are you no longer getting data to your spreadsheet, and what app are you using to update your spreadsheet?

I get no updated watts sent to Google but the app on the phone is updating. I am using Simple Event Logger. Below is a screenshot of my IDE page please check settings. It stopped logging at 1.30 Pm today. I changed DTH, but put it back, so can’t figure out what I did. Is the voltage set right for a 240 volt two phase panel?

There’s a difference in how @krlaframboise’s app sends data to Google vs what’s done with another Google Sheets app and other apps like Grove Streams.

Because of those differences, my DH won’t work for you unless you want to use this SmartApp:

That app doesn’t provide the same amount of data as Simple Event Logger. There’s another person he’s working with on exactly the same issue, and considering this app does a lot more, I’ll have to look into what I can change in my DH to make it work with his smartapp. Stay tuned.

1 Like

Thank you that will be fantastic.

Cool. I just PM’d @krlaframboise to see what we can do.

What DH were you using before moving to mine? DO you still have a link to it or the github repo?

1 Like

No I was using the one without battery I only have a copy on my drive. But I tried using that no luck.

@ethayer/Erik - regarding above to clean up parameters could you answer a couple questions?

First, very basic…after I add the line to the config section, how do I make it do its magic?

Just add the line, save and publish and let the HEM sit for a few moments, or do something to it via the SmartThings app?

Second: I’m actually using a different DTH for my HEM as I’m using to read/report the two clamps separately. From this thread below. Can I add the line to the config section in that DTH, or would I have to use your DTH to accomplish the reset?