Aeon HEM v1 DH Discussion (DTH link in post 411)

So it would appear that when resetting, the reportType 1 was the biggest factor that affected logging. I am not sure why it didn’t log more frequently as a change in 50 Watts should occur far more than once a day. I modified the code and switched to reportType 0 and set the time to secondsWatts 5 and secondsKwh 15 respectively and now see data coming into PlotWatt properly. Mentioning this in case it helps anyone else.

Since I am hardwired, I also commented out the battery sections, and while at it, also commented out the configure button and moved the position of refresh where battery once was. Let me know if you want the revised version and I can send over, but it’s nothing complex or anything you couldn’t do yourself I’m sure.

Why did you modify the code to change that value instead of doing it via the parameters section of the DH?

Actually, I did make the changes from within the parameters section, but when I moved from the much older version of your code to this new one, I did the full reset, which is what caused my problems.

I still seem to be having some challenges with PlotWatt, but appear to be on the right path. My settings might be off from what I had previously and unfortunately don’t have a method of seeing what was configured before.

Got it. I haven’t tried PlotWatt yet. Do you have an easy tutorial or is there a discussion in the Community on getting started? I’ll double check my Google docs app, but I think I’m ok with that capturing my readings.

Depending upon how old the code was, it may have been using all the Aeon defaults. I use to have a document with those, but it’s long gone.

This is the only thing is says in the heading:

  • Aeon Home Energy Meter v1 (US)
  • DrShaw Modifications: Updated configuration settings and tiles

But the code itself might help as the defaults I think were left as is in your original version:

zwave.configurationV1.configurationSet(parameterNumber: 3, size: 1, scaledConfigurationValue: 0).format(),      // Disable selective reporting, so always update based on schedule below <set to 1 to reduce network traffic>
zwave.configurationV1.configurationSet(parameterNumber: 4, size: 2, scaledConfigurationValue: 50).format(),     // (DISABLED by first option) Don't send unless watts have changed by 50 <default>
zwave.configurationV1.configurationSet(parameterNumber: 8, size: 1, scaledConfigurationValue: 10).format(),     // (DISABLED by first option) Or by 10% <default>
zwave.configurationV1.configurationSet(parameterNumber: 101, size: 4, scaledConfigurationValue: 4).format(),   // Combined energy in Watts
zwave.configurationV1.configurationSet(parameterNumber: 111, size: 4, scaledConfigurationValue: 15).format(),   // Every 15 Seconds (for Watts)
zwave.configurationV1.configurationSet(parameterNumber: 102, size: 4, scaledConfigurationValue: 8).format(),    // Combined energy in kWh
zwave.configurationV1.configurationSet(parameterNumber: 112, size: 4, scaledConfigurationValue: 60).format(),  // every 60 seconds (for kWh)
zwave.configurationV1.configurationSet(parameterNumber: 103, size: 4, scaledConfigurationValue: 0).format(),    // Disable report 3
zwave.configurationV1.configurationSet(parameterNumber: 113, size: 4, scaledConfigurationValue: 0).format()   // Disable report 3

I keep it logging “in the background” as a sanity check for my influxdb logging. The service is better than thingspeak (IMHO) but it doesn’t do what it says it will, and figure out what runs in your house and how much electricity individual things use.

1 Like

That’s the exact SmartApp I am using for PlotWatt logging.

Not sure what is causing it, but if I exit the HEM Thing and re-enter, the last reset status and total usage go blank until SmartThings on Android is fully closed and reopened. Only those two fields appear to be affected and they show up and disappear when re-entering the device.

That’s a well known bug/feature with how ST renders text on Android vs. iOS. It looks good on iPhones, but like crap on Android devices. If the code you’re using still has “valueTile” for the tile having issues, change it to “standardTile”. That will help some, but Andoid devices will still have a problem rendering. There are many posts in the community about this. Search for “rendering”, or “text alignment” and you’ll find a few others.

That must make you absolutely nutty. Setting to standardTile makes it align incorrectly and valueTile shows correctly, but disappears until you close the SmartThings app and reopen. Looking at where the data comes from, both the energyDisp and energyTwo seem to be in the same zwaveEvent, so I can’t fathom what the big difference is that would have the odd behavior.

You have no idea… Up until the last update everything was looking great, and now it’s crap. Frustrating is an understatement, especially when DH’s should work for any of ST’s supported phone OS’s.

As the saying goes, if it’s not broke, don’t fix it. I had the original code of yours working fine and refreshing every 10 seconds IIRC, but now it doesn’t refresh unless I force it. I have gone as far as deleting the HEM, resetting all settings, removing any code, copying the latest version and adding as a new device type, then re-adding the HEMv1 by pushing the button a few times in the back.

Everything looks fine from what I can tell, but it refuses to auto-refresh, thus isn’t logging power changes as configured. I will contact ST support tomorrow in case there is an issue I am affected by and just unaware.

I just got a hemv1 and not sure if it is working correctly or not. Lots of small issues. Under “recently” the last update was about 12 hours ago (running on batteries at the moment). Cost is “–” even though I have entered some0.107 for cost per kWh. It keeps forgetting the icon I selected. On android the device image is not used (I think it was showing on ios though).

Does hemv1 accumulate data? Or if I miss a high load period (a/c on and frig/freezer running hard for example), due to how often the hem reports data, would it just not count that high usage period? Thanks!

Running only on batteries does limit how often (and what) things report (rounded up to the nearest 4 minutes when battery powered).

With all the other issues you’re reporting, I would recommend excluding it and re-including the HEM. If at all possible, do that when on AC power. If you did join it correctly using AC power, and then switched to batteries (perhaps you moved the device), pull a battery so the HEM powers down, and then put the battery back in. You should see a red light on the front stay on and never blink if it joined correctly.

No it does not accumulate. It sends whatever data it reads based on your preferences you set up. If you miss a high load, then I recommend adjusting the report type to 1 and setting a low “change in watts” value and a low % change value.

I got it installed last night into circuit breaker box and have it on AC now. It is updating much more frequently now.

The SmartThings app tiles seem to be updating but the data from power(W) doesn’t seem to be getting “sent” outside the app/tile…
(1) it is not logging to my GoogleSheets via SmartApp (last entry was 800.4W yesterday)
(2) it is not updating on my SmartTiles webapp. SmartTiles has been stuck at 800W as well even though the energy (kWh) has been gradually increasing every hour.

So I pulled the trigger on Hub V2 and had to readd all of my items to SmartThings.
Ever since then my HEM v1 has not reported, even with the original DTH I was using for it which worked beautifully for the previous year.

I tried this DTH, and it is still not showing me any data.
The device is connected to the Hub, and when I use yet a third DTH I get readings from it, but I don’t get the functions I want, such as in this DTH.

Anyone have any ideas?

Reset and re-add, then hit configure a number of times and watch the logs to make sure it fully updates the device. Also, running a z-wave repair may help. One of my HEM’s actually stopped reporting a few days ago, the others were working fine, repair brought it back to life. All of mine are ac powered, if using batteries, try the usb adapter.

I just went through this and found it necessary to exclude the HEMv1 from the SmartThings IDE under the hub\Utilities section. Once doing so, re-adding it fixed the HEMv1 reporting. According to Aeotec support, it may be due to the following reason:

Thats odd that the automatic reports are not working anymore while polling does, I am unsure what would cause this issue. Although it is possible that the association group somehow lost the smartthings hub (nodeID = 1), which may require you to re-associate ST hub to Group 1 of the HEM G1.

The steps were found on their FAQ in the following link: https://aeotec.freshdesk.com/support/solutions/articles/6000113113-how-do-i-factory-reset-my-aeotec-z-wave-device.

After rediscovering the HEM, I immediately started seeing data, but it was completely off, so a 255 reset later and reconfigure with desired values did the trick.

Just updated to the latest release and I’m seeing a warning FYI.

Thanks for passing that along @greg. I’ll have to watch mine to see if I get anything similar. It’s not something to worry about, but I’ll investigate regardless. It looks like some type of message from the HEM is being passed that the DH doesn’t know what to do with.