Aeon Doorbell Type Beta

I would have. But it all started when I hesitated to check it out and the wife said “KMugh, don’t be so scared, the burglar may get away!!”. So you understand, I had to.

@krlaframboise @wdavidow Thanks for the tip. Will try it out.

I first reported this issue back on December 15th, glad it is happening to someone else and I’m not alone. I have investigated to no end and still have not found out why this is happening. Updating the code and changing the default track seemed to have solved the problem however.

@driodguru Which device type code did you update to? I am extremely hesitant to change the current code given that it works for the most part for my needs (I spend a good while trying out different device types when I added it to ST).

I’m currently using “robertvandervoort : Aeon Doorbell - RV v0.5” as a device handler. No phantom rings everything has been working as planned for the past week or so, however a week isn’t a heck of a long time for testing but if I get another phantom ring I’ll let you know.

I have video 24/7 on it so I know when I get a notification if it is legit or not (especially when the kids are out of the house since the little ones like to press the button on the speaker.

I’m using “robertvandervoort : Aeon Doorbell - RV v0.5” as a device handler as well and the smartApp tiles do what they should, and the doorbell rings with the button. The one problem is that the alarm function doesn’t work. I have a push notification for the doorbell press, and that is triggered when the alarm is triggered, but there’s no sound. Anyone else experiencing this?

Have you tried the other device handler?

I’ll try that now. Thanks!

So with the robertvandervoort handler when I configure it I get the error “java.lang.NullPointerException: Cannot invoke method toInteger() on null object @ line 370”. But when I removed and readded it, the error stopped. I also get this error “groovy.lang.MissingMethodException: No signature of method: physicalgraph.device.CommandService.executeAction() is applicable for argument types: (physicalgraph.device.cache.DeviceDTO, java.lang.Boolean) values: [Aeon Doorbell - RV v0.5, true] @ line 41” when linking it to door sensors.

Also, the api gives me an internal server error when I try to change the device type of the doorbell, and when I removed the doorbell from ST it won’t let me delete the robertvandervoort device handler and that’s what it defaults to, so I can’t try the alternative at the moment.

Was that after trying the other handler?

That’s with the robertvandervoort handler.

See my edits above, I added more info at the bottom.

you could try overwriting the code of the DH with the code of the other DH and then just change the name and namespace to match the old DH

anyone else have issues with phantom doorbell rings when the temperature drops or rises?

Try replacing track 1 with a silent track. There’s a link to one on the other device handler’s page.

its not ringing track one its my doorbell ring track 2. it has to be the switch outside the contacts must be just a hair too close together.

Is there any sort of feedback from the doorbell to let me know whether I am pairing securely or not. I haven’t seen this mentioned in the forums before. (Also, I’m a bit of a noob.) I can disconnect the doorbell from my network and the ring starts flashing again. Then I double click the button and it seems to be flashing the same way as before. Then I pair. How do I know if I’ve paired using the secure method or not?

I’m able to get @thoward1234’s device type to work partially, but @Robert_Vandervoort’s device type won’t work at all. I’m guessing the problem is secure pairing.

[quote=“jjeff, post:420, topic:28889”]
Is there any sort of feedback from the doorbell to let me know whether I am pairing securely or not.
[/quote]I wrote a different device handler for this doorbell and someone else is running into the same pairing problem so I released a test version last night that allows you to use it with or without it being secure. If it solves the problem I’m going to add it to the official release.

Since this is a different device handler you would need to remove the device and the device handler, install the new device handler and then pair the device. The secure option is in the device settings.

The other person that’s having this problem hasn’t had a chance to test it yet, so I’m not sure if it will solve the problem.

1 Like

I’m having this issue as well, will test tonight and report back. Thanks for the new DH.

[quote=“techvudu, post:422, topic:28889”]
will test tonight and report back
[/quote]Thanks for being willing to test it because I can’t get mine to not connect securely so I’m unable to test it myself.

When I turn off the secure commands preference all the buttons stop working, so in theory if your buttons aren’t working by default, they’ll start working when you turn it off.

1 Like

@krlaframboise i have to give you some props and many thanks. Never has my bell worked from the app regardless of how many combinations of code I have tried in the past months. (except for Aeon Siren DH) I almost put it up for sale due to the fact that it was useless to me. Now I can set it to ring when any door opens which was the intent.

1st test was not successful (no secure connection), after removing DH, rebooting hub, and reseting doorbell then repairing agian, I can finally now actually ring the bell from the android app.
Before and After (sorry for red hue, it’s from Twilight app)