Aeon Doorbell Type Beta

I wonder if an external antenna wire to go through and behind the aluminium siding would do the trick? Perhaps it could be optional or just wrap around the back/inside of the button out of site but if needed you could pull it out and push it through a small hole in the siding that would be covered by the button…

We sent a request this morning to Aeotec to eliminate the autoplay. We’ll let you guys know as soon as we get any commitments from the manufacturer on the improvements coming for the next generation of product. Thanks again for all your feedback and patience!

2 Likes

I totally agree and in my communications with them I mentioned this flaw. At the least it should be a preference.

1 Like

Ok I need some guidance here. Hopefully someone can help me.

I just got my doorbell, and I got the device type installed using https://github.com/jamesdawson3/SmartThings/blob/patch-1/Aeon%20Doorbell/device_type-aeon-doorbell-v0.4.

I can go in my devices on the app, and have all the options with the device. However none of the switches or tests are making any noise? If I hit the test sound button…Nothing if I hit the off button, it goes Ringing, but no sound. I dont know where to go from here?

Also, the doorbell button came with no battery? Is this normal? If so a bit odd, now I have to go find the battery.

Thanks

Same experience here. I thought I didn’t hear anything because I’m deaf, but placing my finger over the speaker, there was also no vibration.

I had to remove the device, exclude it from z-wave, and then “Connect New Device” three or four times. I then used the v0.2 version of the device type (it’s available earlier in this thread, I think). All I want is a doorbell and for some reason that version seems to work better for me.

The doorbell now works, I can’t hear it, but at least the speaker vibrates. I used Rule Machine to have it blink lights when the doorbell goes off.

Barry.

1 Like

Go into your device preferences in the IDE and be sure all boxes have a value. Also be sure to hit configure in the device page in the App. Let me know if that doesn’t do the trick. See posts #278-280.

1 Like

Brilliant for your situation.

Yet another important reason that the autoplay/virtual switch going on automatically when power cycled needs to be optional / eliminated.

1 Like

Yes, I hope Aeon is watching this thread.

There are several excellent product enhancement suggestions mentioned this thread. These include:

  1. Power cycle autoplay eliminate option above
  2. Option for an external antenna that can be threaded behind an obstruction.
    3… (I’m sure I missed a few)

I’d like to add a much, much louder speaker. I also have the siren. The volume of that is more appropriate, and even that should be louder. People can always reduce the volume using the configuration options – too loud will never be a problem.

My hearing friend has mentioned that he can barely hear the doorbell.

Barry.

If I hit the configure button nothing opens up? Im guess that’s not normal.

I have made some headway…Some sounds are working. I was able to add a sound and connect it to a Rule in Rule Machine.

But when I go into the device nothing works there…

Also if I press the doorbell it takes 3-4 pushes before it makes a ding?

I am using the android App.

When I hit the Configure button on the device page, also, nothing happens.

In order to set parameters I have to use the Edit Device option from the menu in the upper right corner.

I just mounted my doorbell. I put a 1 inch thick block of wood between the doorbell and my aluminum siding. There are also miscellaneous screw holes hidden behind a block of wood. This works.

I may be restating the obvious, but this doorbell seems to easily suffer from interference. When you press the doorbell be sure you are not holding it in your hand or between your fingers. Place the doorbell on a table or something wooden. On a table the doorbell has worked for me from the other side of the house, rooms away.

Barry.

You have to go into the IDE and check that all settings have valid parameters, this is NOT the same as doing it through the app. The configure button doesn’t “do” anything when tapped in the app, it’s just sending parameters to the device and there isn’t anything that pops up saying it was successful. So not seeing anything is normal. However, if you live log in the IDE, you’ll see if it is successful or if it is throwing errors. This will help us figure out what your issue is. As for the button intermittency, I think this is just a hardware problem, as many have pointed out, possibly due to holding it in your hand.

[quote=“canalrun, post:324, topic:28889”]
When I hit the Configure button on the device page, also, nothing happens.
[/quote]I use the android app and I too thought you had to hit the configure button to change the settings, but if you choose Edit Device from the menu, you can change those settings. This is just a guess, but I think after you leave the Edit Device screen you have to click the configure button to have the settings sent to the doorbell.

OK great. I set all my parameters and then hit configure. Just curious is any thing supposed to work in the app? The test tone? Bell? When I switch there off button it says ringing, but no sound. Is this normal?

I’m pretty sure the first time anyone installs the device type they’re going to get errors because of that bug on line 359. The prefRingtone gets set on the previous line so checking if it has a value instead of checking prefAlarmtone prevents prefAlarmtone from getting assigned a default value which is why everyone is getting null errors.

I’ve fixed line 359 - so assuming he has the latest version, that shouldn’t be the issue. If you first install with a different device handler, say the default Aeon Siren, then switch to the doorbell device type, the old settings don’t seem to get cleared. See post #279. So if one of these “residual” settings is still there and doesn’t have a valid parameter it throws an error.

Turn debugging on in the settings and post some logs, if you wouldn’t mind. It’s hard to know what’s happening without the logs. Alarm test, bell test, and playTrack should all make the doorbell play sound.

[quote=“jdawson, post:329, topic:28889”]
I’ve fixed line 359 - so assuming he has the latest version
[/quote]I could have sworn when you released version 5 it still had that bug, but maybe I’m just losing it. Thanks for making the change.

I know someone recently mentioned installing one of the older versions so my previous post would still apply for them. I think one of the older versions also had the default track set to 6 which doesn’t exist so that could also be their problem.

Yeah I fixed it after you mentioned it, but I didn’t rev the version or really advertise that I made the change…so my bad haha. Changed the default track from 6 to 1 too.

Bell not ringing with button can also be due to the poor battery connector. Carefully bend the tabs out, make sure it stays centered as you put the cover on and rotate it to stay in place

it’s nice to know I’m not losing it.

I just noticed that the only button that works from the android mobile app is the alarm. Those buttons used to work, but I haven’t tried them in a while so I’m not sure if the problem started in version 4 or 5.

Everything else, including the physical button is working fine.