Aeon Doorbell Type Beta

Any interruption in power will cause it to play Track 1 which is why we recommend replacing Track 1 with an mp3 that’s a couple seconds of silence.

Hmm, interruption in power to the siren or the button? If it’s the button, then that could maybe be it - I know cold messes with batteries… If it’s the siren, not sure that is it - my house is newly renovated and I haven’t noticed anything like dimming of the lights or anything like that when the randomness has occurred.

I suppose I’ll finally go through the process of setting up sounds on the siren - I’ve been putting it off, but I want to set up specific alerts for all my sensors, as well as a louder/better doorbell sound.

I’ll try this, thanks!

Just out of curiosity, how are folks setting up the Notify Me When for the doorbell? It’s something I’d like but can’t get it to work. I only see the device available for Switch Turned On and Switch Turned Off, neither one appears to work.

I’ve set it up as a ‘Switch Turned On’ notification for the doorbell, and then I have it fire me a text/push message with my custom text (‘Someone rang the front-door doorbell.’).

It works great for me - haven’t had any issues with it.

[quote=“Aelstrom, post:367, topic:28889, full:true”]
how are folks setting up the Notify Me When for the doorbell? It’s something I’d like but can’t get it to work. I only see the device available for Switch Turned On and Switch Turned Off, neither one appears to work.
[/quote] I wrote a similar device handler that supports the Button capability.

The switch turns on every time the button is pressed or the alarm goes off so this method won’t work well if you decide you want to use the alarm.

Ah, makes sense - I haven’t set it up as an alarm yet, so I wouldn’t have run into that issue.

I get at least one ring every other day at random times. The first time it happened was at 3AM the day after I installed it. I spent a good 5 minutes outside in my boxers on a really cold day trying to figure out who rang the door bell.

1 Like

I recommend you put on pants prior to investigation. Especially in the cold. :smile:

1 Like

I took the recommendation from @krlaframboise to change my doorbell track to anything other than track 1 - for anyone REALLY interested, I made my own custom doorbell ring using this clip:

All good so far. No incidents of the phantom ring, thus far, since adjusting the track!

I would have. But it all started when I hesitated to check it out and the wife said “KMugh, don’t be so scared, the burglar may get away!!”. So you understand, I had to.

@krlaframboise @wdavidow Thanks for the tip. Will try it out.

I first reported this issue back on December 15th, glad it is happening to someone else and I’m not alone. I have investigated to no end and still have not found out why this is happening. Updating the code and changing the default track seemed to have solved the problem however.

@driodguru Which device type code did you update to? I am extremely hesitant to change the current code given that it works for the most part for my needs (I spend a good while trying out different device types when I added it to ST).

I’m currently using “robertvandervoort : Aeon Doorbell - RV v0.5” as a device handler. No phantom rings everything has been working as planned for the past week or so, however a week isn’t a heck of a long time for testing but if I get another phantom ring I’ll let you know.

I have video 24/7 on it so I know when I get a notification if it is legit or not (especially when the kids are out of the house since the little ones like to press the button on the speaker.

I’m using “robertvandervoort : Aeon Doorbell - RV v0.5” as a device handler as well and the smartApp tiles do what they should, and the doorbell rings with the button. The one problem is that the alarm function doesn’t work. I have a push notification for the doorbell press, and that is triggered when the alarm is triggered, but there’s no sound. Anyone else experiencing this?

Have you tried the other device handler?

I’ll try that now. Thanks!

So with the robertvandervoort handler when I configure it I get the error “java.lang.NullPointerException: Cannot invoke method toInteger() on null object @ line 370”. But when I removed and readded it, the error stopped. I also get this error “groovy.lang.MissingMethodException: No signature of method: physicalgraph.device.CommandService.executeAction() is applicable for argument types: (physicalgraph.device.cache.DeviceDTO, java.lang.Boolean) values: [Aeon Doorbell - RV v0.5, true] @ line 41” when linking it to door sensors.

Also, the api gives me an internal server error when I try to change the device type of the doorbell, and when I removed the doorbell from ST it won’t let me delete the robertvandervoort device handler and that’s what it defaults to, so I can’t try the alternative at the moment.

Was that after trying the other handler?