SmartThings Community

Advice on dimming groups of CREE led bulbs


(justin) #1

I just switched to Smartthings from a wink hub today, and I’m having some issues controlling groups of CREE led bulbs. I’ve tried dim with me, and cannot get the dim functionality to work at all. If i set to zero, they all turn off, but if I try to set 50% dim, only the master bulb will dim.

I’ve also tried rule machine, and can’t get that to work at all either. It seems to have no effect at all.

I think it could be an issue with device type, as something I read from the developer of dim with me said the wackware ge link device type had to be installed. unfortunately, installing this on the cree bulbs results in me being unable to control the bulbs at all.

I’ve been researching and trying things for a few hours now, giving up for a little bit so I thought I’d reach out and see if someone else could point me in the right direction.

Thanks for your help


(Scott G) #2

Try modifying the Dim With Me code a bit. In both the installed() and updated() sections where the subscriptions are, change “switch.SetLevel” to just “level”.

Good luck!


#3

I’ve had good results using this:


(Nick) #4

I was having issues with CREE bulbs and “The Big Switch”(exactly the symptoms you describe).“Dim With Me” works if I use a Virtual Dimmer as the master. Not working with CREE or GE Link bulb as the master.
So you can either use the Virtual Dimmer as the master or look at the virtual dimmer device type and it may give you a clue to fix the CREE device type. Hope this helps.


(justin) #5

Thanks everyone, I was able to get it resolved with a combination of sticks18 and nsweet advice. I modified those sections of code, switched to “a better virtual dimmer” and then set the virtual as master. Only annoyance is I have a group of 4 bulbs and they all dim individually over about 5 seconds. Oh well though it’ll work for now.