ADT SmartThings Automations?


Did you get it working with the above information?

I’m trying to create a device. What do I select im the drop down field for “Type” I don’t see anything that will work for this.

I added a generic device tile for the status: “Away”. I tried making one for “Stay” but the field no longer has “Generic Device” to add anyone devices. Just confirming I need to add 3 devices? One for Stay, Arm and Away?

I added a device like this but don’t understand how to set the commands you have in code. I added a device handler with your code but I think I’m lost. Hell I’d pay someone with PayPal $20 to walk me through every step

For the type field you should be able to scroll to the bottom and see “ADT Momentary tile”. Select that. If it is not there go to the Device Handler page and make sure it says published next to the the device handler you downloaded. It should be labeled “ADT Momentary Tile”.

If you can’t get that to work you could use the the standard on that is in everyone’s IDE, “Momentary Button Tile” as well. It just won’t work in the new app

Yes you need on for each mode. So you will need a button for Armed Stay, Armed Away, and Disarmed if you want the smart app to be able to change to that Alarm mode.

That is what the device setup looks like for one of my 3 ADT Buttons.

That is what the Mode change child app looks like in my setup. Simply different buttons linked to each alarm option. A delay to enable the any alert sensor child app delay. And the alarm panel to communicate with

The device handler should look like this from the “My Device Handlers” screen.

Okay so this is what I’ve done so far. I’ve created Smart Apps for ADT Toos and ADT Mode Change. I copied the codes provided into the “Code” section. I published both apps. I’ve also created a Device handler as directed and published as well. Lastly I added 3 devices titled: ADT Arm/Stay Button, ADT Arm/Away Button and ADT Disarm Button and added the ADT “Type” you mentioned (It was towards the bottom of the drop down), and published each device. I am not sure if there’s anything else I am missing but I don’t have the same options you provide in the screen shots for Automations. Does it matter if I select your GitHub Repository for the Device handler? When I select the drop down menu, I don’t have the option to select yours. This also applies to the Smart Apps. I can’t see your Github repository. And lastly is there a order to do all this? I assume it’s Smart App first, followed by Device handler and then the devices themselves. Sorry for all the questions. I am by no means an expert at this. I love technology but suck at programming stuff.


There really is no order when it comes the smartapp “ADT Tools” being published, the child apps for ADT Tools, the device handler loaded. Once those 3 things are done you need to setup your buttons using the Device handler.

You can confirm that the devices are valid as they should be available to activate in the apps.

Once that is done you need to setup the ADT Mode change app similar to what i did above. You may have to use the Smartthings classic app to do the first setup of the smartapp. That would mean from the classic app, Tap Marketplace in the lower right of the screen, then select SmartApps in the upper right. Last click on My Apps. The screen should load your custom apps and you should be able to click on ADT Tools. Once you select ADT Tools you should see see an option for ADT Mode Change. Select that app and then populate as I have above. Then you should be good. Once that is done you should be able to go find the button in either app and select it to change the alarm mode from smartthings.

The screen shots I was providing above are the setup screen for the device handler and the options we doing the setup of the ADT Mode change app. At no point was I doing anything with automation. You will need to set your automation to push the button configured for it to activate each mode once the ADT Mode change app is working.

Just as a reminder if you haven’t looked at it there is allot of good information at Things That Are Smart - ADT Tools

I appreciate the help but I’m still not having luck. I read the link you provided and don’t seem to understand why it doesn’t work. I now added all the child apps along with everything else and the below images are all I can see. I don’t have addtional options to set the virtual button as you do in the screen shot you provided. The only thing I can think is that I am unable to add your repository in the drop down menus for everything or that the child apps are published. I think I’m going to give up at this point. If there is a YouTube video you know of demonstrating every step, I would try probably give it one more try. Thanks for your help.

From that print screen the buttons look good.

You certainly do have some issues with the mode change app. You should have 5 things to setup when going into the app as show in in my previous screenshot. If you don’t have that then just delete it and download it again from the repo.


That is what the info looks like in my IDE for my repo. Just to clarify
Owner = Mavrrick
Name = SmartThings-by-Mavrrick
Branch = master

That repo is open to the public so you should be able to get the apps right from there. If you can get that working we can ensure there are no issues with getting the apps into yor IDE.

In your IDE you should see something like this that will list the parent and child apps. Notice only the ADT Tools app is published.

Once all of the apps are loaded you should go to the Automations tab in the Smartthings Classic app. Click on the Smartapps tabs in the upper right. Scroll down all the way to the bottom and click on “+ Add Smart App”. From there Select “+ My Apps” at the bottom. Most Likely you will see “ADT Tools” near the top of the list of smartapps. Click on ADT Toolsand you will be presented with a list of child apps. From their select the option for “Allows Changing Alarm Mode from Smartapps” option and you should see the ADT Mode change app pop up and it’s setup options. Configure it as we have discussed earlier.

I redid everything but when I don’t publish the other smartapps, they don’t show up on my smartthings classic app. The only thing visible is ADT Tools. Still not working. Thanks though

That is right. Now click on the ADT tools app. You should see several options and the mode change app will be in that list. It doesn’t say ADT mode change though. It is labeled as “Allows changing of alarm mode from smartapps”

Yea I could probably make that association more clear.

The ADT Tools acts as a container for all the other pieces.

I probably made one small mistake because it still only shows me to assign a name and set for specific mode(s) which is Away, Home and Night. My devices say they are all on and stay in that status.

Did you github to work?

Do I need to do anything in Github besides copying your code and info into IDE? I have a Github account but have never used it before.

All you should have to do is copy the code.

If you have a github account all you should need to do is go through the setup process in the ide to link to your account. Then add my repo. Once my repo is added as shown listed in the previous post you should be able to click on update from repo and select mine from the drop down list. The ide will list the apps. You just click the checkbox next to each app and click on execute. It will down load them.

The fact you dont have any input values looks like you somehow didn’t get the code properly in the IDE. It is like you got the very first page that was on your screen, but didn’t scroll to the bottom. Maybe that is the next question. If you open the code for the app in the IDE, how many lines of code do you have for the apps.

If you get github setup that takes the manual copy and paste step out. You just tell it what apps to download after telling it to update from repo.

I was able to add your repo by manually entering it in IDE. Not sure if I need to do anything with Github besides what I did copying your code and commands over into IDE.