ADT Smarthings hub works EXCEPT won't activate ADT

While I have signed up for ADT services, the Smartthings app ignores that and keeps telling me to “Get Started” and on the hib it says “Not Active”. When I go to ADT’s site from within the app, it sees the location I created with contact info and credit card, but after clicking OK, it keeps reverting to ignoring that fact and tells me to “Get Started”. If I try to upgrade from security-only to “Total Protection”, it says “Your previous plan enrollment has not been completed. It must be completed in order to change to a different plan”./ Call ADT, they blame Samsung and say to call them. Call Samsung, they say to call ADT.

Had been enrolled on this hub but got stuck and could not finish adding more ADT devices. Both support teams said to reset it all and start over.

I’ve done factory reset of ADT Smartthings Hub (the “hold down both blinking buttons thorough reset” variant to even forget SSID etc). Tried to set up and got to this point. Both support teams said that either the ADT or Smarthings account was causing issues holding on to bad data. Deleted the Samsung account totally, verified that IDE refused to log in. Then set up a new Smartthings account using girlfriend’s email address and phone. Added ADT Motion sensor and Door sensors, 1 each. Set up a new ADT account with her email/phone/credit card. Signed up for Home Security Monitoring with the first 30 days free. Thought things would be great.

They were not. It did not appear that the Smartthings app realized I had actually signed up. So I repeated the process, clicked the "Get Started’ and logged in with new ADT account for girlfriend, and ADT immediately showed the newly named location I had created, new contact info, and previously selected plan and last digits of credit card. Clicked OK, got dropped out to same main screen of app saying “Get Started…” Repeated that a few times to be sure. Smartthings did not think I was signed up, ADT did.

I added a CO sensor. The App then realized I could have safety coverage, not just security. Great, I thought. Signed in with that new account, chose Total Security Bundle. Acknowledged through to be charged $34.99, but that failed. It said “Your previous plan enrollment has not been completed. It must be completed in order to change to a different plan.”

So I am stuck. ADT thinks I partially have a plan, but Smartthigns is not showing any indication that there is anything.


I could not run my card through on the app, so I called it in, which caused a similar problem. As long as ADT support says it is showing up right on their end, call samsung and get them to set the flag on your account. Keep at it until you get it hammered out, insist on doing a 3 way call between ADT and Samsung if they try giving you the run around.

That is typically a support agent not even in the same zip code as a clue looking to keep their metrics short and close out the call… They hate the 3 way call thing, and if they try to refuse insist you be escalated to their supervisor. Don’t take no for an answer…

found a solution despite being told not solvable by both smartthings and ADT.

  1. Smartthings ADT accounts cannot log in to MyADT, ADT Pulse, or ADT Control. But they can log in to ADT Canopy!!! Logged in there, dug through to billing page on discontinued accounts, clicked small gear mid-page, and chose to cancel. That is where it is possible to cancel ADT Smartthings accounts which you can’t get to in the Smartthings App. That web page is
  2. Canopy GUI still said service to newest location (only remaining one) on newest account (all other locations were gone after cancelling their accounts) was “incomplete”. Tried a few times in Smartthigs App to validly complete with login, selection, acknowledgement, etc., but no change. I then got it to correctly “complete” what the Canopy GUI said was incomplete by going in through the SmartThings Classic App and doing exactly the same steps which were not successful in the new SmartThings app.
1 Like

I have been having the same problem with the App security card not working. I haven’t gotten around to trying my other phones the app is on yet, to see if it’s just one phone or not. This works for me, thanks!