ADT hub won't connect to new devices

Frustrated with my ADT hub - I’m unable to add new devices. I get to the Registering… pop up and it just sits there and spins. Had trouble a few days ago, tried again this morning as was able to connect one sensor, but no more. Things I’ve tried:

  • Pulled hub off the wall, disconnected power and battery and rebooted
  • Z-Wave repairs, multiple times
  • Dug into the IDE - did a reboot from there
  • Read the logs - it doesn’t appear that the hub is getting the “include search” command

Called customer service, he had me:

  • Remove both apps (new and classic) and reinstall just the new app
  • Hard reboot (power and battery)
  • Set “allow unsecure rejoin” in the IDE
  • IDE reboot

Still nothing. Getting elevated to “Tier 2”, we will see what that entails.

I’m thinking it is some sort of communication issue - sometimes commands from the IDE don’t make it to the hub (IDE reboot). I don’t think it’s on my network side since my other WiFi devices are working fine, but for some reasons commands aren’t getting to the hub.

Another weird thing - I can see my hub in IDE on my desktop, but not my chromebook or phone. All are logged in to the same account.

Anyone have other ideas on how to fix this?