Adding AEOTEC Range Extender 6 (zwave plus)

maybe @Kianoosh_Karami can help us out

Are you aiming to use a custom DTH for the Aeotec Range Extender 6?

FYI: FAQ: My lock/device does not pair or appears to pair but it won't show up in the mobile app or IDE - stale DTH

No, just trying to add it. It goes to 30% and just stays. I never see the device in my list but if I use z-wave exclude, it drops one device.

I guess I do have some custom DTH’s for the Iris z-wave extender but that shouldn’t be the same id as the aeotec, right? or wrong?

I have spent the past few days making additional attempts to pair the Aeotec Range Extender 6 (ZW117) with my SmartThings v3 Hub (GP-U999SJVLGDA), each time with less and less enthusiasm.

I have tried everything suggested … and more! NOTHING HAS WORKED!!!

I tried pairing (as did @dworkman) a number of times using the SmartThings Classic App. Each attempt to pair failed. I found using the Classic app in this application more problematic than the newer SmartThings app. I can see how the Classic app might appeal to those trying to set scenes, etc., but I failed to see how it would be helpful in pairing a device released well after the Classic app was replaced by the newer one … but I tried it anyway.

Then, as luck would have it, my Lutron GL-1000 (dumb but, until now, reliable) Dimmer controlling the kitchen lights failed on Tuesday. I took this opportunity to purchase and install a GE/Jasco #14295 In-Wall Smart Dimmer, as doing so would possibly obviate the need for a Range Extender by placing this powered Smart Dimmer (sort of) close to the location in which I had initially intended to install the Range Extender. Doing so would also allow me to implement the numerous suggestions to use a powered Z-Wave device as a repeater/extender instead of a dedicated Z-Wave repeater/extender which served no other function.

This Smart Dimmer is located about 11’1" from the ST Hub and 12’6" from where I would like to place the Aeotec Range Extender 6 (ZW117). Both the ST Hub and my ideal location for the Extender are in the basement, but mounted to the floor joists for the kitchen. Other than plywood, hardwood flooring, and drywall, there is nothing mechanical, electrical, or electronic in the intervening distances that might block the Z-Wave signal.

The whole point of my wanting to install a Z-Wave Range Extender was to enable the pairing of two (2) GE/Jasco Z-Wave #14292 In-Wall Smart Switches mounted in the mud room, adjacent to the kitchen, that seemed just out of range of my ST Hub. They are located approximately 34’ from the Hub, but with a greater number of walls and a tile floor intervening. Although my original location for the Range Extender in the basement just under the kitchen floor would have been more equidistant between these two (2) Smart Switches and my Hub, I figured that the location of the Smart Dimmer was close enough for government work.

The GE/Jasco #14295 In-Wall Smart Dimmer paired with my SmartThings v3 Hub without incident. It is located about 11’1" from my ST Hub and 20’10" from the two (2) Smart Switches in the mud room.

N.B. Any discrepancies in these measurement noted by those trying to add up the various distances I give are the result of devices mounted at different elevations (floors).

The two (2) Smart Switches in the mud room are mounted in positions #1 and #4 of a standard 6-gang electrical switch box, so they’re about 5½" apart. The other devices mounted in this switch box are normal old S.P.S.T. Leviton toggle switches.

This is where things get more interesting (frustrating)! … and also explains why I have been emphasizing that there are “two (2) Smart Switches” in the mud room that I am trying to pair with the Hub.

Initial attempts, made about two weeks ago, to pair either of these Smart Switches to my ST Hub failed, probably because of distance and intervening building materials. On Wednesday, when I tried pairing the Smart Switch in gang #4 with the Hub, probably routed through the newly-installed Smart Dimmer, it paired with no problem. However, when I then tried to pair its neighbor in gang #1, the pairing failed. Numerous additional attempts to pair this Smart Switch with the Hub also failed. Now, remember, this second switch is about 20’10" from the powered & paired Smart Dimmer and 5½" from the powered & paired Smart Switch to its immediate right. (Comments also welcome on this situation.) Oh, well. Back to the Range Extender.

Thinking that there might be some sort of manufacturing glitch at play here, I went out and purchased four (4) more of the Aeotec Range Extender 6 (ZW117) from two (2) separate sources. All five (5) failed to pair with the ST Hub despite numerous attempts to do so. In each instance, the ST app initially indicated that pairing was “30%” complete, then eventually timed out and stated that the pairing attempt had failed.

Per @JD’s suggestion, I ran a “Repair” function on my ST network. The only information revealed at the conclusion was that a Smart Switch in the living room (which is at the total opposite end of the house from the kitchen) was unable to establish a new route to the Hub. Since the Smart Switch in the living room has been working perfectly for the past few weeks, I didn’t think that this notification was of any consequence.

Per @Kianoosh_Karami’s question, there is no “custom DTH” installed on the Aeotec Range Extender 6 (ZW117). All I want it to do is extend the range of my Z-Wave signal from the Hub in the basement to the Smart Switches in the mud room.

(And, please, don’t anyone get hung up on the fact that the Hub is mounted in the basement; it’s only about 11" below the wooden floor above.)

I am reaching out to the folks at Aeotec (Aeon Labs) regarding the above issue with their Range Extender, and will let everyone know what they have to say.

1 Like

HOLD THE PHONE!!! After posting the above comments to this conversation, I was inspired to go to the mud room and make another attempt to pair the remaining unpaired GE/Jasco Z-Wave #14292 In-Wall Smart Switch with my SmartThings v3 Hub. I followed the same process as I did on Wednesday,; however, this time the Smart Switch paired immediately! It must be the phase of the moon or something!!!

This successful pairing of the two (2) Smart Switches in the mud room eliminates the need to pair the Aeotec Range Extender 6 (ZW117) with my SmartThings v3 Hub. However, as a matter of principle, I will continue attempts to successfully do so and advise results.


Would you please send me your hub ID to me via PM?

1 Like

S/N is on its way.

I’m also having trouble getting this extender linked. I’ve lost count as to how many times I’ve tried over the past 3 weeks. And I know it’s almost synced as every time it fails or the hub doesn’t see it, I go and exclude the extender, and it says that it excludes it. And I’m back to where I’ve started…the extender is back to changing colors. I’ve tried both apps and online…followed the directions based on the apps of ST and the Aeotec manual. Other things that I have tried that I didn’t see above was rebooting the hub, repairing the z-wave network, removed the power & batteries (for 60sec) and put the extender in multiple places including 10 feet away with nothing obstructing it. I bought the 2 pack and have tried both of them.

Any help would be awesome.

Please let us know if you solve this issue Kianoosh. As you can see from this thread it’s not just Bill have the issue. Do you need my serial number too?

Same issue. Device indicates it is pairing correctly, Smartthings app never recognizes that a device was added, just continues searching. Device never shows up in the devices list. Can exclude device properly.

Aeotec Range Extender 6 - ZW117-A01
Smartthings Hub v2 US

Tried both classic and new app. Same results.

Edit: Sent email to Aeotec support and linked this thread.

1 Like

Must be a recently created problem.

I’ve got 3 of the Aeotec Range Extender 6 devices in my Z-wave mesh, US version 2 hub. All paired easily and work great.

I added the last two probably two months ago, so a couple of hub firmware revisions back.

Well I have two that will not sync. Today I decided to factory reset the ST hub. Tried several times adding the extender first…no luck. Added everything back that was there before without issues. Then tried the extenders again, no luck. Tried both in multiple locations. Nothing. Frustrating.

Has anyone told Aeotec? Seems they have a vested interest in getting this fixed.

I have not.

Any update please @Kianoosh_Karami?

Aeotec is aware of this issue and have tested and reported the issue to SmartThings support. It has been confirmed by unpairing and pairing back a range extender 6 (paired mid 2018) that was working and shown in the network, then unpaired/re-paired on 9/5/2019 noting the issues that many are seeing now where the Range Extender 6 LED shows that it pairs via its LED status, but SmartThings does not list the device anywhere.

At this time the best course of action is to reach out to SmartThings support which will increase priority of resolving this issue.

You’ll go through unpair/pair process and forward any screenshots they ST support will request. Aeotec are doing the same thing currently.

1 Like

I raised issue with Aeotec support and they replied with the same message. They are aware of the issue, are able to reproduce the issue, and have escalated it to SmartThings support.

1 Like

1 Like

Just received the below firmware update notification. Fingers crossed it includes our fix.


© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.