Actions not showing in Harmony Hub Control

I’m getting the same result. For some reason it’s not working with a virtual switch, but does work with a real light.

Yea, that can’t have anything to do with the harmony integration, Neither ST nor Harmony can tell the difference between a virtual and a real switch. I’ve got virtual switches in ST that I include in Harmony activities, I can think of no reason the reverse wouldn’t work, don’t think that problem is related to the harmony app.

You’re right. My stupid mistake. Had a device type selected that didn’t publish it’s events, so Harmony Connect had nothing to respond to. It’s all working now.

@thegibertchan - just wanted to let you know this seems to be fully working for some of us.

You are the lucky fews. It does “NOT” work for majority of us. We do realize that it’s still in the labs. As for the unfortunate ones, we cannot even add the hub to our “things” as was stated earlier.

Me personally I don’t care about the integration as I only use the harmony for A/V functions but there are plenty in the community who would really appreciate the integration and bought the harmony homes thinking that the integration will work at some point.

Ron, I don’t think in my case luck has anything to do with it.
I know you read my post on home networking tips, this thread (and maybe another one) were the incentive to spend the time on that.
Anyway, software is software, and since the latest software works for some of us, that only leaves hardware/networking issues as the differences between the haves and the have nots.
Maybe the have nots are stuck in some networking edge case, that should be handled by the software but isn’t, I don’t know.

All I can tell you is how my net is set up, and that the integration is not universally broken.
If it works for me, and a few others, there’s no reason it can’t work for everyone that’s having issues.

Unfortunately, this is one of those crossover areas, where does ST/Harmony support end?, who’s ultimately responsible for my home network?, How many edge cases exist, and how many of these is ST/Harmony responsible for?

@Mike_Maxwell please don’t get me wrong. I am not at all complaining. :slight_smile: just trying to point out that after the latest harmony update, you will not be able to use the integration if you have not already had the hub recognized in the app. It used to work fine for me too but i was stupid enough to remove it for some reason. And I honestly I don’t use harmony with ST and don’t even intend to.

And if someone claims and sells the integration, they are very much responsible. Not all users of this integration is going to be creating virtual switches, IFTTT triggers and what not.

And as far as it if it works for you and there is no reason it should not work for others… We are all not geniuses. Some of us are just plain and simple users.

I agree, “they” are indeed responsible for the integration, but the condition/configuration of a network infrastructure?, particular one in a residential environment?, I can’t hold any device vendor/software integrator responsible, even the ISP I pay every month…

@Mike_Maxwell I so do look up to you and learn.
in this case I am not sure it’s my home network. I have three airports spread across the house on fixed channels wide enough not to overlap. Two of them are in bridge mode (connected via Ethernet to main base station). All device MAC addresses have their reserved ip’s. Sonos play 1’s reliies on Sonos BOOST SonosNet which is far away in the basement connected to one of the routers over Ethernet and ST and harmony hubs are all on different floors.

The ST app very much recognizes the hub thru connect. When you click next and select device (any device) does the device unauthorized, general exceptions etc. comes up. This is only after the last harmony update which ST support is aware of and in talks with Logitech as per @thegibertchan. If I had not stupidly removed my hub from connect “after” the update, it would have worked for me by changing the port on it which ST had done for me earlier. They have been extremely helpful and in fact i told them not to bother fixing the port EVERYTIME as I would much rather wait for the full integration as I don’t use the integration.
The issue that we are facing now is that you cannot use the integration at all as you cannot add the hub to the things AT ALL after this harmony update.

I emailed support about this looks like the new harmony firmware on the home hub broke the API. IFTTT and Smartthings does not work for me at all with alot of other people. Mike what firmware are you on 4.2.8?

Yes, 4.2.8, the API can’t be broken, I’m using it.

Now maybe adding a hub from scratch is broken, which is what Ron has observed. If you can connect to the hub (via ST), the remainder of the API works.

I’m not going to delete my hub and try to re-add it to prove Ron’s point, that’s for sure.

Here is the email from st support:

Tyler Lange (SmartThings)

Dec 31 12:45 PM

Adrian,

Logitech has confirmed that they made changes on their end that broke their API for partners like us and IFTTT. We’re working on correcting the problems but I don’t have an estimate yet.

Thanks,

Tyler Lange
SmartThings Support

Interesting, it must be adding a new harmony hub that’s broken, cuz the dang thing is working bi-directionally for me. I’ve even added/removed devices to the integration since Harmony’s “upgrade”…
Is ST fixing the issue, or is Harmony?, if the latter, I wouldn’t hold your breath…

@Mike_Maxwell We all love you no matter what I say behind your back! :wink: we are all friends ! Hehehehehehe! As a favor please please remove your harmony hub from the app and give it a shot! For the sake of this community. :wink: nah! Kidding!

If this is what u see don’t panic. Support is aware of it.



Hmmm, let me think about that… ahhh, no…

I can confirm adding a new hub is the issue. My first hub was working fine and last night I added a second hub and got the same Device Authorization error. Didn’t see this thread, and deleted my original hub which was working and now can’t add either back. Wonderful. The good news is I use the Logitech -> ST integration to program the physical buttons on my remote and that still works.

I’ve not seen mention of this problem over at the harmony forums, I would raise a stink over there regarding this issue as well.
You may at least get an acknowledgement from the mods regarding awareness and expected resolution.

Is there a solution yet to Harmony Hub not being found? I can control Smartthings through Harmony but not the other way around since hub is not found…

Any update on this, I’m having the same issue adding the hub to smartthings as everyone else

No update. Logitech emailed me last night apologizing for the delay and said to use IFTTT as a workaround. Little do they know that IFTTT is very limited with ST.

Awesome workaround, a if Harmony’s built in IR delay wasn’t long enough already…