ActiON Dashboard 4.6.3 is here! (Now

I updated the code. There was a typo for momentary and camera.

Did you do something different @sjones0812 on your install? I am still getting the same Error on the last step.

The default tile size is 120px. The width of iPhone’s screen is 320, therefore 3 tiles don’t quiet fit.

You can try to adjust tile size a little bit. Append “&t=120” at the end of your URL. Play with 120 value a little bit, you can go up and down.

I’m still getting my previous behaviour. And only way to get the smartapp installed is to reset the Oauth token on the last step but then i get the errors below. Otherwise on the last step i get the following error from the ST mobile app:
“Error: Unexpected error occurred.”

@625alex It seems if i remove the “power meter” tiles I am able to get to my dashboard. Once i add a “power meter” tile i get these errors again:

URL provided by the logs I get the following error:{“error”:true,“type”:“java.lang.NumberFormatException”,“message”:“An unexpected error occurred.”}

And from the logs I get the following error: java.lang.NumberFormatException @ line 387

So removing “power meter” tiles allows me to get to my dashboard.

Thanks Alex. That was easy and on the smaller devices, “&t=105” gives three tiles per row and doesn’t look cut off or crowd the tile. Looks good.

@storageanarchy, @huydnguyen, @sidhartha100, @B_Ferguson

Your symptoms are consistent with not enabling OAuth. I just tried to install a brand new instance without OAuth and I see what you see. Some people obviously installed it successfully.

Please try the latest copy of the code. I shuffled some code around so that if you have an OAuth exception it will be ought and more obviously displayed in the logs. Also, try to install with no devices selected.

I was sure to enable OAuth everytime. So far it seems if I don’t use the “Power Meter” tiles, I am able to access the dashboard.

Edit: Also only way for me to get passed the last step in the iOS app is to have the “reset Oauth” switch to enabled and then it seems to install. So it seems I encountered two unrelated issues.

  1. need to reset OAuth for the app to install
  2. remove “power meter” tiles so I can get to my dashboard

Definitely have OAuth enabled, and I CAN get it to install if I set the switch to regenerate the token.From there, I haven’t had the Unauthroized issues…

regenerate token also worked for me.

How did you get your Ecobee’s in the dashboard? I didn’t see that in the options. Thanks!

Thanks, makes perfect sense…I’m using just defaults so I see icons instead of words.

Changed line 303 from w2 to w1 (line moved…you must be editing :wink: )

Thanks again…

On the last step of installing the app on the smartphone, toggle the reset AOuth access token.

Click done, then go back in and turn off Reset AOuth.


Can I copy paste this code over v3.0 ?

I upgraded exactly that way without any issues.

What is the dropcam streaming URL? Does the dropcam have to be a public cam?

I just updated the docs.

In order to display a Dropcam stream, your camera must bu public. This is the only way to display a Dropcam stream.

Login into your Dropcam account and select the camera that you want
to add to the dashboard. Click on Sharing > Public. Click on “Make
Public” button.Copy content of “Embed Video” box to a text editor.Inside the block of code there will be a URL that looks like
Copy this URL into your SmartApp.

Bummer, but it makes sense since there is no way to enter credentials through the URL.

1 Like

This is what I thought. Don’t think I want to make my streams public. Nice added feature but currently don’t want to put my baby’s crib public :slight_smile:

Alright, this was a rough start, I apologize for that. We are getting there.

I must’ve been out of it last night when I was trying to merge and clean up code. I was rushing it because I wanted to release this before Christmas, so that the Holiday Light feature would be relevant.

Here are the issues we encountered so far:

  • Documentation - updated
  • Dimmers - fixed
  • Image capture - fixed
  • Momentary button - fixed
  • If you encountering errors during installation you either
  • Didn’t enable OAuth when you installed the app
  • You tried to install via the IDE and you didn’t get to the end of SmartApp preference selection and clicked “Installed” rather than “Done”
  • Done everything right and some other weird thing crapped out. In this case try to set “Reset OAuth” in app preferences and then go through preference selection once more and then unset this option.
  • If it’s something else, let me know
  • If you think your tiles are too small/big you can try to change this from the default target size of 120px. To do that, add “&t=120” at the end of your dashboard’s URL and play with the value to see what works best for you. If you are using a desktop browser you can also use zoom in/out.