Ability to turn off lights after x minutes of no motion is missing

Totally agree @ogiewon, a lot of functionality has either moved around too much or lost in my opinion. I have 11 motion sensors in my house doing a lot of automation, and the loss of functionally from the previous Dashboards is causing me more effort to do the same thing, or to develop my own work arounds with custom smart apps.

Luckily all my previous Dashboards are still there. Until ST does a lot more with the new lighting automation tool, I have no plans to convert over.

2 Likes

Right, but you must enable the motion sensor to turn on the light.
What we’re looking for is “turn off after motion stops for x minutes”, without having the motion turn the light on.

3 Likes

If you follow the steps I outlined, you will see that there is no slider that reveals the minutes field. That slider only appears if you are creating a “Turn On When there is Motion and then Turn Off When Motion Stops” scenario. The slider disappears if you want something that is already onto turn off when the motion stops.

The bedroom lights are always getting left on, so I want them to turn off automatically after a certain amount of time when no motion is detected. This is no longer possible in the new app.

1 Like

Got it, my bad, I misread your original post.

Yes, you’re right, that just looks like a bug. The minutes field appears if you “turn on after no motion” but the minutes field does not appear if you “turn off after no motion”.

I would report it to support@smartthings.com

But the minutes field is just missing for the off option:

Glad someone already posted this…I was just about to post up on this as well. Just as an extra use case…I need a separate turn off even that is reliant on no movement after a period time but only in certain modes.

In my den where we watch tv, we may not move enough or fidget enough over five minutes to kick off the sensor so the lights would go off. My work around was my harmony remote, whenever we turn it on, kicks off a virtual switch that changes my mode to “TV time”. During this mode, the turn off even won’t fire. Since I have a different turn off event, I can’t use a delay. Now they go off very quick if I walk in and out of the room.

Really would like to have that option back ASAP!

It used to be called “Light Power Allowance” under the green living smart app which has been removed. I’m looking for the same thing here. No sensors involved just manually turn the light on and have it shut off after x minutes.
[/quote]

1 Like

Light Power Allowance is missing also. The other missing feature is to select how many minutes after motion stops to turn something off. There is no input for minutes in that case in Smart Lights. That’s an omission that should be fixed. I would assume that turn off after some time missing is an oversight, and they should fix that also.

I just wrote two very small apps to do these two functions:

For Turn off after motion stops:

For Turn off after some minutes:

8 Likes

Thank you Sir! I was really hoping that ST would have put this in Smart Lighting for local processing.

1 Like

I think both of these functions missing are just oversights on their part. Write to Support, complain, explain, etc. These are super easy for them to add to Smart Lights, but they need to hear from us to do it. :grinning:

1 Like

Bruce, thanks for the code! Worked perfectly and I am back in my happy place again. Please post for others as I have seen this requested much since the upgrade.

1 Like

Hi Bruce,

I’ve installed turn off after motion stops and it doesn’t work at all. Any idea what I could be doing wrong?

Thanks,
Joe

Any more specifics? The lights just don’t turn off? I tested it before I posted it, I will run another test now and report back.

Pretty much. Using a single motion sensor on a single outlet.

I’m also using smart lights to turn the light on, and the built in “off after” doesn’t work either.

The app works for me. There must be something else going on in your setup, especially if Smart Lights is failing also.

Thanks for checking.

I really can’t see what it could be.

Smart Lights works if no delay is set. So motion on, no motion off is fine. It’s just when I want motion on, no motion for 5 minutes the light doesn’t go off at all.

The sensor, outlet (light) and 1 door sensor are the only things I’ve got connected.

What type of sensor is it? You can turn on Live Logging in the IDE and see if that sensor is throwing the motion inactive event as it should. That should happen within 10 seconds of motion stopping.

The standard SmartThings one.

It’s definitely throwing the inactive event.

23:13:34 BST: debug Parse returned [name:motion, value:inactive, descriptionText:Living Room Motion Sensor motion has stopped]

Evidently, runIn() scheduled events are failing in the UK. Several different reports of this, and that’s what’s failing with this app also, in the UK.

The problem I’m having with this feature (turn off lights after x minutes of no motion) is that it doesn’t seem to be working properly – or at least not the same way – after my switch to hub v2.

I have several lights in hallways set to turn on with motion, and then turn off after 2-5 minutes of no motion. This all worked perfectly fine under the old hub/app.

Now, this use case is biting us all the time, because the new one doesn’t handle it right:

  1. Person walks into dark hallway. Motion is detected; light turns on.
  2. Person leaves hallway; motion sensor registers “motion stops”. A timer starts (presumably), let’s say this one is set to turn off after 2 minutes of no motion.
  3. Person re-enters hallway 90 seconds after the “motion stops” event. 30 seconds later, the light turns off, even though there is now motion detected in the hallway because someone is in it.

Lights turning off while there’s motion active has been driving us absolutely bananas since the hub v2 “upgrade”. I presume this is because there’s some logic error in the new Smart Lights app in which it doesn’t reset its timer/unschedule the lights off command if motion is detected again before the motion stop timer expires.

I have looked through several threads about the new buggy Smart Lights app but I haven’t seen a peep from Support. I’m not going to install a non-blessed SmartApp to “fix” this because then it has to execute in the cloud, which totally defeats the purpose of Hub v2. Given that lighting is probably one of the most commonly automated things, I imagine the scope of impact is significant. @Ben can you provide any insight?

I thought the purpose of Hub V2 was to automate your home. Most things are going to execute in the cloud anyway. Smart Lights is the exception. Except, Smart Lights has some issues, not least of which is a bug that messes up motion controlled lights. “Non-blessed” smartapps work, which the “blessed” Smart Lights does not.

You can wait until ST fixes Smart Lights, and do without automation in the interim. Or check out Motion Lighting: Motion Lighting. No matter what, if you want motion controlled lighting that works NOW, it’s going to run in the cloud. Once they fix Smart Lights, small matter to remove one and replace it with the other! :grinning:

3 Likes