ABC - Advanced Button Controller - Newest Edition

I’m not using the new ST app. How do I add the device handler for ST Classic? I can’t be the only person trying to do this.

Well. Classic app is soon dead. Just install the new app and install the device from there. No problem at all…

1 Like

You have 8 days lol. Might as well get it in the new app via IDE.

I have installed ABC button controller but when I open the app its says “No devices found”. I am using the latest ST app and ABC. I have an Inovelli Red on/off switch. I can see it in the ST spp and Alexa but can’t find device in ABC app with ST. Any help would be appreciated. Thx

Did you load the Inovelli Red Series DH? The switch may not be exposed as a button without it.

I fixed the issue. The DH I had installed was incorrect. I installed the DH from Inovelli website and it worked. Thx!

2 Likes

Brilliant, thank you for the update

Are there plans to add functionality to trigger scenes to ABC?

Hi Kyle, I will be looking at the app again shortly to see what changes need to be made to bring it up to the new app standard. Unfortunately, it is one of my minor projects but I will attempt to find some time for it in the next month or 2 and bring together a new version.

Paul ET all
I’m not sure if the app was updated but anything on my question about using the dimmer the way I put it with IFTTT?

Hi

I am using ABC with an IKEA Tradfri 5 button. I’ve got the dimming working but can’t work out how to set the buttons so that they will cycle through colour. Does this smart app do that or is there something else I should be trying.

I’m still pretty new to all of this so still learning!

Thanks for any help!

Hi

At the moment colour temp (white level) is working, I’m not too sure on RGB yet but will look at this to see if its something that can be easily added

Paul

At the moment colour temp (white level) is working, I’m not too sure on RGB yet but will look at this to see if its something that can be easily added

Wow, thanks!

How do you install it? I copy the code but get this error:

No signature of method: script_app_metadata_d30c7531_323b_4a7c_aeb3_74aabbfabc29.metadata() is applicable for argument types: (script_app_metadata_d30c7531_323b_4a7c_aeb3_74aabbfabc29$_run_closure1) values: [script_app_metadata_d30c7531_323b_4a7c_aeb3_74aabbfabc29$_run_closure1@34c67aa] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

Why like this?

For some reason I can’t find a new Scene (still called a Routine in the ABC app) to assign to a button push. I see the older routines that I’ve created from the old ST app pre-migration, but I’ve also created some new scenes in the new ST app, but I can’t see those in the list within ABC. I’m running ABC version v1.200505, which I believe is the latest version. Is there something I’m missing?

EDIT: Scrolling further up, I see that this question was already asked. I guess it doesn’t work yet with this version? Hopefully you get some time to update Paul! :slight_smile:

is there support for the new RGB dimmers and switches? specifically the leds. i would like to have the leds glow red when the home monitor is armed. (edit: thru webcore)

i’ve tried updating my ABC code (cut/paste/save/publish), but i get a java error. do i need to completely remove the old app and reinstall?
trying to save child creator “java.lang.RuntimeException: Metadata Error: Parent SmartApp ‘paulsheldon:ABC Manager’ not found”

Hello,

The new ST app changed one of my routines to a scene and now the button stopped working.

I noticed here in this thread that this is a known issue and will be looked at. The time that was announced is nearly over and I wonder if this can be fixed or should I create a virtual switch and core piston as a workout?

Thanks,
Markus

1 Like

Hi,

Sorry for delays, too many projects & work stuff. I’m off over Christmas so will attempt to look into any outstanding issue during that time.

Paul

Please add any issues & requests to GitHub , those will be done first and then any within this thread.

Issues · paulsheldon/SmartThings-PS (github.com)

Paul

The same happened to me. The timing of the change lines up with my controller being updated to 0.34.09. As recently as earlier this week, the button controller was calling the routine/scene without error.
I created two “Automations” to replace the two buttons that were generating errors, which is far from a perfect solution, so I will have to find a better fix later.