SmartThings Community

3A Nue RGBW strip controller with normal RGBW led strip lights: Manufacturer’s DTH

dth_lighting
project_lighting

#85

Hi Robert,

You can just select device Type - ZLL RGBW Bulb and version - Published. If still not working, please let me know.

Regards,

Kevin


(Joseph Conforti) #86

Just and FYI. I’ve been using this DH and it works flawlessly and gives better options and control. I like how it allows me to set the default power on status and gives me some cool fade/pulse/blink options.


(Davin K Dameron) #87

I’m having an issue with these. The issue is very similar to the Sylvania garden Spot issue I was having before updating their firmware. I can turn the lights on and control the color, but sometimes I can’t get them to turn back off. The only way to turn them off is to reset them. I’m using the device handler 3A NUE ZigBee RGBW Light. Same issue when using the osram one.

I also tried pairing these to my lightify hub, but it finds no updated firmware.


(Davin K Dameron) #88

To add more information…

After dimming the lights and then brightening them again, I can now turn them off. Some kind of weird firmware bug here. I’m thinking I’ll return these unless there’s better firmware somewhere.


#89

I recently purchased two of these controllers. I am unable to get either to pair with my ST v3 hub.

The hub has OTA enabled for all non-light devices and Unsecure Rejoin is true.

I have reset the devices and power cycled the hub, but nothing seems to work.
Any advice would be greatly appreciated.


#90

Hi Alan,

How far is it between the controller and the smartThings Hub? Please send your smartThings account and temporary pw to my email 3aSmartHome@gmail.com so that I can have a check for you.

Regards,

Kevin


#91

Email sent.

The controller is currently about 2ft from the hub in the same room .


#92

It should work fine. Please check your setting and select the device Type - ZLL RGBW Bulb and version - Published.

Regards,

Kevin


#93

Thanks for looking. I did manage to get them to work.

The issue seems to be the app I am using. All of my devices are iOS based, and the app seems to behave a little different.

This is what worked for me.

  • Under Devices , click the “ + ” button to add a new device.
  • Click Add Device Manually
  • Select Light Bulb.
  • Click Add next to Belkin WeMo (others may also work, but this is what I used)
  • It will then start a new search and identify the 3A controller as a “Thing”

Thanks again.

Alan


#94

Yes, you can set up this way. Thanks for your update.


#95

@3asmarthome - I’m not much of a coder bu i have taken your base code and added some of the extra buttons from the DH that @JConforti provided, it didn’t work for me but i liked the extra features.
It is a bit of a mash up and could use some proper development but it does work and now i have colour cycling, flashing and default colour options.

I have put it on github https://github.com/banditkd/SmartThings/blob/master/3A%20NUE%20ZigBee%20RGBW%20Light-banditkd so you can have a look.

obviously open to anyone that wants to try it - but no guarantees it will work :slight_smile:

Thanks

Mark.

p.s. i’m only using an RGB strip so haven’t included the white option yet


#96

Hi Mark,

You do not these code anymore. You can just edit the device by selecting Type - ZLL RGBW Bulb and Version - Published.

Regards,

Kevin


#97

Hi Kevin

I have tried all the ZLL and Zigbee device handlers and none of them will control the LED strip, they won’t even turn it on or off.

Hence me using this device handler

Regards

Mark


#98

Hi Mark,

It seems that you did not pair it correctly. Please delete the device, reset and pair it again. After that, if it is still not working, you can send me you smartthings account and a temporary pw. I will have a look for you, then you can change the password.

Regards,

Kevin


#99

Hi Kevin. I did get it to pair but there are no options for colour cycling, default colour etc. So I reverted to your original with my additions.

I’ll leave my version on githib just in case anyone else wants to use these functions.

Thanks

Mark


#100

Hi Mark,

The SmartThings Device handler does not include the colour cycling function. If you can add the code in the Device Handler, it will have the cycling function.

Regards,

Kevin


#101

Hi Kevin. I was aware it originally didn’t include these options so I added them and put the code on gihub for other people to use.

Wasn’t sure if you were actively developing this DH but as you are suggesting people use a standard zll DH I suspect not.

So I’ll leave my copy in place in case anyone else finds it useful

Thanks

Mark


(Davin K Dameron) #102

@3asmarthome

I have 2 of the RGB controllers. One of them works ok, one doesn’t. The one that works shows up in the IDE with the following “Data”.

application: 01
endpointId: 0B
manufacturer: FeeBit RGBW
model: FB56-ZCW20FB1.2

The one that is not working shows up in the IDE with this “Data”

application:
endpointId: 0D
manufacturer:
model:

I’ve tried removing and re-adding several times.


#103

Hi,

For the one showing endpointId: 0D, it did not pair with the smartThings Hub correctly, please reset and pair it again.

Regards,

Kevin


#104

Hi Mark,

I will update it ASAP.

Regards,

Kevin