2Gig Hub not being recognized as a secondary

I’ve read multiple posts and I believe I have been following the correct instructions to try and add my 2GIG panel running V1.19.3 firmware: reset, add device on smartthings, learn controller on the 2gig and it almost works BUT the 2GIG sees all my devices but can’t communicate with them and the smartthings hub reports a new dimmer switch has been added. The two devices were inches apart and left them for hours to sync. IF any one has any ideas the config of the device that was added is:

  {
        "deviceId": "d943ec78-8db5-4728-b445-9daa9f68decb",
        "ownerId": "9551f7d5-3f19-ae55-dc91-7dbe92bf620f",
        "name": "switch-binary",
        "label": "Hub",
        "deviceManufacturerCode": "009B-1000-1001",
        "manufacturerName": "SmartThingsCommunity",
        "deviceModel": "1000-1001",
        "presentationId": "74cf66e1-ae7f-3a14-a6a8-1affef9ec321",
        "locationId": "36fd4a6a-bea1-4eb6-b8bd-c62e8388c02c",
        "roomId": "4dd2c564-4e2a-4dbf-bff8-5be8fc46b0f2",
        "sharedLocations": [],
        "components": [
            {
                "id": "main",
                "label": "main",
                "capabilities": [
                    {
                        "id": "switch",
                        "version": 1
                    },
                    {
                        "id": "refresh",
                        "version": 1
                    }
                ],
                "categories": [
                    {
                        "name": "Switch",
                        "categoryType": "manufacturer"
                    }
                ]
            }
        ],
        "createTime": "2024-06-21T21:00:16.360Z",
        "parentDeviceId": "f28e86dd-4f35-457a-9ca6-e3cf222d4e9a",
        "profile": {
            "id": "24598736-00b5-3c83-af9e-f79857f1121a"
        },
        "zwave": {
            "networkId": "3B",
            "driverId": "2cbf55e3-dbc2-48a2-8be5-4c3ce756b692",
            "executingLocally": true,
            "hubId": "f28e86dd-4f35-457a-9ca6-e3cf222d4e9a",
            "networkSecurityLevel": "ZWAVE_S0_LEGACY",
            "provisioningState": "PROVISIONED",
            "manufacturerId": 155,
            "productType": 4096,
            "productId": 4097
        },
        "type": "ZWAVE",
        "vid": "74cf66e1-ae7f-3a14-a6a8-1affef9ec321",
        "mnmn": "SmartThingsCommunity",
        "ocfDeviceType": "oic.d.switch",
        "restrictionTier": 0,
        "allowed": [],
        "executionContext": "LOCAL"
    },

The SmartThings platform calls something a switch if it doesn’t know what else it is and it’s fine if it does – – the secondary hub itself just needs to be on the same zwave network. It’s going to do all the work, so it doesn’t really matter what SmartThings thinks it is.

As far as the 2 gig hub Not being able to communicate with any of the devices: which devices are they? Specific brands and models. It’s very common for both locks and batterypowered sensors not to be passed along to a secondary hub, for example. :man_shrugging:t2:

1 Like

Also, have you had a chance to read the community FAQ? It’s a couple of years old, but still applies:

FAQ: Zwave Secondary Hub Basics

1 Like

When the 2GIG was first installed in 2016 I added two Schlage locks and a Leviton dimmer switch to act as a network bridge for the lock on the front door. In 2021 I added two Minoston smart plug and a couple of Ultra Pro Light switches to control my holiday lights. These all worked fine with the 2GIG as primary controller.

Most recently I wanted to use the Minoston 800 scene controller which I could add to the 2GIG and didn’t cause any issues but the 2GIG had no way to tigger a rule when a button was pressed, so I added the Aeotec Hub, a bunch more UltraPro switches (Some on-off, some dimmers), 2 Leviton Fan controllers and some Zigbee smart buttons which I assume don’t come into the equation. I removed all the existing zwave devices from the 2GIG using the device exclusion procedure and included them into the smart hub. I then tried to add the 2GIG as a secondary, when that didn’t work so I wondered if the Minoston scene controller was the issue. I excluded those from the smartthings hub, reset the 2GIG and tried again. One of the smartlocks appeared correctly but nothing else. As far as I could tell they were ingested into the 2GIG but had “unknown manufacturer” and any attempt to use them would fail.

Since writing my original post I’m wondering if the advanced security is the issue I set up all the devices using the DSK as a PIN as smartthings prompts you to do. I’m also wondering if I even need to make the 2GIG a secondary controller? Having the 2GIG automatically push alarm codes to the door locks was nice but it’s not like I change codes often and I can use Guest Codes, it’s just two steps rather than one. The three things I’m missing are:

  1. I would like is to be able to check the alarm status in routines but I think the alarm.com edge driver should get close.
  2. Turning on a light when a door opens, I can probably make do with turn on the light when the door is unlocked.
  3. Turn off a lamp when the alarm is armed stay, it’s on from sunset to remind me to set the alarm. Maybe the 5 minute delay will work or I use one of the scene controller buttons to set the alarm and turn off the light.

I’m sorry, I’m really tired today, but I’m confused by this explanation.

You had 2 zwave controllers, right? A 2 gig one and an Aeotec “works as a SmartThings hub“ V3.

Which one do you want to use as the primary?

Which specific devices are connected to which hub?

When you add a secondary hub to a zwave network, it must have no zwave devices connected to it. None. Then, at the moment that it joins the network owned by the primary controller, the primary will give to the secondary a list of the Z wave devices that are currently connected to the primary hub.

Any devices that you add to the primary after the initial join by the secondary, will not be described to most secondaries.

Devices that you add directly to the secondary are usually described to the primary, but not always.

And locks can only belong to one hub or the other, because of the security requirements. So a secondary Z wave controller cannot send commands to a lock that belongs to the primary controller.

I can’t tell from your description if that’s the process that you followed or not. :thinking:

The Minoston MR40Z Will work with a custom edge driver with SmartThings, but is a central scene device. It is likely that you will only be able to use it with devices connected to the primary hub after it is also connected with the primary hub.

https://products.z-wavealliance.org/products/4246?selectedFrequencyId=2

Hi JD,

I have two hubs, I removed all devices from the 2GIG and added them to the aeotec. I am now tring to make the 2GIG a secondary using the procedure:

Reset the 2GIG
Add device in smartthing
Learn controller on the 2GIG

The two hubs are inches apart and I left them for 24hrs

Smartthings reports that a dimmer switch was added and the 2GIG has all the devices but there is no info, trying to access them fails with “could not communicate with device”, and I have tried reset network multiple times.

If you added the devices using S2 security, then that is the expected behavior because the secondary hub doesn’t have the encryption key for the secured messages. Same problem as with zwave locks. :man_shrugging:t2:

That was the conclusion I can to as I was writing my reply. I guess my final question would be is the S2 security worthwhile for light switches since the smartthings app seemed very insistent that I should enable it and can I disable it without excluding and including all the devices?

That’s two questions. :grin:

is the S2 security worthwhile for light switches

Not for most people. It’s a light switch. It’s not much value to a hacker. The exception is if you want to use it as the beaming repeater for a nearby lock. In that case it needs to match the security level of the lock.

Also, when you said “network bridge“ in your first post, I assume you meant “beaming repeater“? It would be very unusual for a light switch to work as a bridge for a zwave lock. :thinking:

can I disable it without excluding and including all the devices

If I understand you correctly, I think you are asking if you can change an individual Z wave device from using S2 security to using S0 security, and if that’s what you’re asking, then the only way to do it is to remove the device from your network and add it back in at the new security level. But you do this one device at a time. In zwave, different devices on your network can be at different security levels. The level for each device is set at the time that it joins the network.

JD,

Thanks for all your very prompt replies, yes I mean beaming repeater, I’m new to zwave so sorry I used the wrong term. The 2GIG gets upset if it can’t talk to all the devices it knows about so I’m thinking I’ll play with the alarm.com edge driver before I exclude and include all 20 devices.

1 Like

No problem, I was a network engineer before I ever got my first SmartThings hub for myself, so I tend to care a lot about little stuff that most people don’t care about at all. I just like to be precise to be sure we’re talking about the same thing. :sunglasses:

2 Likes