2 Zigbee keypads regularly going non-functional

That was my intention when moving the 1st floor Tradfri to the 1st floor ceiling, reducing the distance from 25 to 10ft. I just didn’t get as much improvement as I’d hoped. I’ll try reducing the hop distance even further.

1 Like

We use distance as shorthand, but it’s really signal strength. I can get six or seven times as much distance outside line of sight in clear dry air as I can inside a house. It’s all about the architectural barriers in between the device and the network. In some stucco houses you’re lucky to get 8 feet.

2 Likes

It is now clear that the zigbee heal is not affecting any routing. I now have 2 Tradfri Outlets with LQI over 100 that are skipped over physically and in routing in favor of connecting directly to the hub. I’m going to try and drop one from the mesh and add to affect routing.

LQI is on a scale from 0 to 255, so “over 100” May still be pretty bad. You’re aiming for values of 200 or higher there. What’s the RSSI?

https://docs.hubitat.com/index.php?title=Zigbee_Logs

Also, as I’ve said many times in the forum, it does take a lot of patience to work with mesh networks. They don’t rebuild instantly. You may not see the full results for 24 hours. (You also have to wait for ST to update their route reports, which are not real time.)

Run the heal, wait for the next day, then check the routes.

I know it’s super frustrating to wait in these kinds of situations, but it is what it is.

Again, thanks for the continued input. The RSSI of the new devices were -75 and -65. The one at minus -65 is 5 ft away from the hub in clear air.

The one at -75 had not been included in any routes even though the first heal was initiated 55 hours ago. All other RSSI are at the -80 to -88 range.

The other devices may not be able to reach it reliably, so they’re defaulting to the hub. :thinking:

You moved your WiFi to channel 6, if I recall correctly. What’s the Zigbee channel of the hub?

I moved the hub to channel 25 several days ago.

That should be OK unless your ruckus is doing Channel hopping, I haven’t looked at the specs on it.

I prefer Wi-Fi 11 and Zigbee 11 because that’s your maximum distance and it’s easy to remember, but six and 25 should be OK.

https://www.metageek.com/training/resources/zigbee-wifi-coexistence.html

Basically to fix it you need to start with the device closest to the hub and build a strong network out from there, don’t even think about the problematic ones Until you’re getting a good background.

In other words having one device close to the hub with really good numbers doesn’t help the other devices on the other floor if they can’t reach it. You have to have the whole chain looking good.

I know I suggested this before, so you may just have reasons why it’s not doable, but as a field tech, my next step would be to move the hub down to that lower floor and see if that fixes things. If it does, then you know it’s just a mesh strength issue.

When I adjusted the Ruckus I pinned it to 6, it is not allowed to channel float. My through the brick wall neighbors are pinned to 1.
Maybe my cordless phones are interfering more than I think they are. Much of what we are learning is leading me back to trying a zwave keypad. I’ll take a pause now and wait for the system to settle and see what kind of numbers my re-added devices have and how the routing adjusts.

1 Like

It may not fix it either, but did you try to see how the unsecure rejoint is configured in the Hub?
In this case it would be convenient to try Allow Unsecure Rejoin if you have not tried it.

That’s not going to affect the RSSI or LQI numbers, though, and so far those just haven’t been good enough for reliable operation.

1 Like

I agree with that.
I meant that when the device is disconnected, it can reconnect automatically and not stay offline.

The devices showed up faster than I expected. The Tradfri 5 ft away from the Hub in open air is reading LQI: 196, RSSI: -51. The one on the ceiling of the level below, 10 ft from the hub is LQI: 108, RSSI: -73.
I have only one outlet in between the Hub and the one on the ceiling. That will be the best I can do. I can not move the Hub a level down. Also, cordless phones are 1.9Ghz.

Hi @Mariano_Colmenarejo, I am currently configured for Secure Rejoin. I can try changing the setting.

With the latest version of the zigbee stack the metric calculation is performed every 1 hour.
In fact with this zigbee version, the routes that can be chosen by more than one path, change much more frequently than before. In my case even more than once a day, but everything works fine.

The zwave metrics calculate once a day or less

1 Like

Those numbers look good. (Again, with the understanding that 10 feet from the hub with a floor in between is not the same thing as 10 feet in open air.)

So now let’s see what we get for another Zigbee outlet in the same room but down at normal level not at the ceiling. The fastest way to get this result would be to reset the plug and then re-add it. If it picks the ceiling plug as its parent, then I think you’re on your way.

There’s no ceiling fan in that room is there?

Yeah at least temporarily turn that toff while you’re trying to fix things - unless you have a bad actor sitting outside your window waiting for you to turn it off to install his malicious Zigbee device… (It will help any zigbee device that has fallen off rejoin…)

Please follow the recommendations of @JDRoberts , I do not want to interfere with his very good recommendations, only provide some captures of a zigbee network working well, similar to yours with devices distance and the metric values.

When you interpret the metrics you have to take other things into account as well:

For a repeater “Router” device, (I think it should be closer to the device to be repeated than to the Hub):

  • With approximate values ​​of LQI: between 100 and 180 and RSSI: between -60 and -75: you will see metrics with very few errors, they work well.

1 Like

Yes, @Mariano_Colmenarejo , thank you, I wasn’t very clear. If the lower floor device which is the next device that we are working on connects through the device that we now have which has good numbers, then those good numbers will show for the last hop of the lower floor device. But definitely always you should be looking for the number of lost messages. :sunglasses:

2 Likes